Philips Android TV

Search This thread

fafafa44

New member
Jan 30, 2017
1
0
Hi I have the PML9506 model and the its firmware version is TPM211EA_001.001.233.026 . I saw a newer version on the net but my TV cant find it online and I couldnt find the link of the firmware. Its version is TPM211EA_R.101.000.124.200 . I am not sure its the latest one but I guess so. Would anyone share the latest firmware for the PML9506 please. Thanks.
 

Cpio

Member
Sep 30, 2007
6
0
Turkey
My problem is solved.
I bought a new USB Memory Stick.
I copied the same image file into it and it loaded and opened normally.
 

Alised

New member
Mar 23, 2022
2
0
Hi, I have a Chinese Phillips 32PHF6365/T3. As you can imagine everything is in Chinese and there is no access to the app store. How can I replace the current firmware by something in English or any other western language where the app store would be unblocked? Thank you very much. Alex
I have the dame issue, any idea?
 

Alised

New member
Mar 23, 2022
2
0
The OS and the controller of the TV really shocks me. Functions of install apps from local, network proxy are removed from system, and the controller doesn't have a "Menu" key -- only "Home" or "Settings". 嘤嘤嘤~
It is hard to find out solutions to install foreign apps because the app store is full of ads and some useless CHN apps. The settings interface is helpless as well because it only has few options about the system. I've seen there's some firmware for 8204/8105 series on the Internet. But I can't get their details to confirm whether I can flash it on my device.
I'll try to download the official recovery image and find something useful from it.
Maybe #3104 can be solved once we finished works on my model.

Additional Informations:
1. Chinese Philips TV's UI is very different from others. (I'll attach some photos later) Meanwhile, there's few Chinese geek interested in smart TV, so Chinese forum won't help us.
2. This model's CPU has 4 cores. A73*2 and A56*2, the RAM & ROM of it is 3+32GB.
3. Files from USB drive cannot be full showed directly from the system. Any files expect video, image and music will be hide.(Include .apk files)
Any progress?
 

ilijabt

New member
Mar 23, 2022
2
0
Need help with my 49PUS7909/12!!

hi

i was filling in some service menu codes i found on the internet, after that my whole tv got stuck and when i removed te power plug and plugged it back in the tv suddenly my whole lcd screen started to flicker..
When i boot the television the philips logo is looking normal and after that it begins again..

I allready tried recovery modus, factory reset and firmware downgrade to version AND1E_000.009.225.000.upg and upgrade it again but nothing works ?! Can't find anyone with this same problem..

See a couple of videos of the problem:
youtube.com/playlist?list=PLGMz1R-VIB0EdObB_1eCLjoRgGRUPTs2Q

my tv is just past his 3th year and i allready contacted philips but the guaranty is only 2 years and i can send it to repair but dont want to pay hunderds of euros for repair..

i tried some of this codes from this site before this happend
tips-trick-electronic.blogspot.com/2014/05/philips-tv-service-mode.html


The strange thing is when it boots it doesnt flicker even a couple of seconds in recovery modus and then the screen goes black and then the flickering starts.
It looks more like a software problem than a hardware problem but i tried al sort of firmware's and removal tools and put in again some service menu codes but nothing fixed this weird problem.:(

Please help me !!

Greetings
D.
hi
did you find solution, if you find please write to me
 

ol1ver

Senior Member
Jun 25, 2011
60
18
gitlab.com
Hey guys,

I'm looking into getting the 77OLED806/12 and before making my final decision, I'm interested in looking into the service manual for the TPM21.1E chassis. Anybody aware/have the service manual for this one yet? I couldn't find it yet. I am looking into the TPM18.1E atm which probably is somewhat similar, but would really like to get my hands on the specific service manual. My google-foo has yet evaded me and eserviceinfo.com doesn't seem to have it either (where I found the TPM18.1E one) ...

Thanks in advance.
 

GaricST

New member
Feb 8, 2021
1
0
who can help with entering "option code" I type "062598 HOME 135" and get the following error “samsetoptionservice triggered but set optioncode failed!” (65OLED706). how do I solve this? maybe there is another way to enter this code?
 

Attachments

  • 88A37FAF-F7D6-45CD-9F58-B3BDC2F41FB1.jpeg
    88A37FAF-F7D6-45CD-9F58-B3BDC2F41FB1.jpeg
    1.1 MB · Views: 86
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    11
    firmware decryption + rooting attempts

    #################################
    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.
    #################################

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files:

    boot.img.zip: kernel + initrd + ramdisk (unknown file format)
    bootloader.zip: bootloader (unknown file format)
    tzk_normal.img.zip: ? maybe recovery (unknown file format)

    user_setting.zip: content of /user_setting
    system.img.zip: content of /system (ext4-img)
    firmware.img.zip: content of /firmware (ext4-img)

    BackEndBin.zip, EdidBin.zip, fpgaUhdBin.zip, RougeBin.zip: different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "org.droidtv.tv.tv_power_system_access" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.


    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).

    Cheers,
    5003b4d49cbf7916123271b7b1918f123cca0c09bf1428f4398257751ac6570c

    ps: some of the information were dumped on an older firmware and some with the current one
    11
    Steps for install any APK in 2014 Philips Android TV AND1E

    Hello,

    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    8
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...