Philips Android TV

Search This thread

Dolcrine

New member
Aug 17, 2020
4
0
Hi !
I tried a lot of things to repair my TV.
I took it apart, cleaned the receiver properly. It works normally when the TV is on but once off or in standby mode, the receiver receives 1 time out of 100 IR. The LED is not blinking, so I suspect a power issue. What do you think ? I've scoured the forums with no real help...
I thought I would go through HMDI - CEC but Philips Easy Link does not offer me any option to start my tv with a ChromeCast
It's a Philips 55PUS6501/12

Thank you in advance for your answers ! 😊
 

hu016865

Senior Member
Dec 3, 2010
136
6
tehran
I have a 65 inch Philips 7601 TV with the latest update.
My problem is that after some time the TV control stops working.
Only when the TV is turned off, the remote control turns on the TV, but other buttons do not work. Even the TV does not turn off with the remote control.
But the Xiaomi gamepad connects and works without any problem.
I installed the Philips TV app on my phone.
I have to reinstall the TV, then the control works again
I checked and replaced the batteries, but it didn't make a difference.
Is it possible that the problem is from the last update?
 

bellzebu

Member
May 14, 2012
31
15
Alceda
Hi,

55pus7504_12 running the latest firmware available tpm19e_r.101.002.178.000

Can't play h.265 video, any workaround on this?
 

bellzebu

Member
May 14, 2012
31
15
Alceda
Use MxPlayer from playstore
My bad, I can't play SDR vids using HW+, some players like mpv can decode SDR using SW but the performance is really bad. This how it looks using kodi, vlc or the built in media player. I have no problems playing 10 bit HDR.
 

Attachments

  • IMG_20221024_012621.jpg
    IMG_20221024_012621.jpg
    449.7 KB · Views: 47

Emyl2011

New member
Jul 12, 2013
2
1
31
Lenovo ZUK Z2 (Plus)
Xperia XZ2
My bad, I can't play SDR vids using HW+, some players like mpv can decode SDR using SW but the performance is really bad. This how it looks using kodi, vlc or the built in media player. I have no problems playing 10 bit HDR.
Its the video file maybe? Try playing on a powerful enough pc and if plays well you have your answer: Tv CPU is to weak for that file. Last option would be to try if you didnt already MXcodecs(search on google and find xda link). Thanks!
 

Qiuba

New member
Oct 28, 2016
1
0
Hi ALL,

i'm new in town and I have a little problem... :)
My super tv is 55pus7303/12, but it have a little issue with PS4 gamepads. Its pairing well, but buttons are complitly in other functions. For example X button works as canceling istead of confirm, R3 works as START, only directions are good. A want to try some button remap application but they doesnt work as i want to.
I've checked internet and my information is its probably android version fault. My is OREO.
Please help me. Can I update it with some custom rom ?

edit:

i've found this site:

it looks legit, can some of you tried this?
 
Last edited:

hkrt1979

New member
Apr 9, 2013
2
0
eskişehir
Hello friends. Unfortunately, all applications and platforms (plex, YouTube, stremio, blutv, etc.) that can normally play videos on my 2016 Philips 55pus6561/12 television cannot play videos anymore. I was confused what to do. I downloaded VLC player from playstore for a while. From there, I tried to play video over the network and it played. Then it stopped playing again. Playstore also stopped opening. So you see, the TV started to go crazy.. software version is QM163E.0.26.70.1 , android version is 8.0.0 .... can I root it to overcome all this? Will the TV be upgraded to android 9, 10 or 11? I would greatly appreciate your help, thanks in advance.
 
Last edited:

zakk87

Senior Member
Sep 3, 2010
499
149
35
This is the worst TV brand on this planet. Since few days Netflix stopped working on my PUS7303. Error -1044. Tryed power off, uninstall app, delete data of the app, update. Nothing. Should I throw it by the window?
 

zakk87

Senior Member
Sep 3, 2010
499
149
35
phone app freeze, nothing on TV, YT cast works.


Netflix app did works for 4 years and suddently...
 
Last edited:

jimVmax

Member
Oct 28, 2003
27
0
York UK
Hi
Can anyone help, I have a philips 58pus8545 I need to downgrade firmware. Also how do I get into recovery mode.
Any help would be appreciated.
Thanks
J😉👍
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi,

    you cannot root these TVs also ATV 8 is the latest and final ATV version for these 2016 TVs. You can try to make a factory reset...

    [email protected]
    1
    Hi,

    you need to rename the file to "autorun.upg" - the "R" does not matter ...

    [email protected]
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    11
    firmware decryption + rooting attempts

    #################################
    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.
    #################################

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files:

    boot.img.zip: kernel + initrd + ramdisk (unknown file format)
    bootloader.zip: bootloader (unknown file format)
    tzk_normal.img.zip: ? maybe recovery (unknown file format)

    user_setting.zip: content of /user_setting
    system.img.zip: content of /system (ext4-img)
    firmware.img.zip: content of /firmware (ext4-img)

    BackEndBin.zip, EdidBin.zip, fpgaUhdBin.zip, RougeBin.zip: different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "org.droidtv.tv.tv_power_system_access" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.


    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).

    Cheers,
    5003b4d49cbf7916123271b7b1918f123cca0c09bf1428f4398257751ac6570c

    ps: some of the information were dumped on an older firmware and some with the current one
    11
    Steps for install any APK in 2014 Philips Android TV AND1E

    Hello,

    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    8
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...