Philips Android TV

Search This thread

krgzzz

New member
Nov 10, 2022
1
0
hello i have phillips 55pus6482 tv. I turned off the TV tonight, but when I woke up in the morning, I saw that it turned on by itself and stuck on the phillips logo. I tried turning it off and on several times but the situation did not change. each time it got stuck at the pihillips logo and wouldn't turn on. The button on the remote or the TV has no function. What do you think might have happened?
 

jimVmax

Member
Oct 28, 2003
27
0
York UK
hello i have phillips 55pus6482 tv. I turned off the TV tonight, but when I woke up in the morning, I saw that it turned on by itself and stuck on the phillips logo. I tried turning it off and on several times but the situation did not change. each time it got stuck at the pihillips logo and wouldn't turn on. The button on the remote or the TV has no function. What do you think might have happened?
It looks like your firmware has become corrupt. First unplug your tv from the mains, then press and hold your power button on the tv ( not the remote, the small joy stick on the back of the tv), while plugging your tv back in.
Keep holding it for about 30 sec. Let go this should reset your tv. Hopefully it should reboot.
Best of luck
 

Magic_Knight

Senior Member
Jan 17, 2007
132
25
Monza
Hi,
I have a Philips 65OLED706/12 model (with Android TV 11) and I'm experiencing playback issues with DRM protected HbbTV video streams. My TV's firmware is version TPM211EA_R.101.000.178.222. On Philips support site I have found that newer versions are available but they don't have that "_R" in the name... latest version is TPM211EA_101.001.003.223 and my TV refuses to update. What's the difference between "R" and "non R" firmwares?
 

coni57

Member
Feb 4, 2020
17
0
Hi,
maybe the problem does not only apply my TV65oled 934.
I connected an external hard drive to USB and set up for TV recordings.
With Total Commander I can see the hard drive but without RW access.

I also connected them to the PC and that doesn't work either.
But when I connect it to my Samsung smartphone, I can delete and copy data on the hard drive as normal.

Maybe there is another way to write on the hard drive?
 

dweer

New member
Nov 22, 2022
1
0
Hello everyone,

I have got Phillips TV too, but it is a model made for Chinese market, hence no Netflix, no Google, no Youtube -- nothing. Is it possible to flash US firmware onto it?

Specs are:

Model: 55PUF6092/T3
Android version: 4.4
Software version: V2.1.0
Engine: PixelPlus ULTRA HD
UI: Philips One UX
Panel: 4K, 2D

CPU: ARM Cortex A53 CPU
GPU: MaliT720MP2 GPU
Memory: 4GBEMMC, 1GB DDR3
DTV: DTV
Network: Wi-Fi

Thank you
Hi, Did you find any solution for this. I have the same issue for same model
 

nokiae60bgd

New member
Nov 22, 2022
2
0
My unit is
Philips android TV
55PUS7354
TPM191e_r.101.002.098.000
Android 9

Stange thing happening ...
As I have two wifi (two different isp ) when I connect to one all is good and working, when I connect to other one all good again
But when I want to connect back again to 1st one - tv is asking me for wifi password to enter (like I'm connecting for a first time to named wifi )?

Has anyone had that kind of "forgetting illness " problems and how to solve it ?
 

alex776

New member
Nov 30, 2022
1
0
hello
I have a tv 70PUS8505/12 for 1.5 years and recently one problem started. When I watch netflix or normal tv after a few minutes it keeps putting me in the start menu and loading... is there any update or what can I do? Latest firmware is TPM191E_R.101.002.178.000
Thank you...
 

dioxnet

Senior Member
Apr 25, 2012
116
7
¿Alguien ha actualizado a Android 12?

Mod translation: Has anyone updated to Android 12?
 
Last edited by a moderator:

knezolino111

Member
Feb 7, 2015
14
0
Xiaomi Poco X3 Pro
Edit: downgrade it but problem is still visible.

Hey guys,

i just recently discovered that there is topic for Philips TV and that's nice.

Anyways, few days ago i got Philips 58PUS8517/12 and i have a problem with choppiness of picture while i'm using android app TiviMate.

I have IPTV channels running in 1920x1080 and in 50 fps. Problem is that picture is not smooth and i can see frame drops every few seconds. When i connect FireStick, everything is great again and its smooth but im trying to get rid of stick since i have Android tv. And to mention, on channels with 25fps, everything is great.

I already played with picture settings but that choppiness is always there no matter what i do. Can i get some assistance on what to do about it? TV is updated on latest software already and it did update when i got it so i don't know if everything was okay on older version. Should i downgrade? And why is there no resolution change option in settings?

Thank you very much.
 
Last edited:

elcenzo

New member
Dec 24, 2022
1
0
Hello,
I have a Philips TV 55PFL6008K/12, the TV shows the logo and then it just goes black (Backlight is on). The red flashes continuously.

Once Recovery Mode appeared by itself and then nothing.

I looked and read about any software .pkg but there was none, software with .upg doesn't react to anything.
It does not accept software with .upg

Chassis: QFU1.2E LA

Mainboard was changed once 3 years ago
705TXGCS099158 2K13 FUSION 6 SERIES MODULE ASSY FOR EU

If anyone has any such cases, please let me know.

Thank you.
Best Regards.
 

ghiatanicu

New member
Jan 2, 2023
1
0
hi i have a smart tv android philips 7600 and it is stuk on logo and i can not enter to recovery mode please someone help meeeeee, i need very quick a help how toenter to recovery mode from remote control because i try from joistik from back on the tv and it not work stay onley on logo and after pulg in the cord to power it appears the logo like 10 second and it gose on black screen for 83 seconds and then it stay on logo and nothings happends , i konw hpt to flash from usb drive but i need help how to acces the recovery mode from usb direct or from remote control pleaseeeeeeeeeeee help meeeeeeeeeeeeee.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I have a Philips 43PUS8555/12 TV in the link there are two firmwares:
    1) TPM191E_101.2.178.0
    2)TPM191E_201.0.215.200

    Which to use?
    Thank you
    1) Is Android TV 9
    2) Is newly released Android TV 11

    There is no huge difference between these versions.

    Using the built in update feature on your TV it should offer 1) as update if you are not running it already. Some people are already getting 2) through their TV as OTA update but this depends on where you live. If you want to be safe, use Android 9 and update later to Android 11 when it comes directly available to you.

    For me Android 11 seems to be working ok for now, but some people have had issues (and I also had some issues like I wrote here earlier). Often new Android version updates have some issues in the beginning and they are later patched in following updates.

    After update you should restart TV through settings menu like @Toengel said earlier in this thread. If there are still some bugs and lagging, you might need factory reset after the update.
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    11
    firmware decryption + rooting attempts

    #################################
    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.
    #################################

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files:

    boot.img.zip: kernel + initrd + ramdisk (unknown file format)
    bootloader.zip: bootloader (unknown file format)
    tzk_normal.img.zip: ? maybe recovery (unknown file format)

    user_setting.zip: content of /user_setting
    system.img.zip: content of /system (ext4-img)
    firmware.img.zip: content of /firmware (ext4-img)

    BackEndBin.zip, EdidBin.zip, fpgaUhdBin.zip, RougeBin.zip: different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "org.droidtv.tv.tv_power_system_access" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.


    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).

    Cheers,
    5003b4d49cbf7916123271b7b1918f123cca0c09bf1428f4398257751ac6570c

    ps: some of the information were dumped on an older firmware and some with the current one
    11
    Steps for install any APK in 2014 Philips Android TV AND1E

    Hello,

    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    8
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...