Philips Android TV

Search This thread
Jun 17, 2011
Hi everyone, I own an older Philips 4k TV (48PUS7600/12) from 2015 with Android 5.1 and I want to use it as a monitor, but the input lag is absolutely horrendous, I tried enabling Game Mode and also to disable all the image processing settings from the picture menu, but it's still noticeable when use it as a PC monitor.

I was wondering if there is anything I can do to the Android OS that will disable any other picture processing background processes in order to gain better input lag.


Oct 30, 2014
I have android philips tv 32PFS6906/12 with firmware TPM215E_R. Support site has new firmware TPM215E _ I extract files /firmware not only one file/ on usb fat32 but update dont start.


Senior Member
Apr 23, 2011
Guys, any advice on how to get the Google TV-like interface on a 2021 Philips TV (OLED936)? Apparently, those living in US and Germany already have their home screen looking like Google TV, but mine (living in the Czech Republic) is still stuck on the same Android TV home screen as on Android 9, even though running Android 11.
Last edited:


New member
Jan 9, 2023
Hello, I am the owner of 47PFL6198K/12 3D since 2014. In 2020, the motherboard was replaced. After two years, I wanted to watch a movie in 3D. The problem is as follows, I always watched movies with the WDhub hdmi port and the 3D worked now when I want to switch to side by side it becomes black picture. After the reset, the TV detects and switches to 3D but does not display the effect. Everything else works normally except 3D. The TV does not detect any updates anymore. I am attaching photos. Thanks for the help and the answer Morris.


  • 20221228_195538.jpg
    825.7 KB · Views: 53
  • 20221229_190654.jpg
    702.5 KB · Views: 51
  • 20230106_192952.jpg
    948.8 KB · Views: 52
  • 20230107_122549.jpg
    852.5 KB · Views: 52
  • 20230107_122622.jpg
    825.3 KB · Views: 47
  • 20230107_122633.jpg
    534.5 KB · Views: 48


Senior Member
Oct 26, 2017
Last edited:


New member
Jan 9, 2023

you got the hardware upgrade kit when you mainboard was replaced (/R1). 3D is not supported anymore on this TV model with the hardware upgrade kit.

[email protected]
Hello. First of all, I would like to thank you for the complete answer and for the quick publication. Is it possible that something is being done on some kind of update that would activate 3D or is there no 3D variant at all. Only an old motherboard would solve the problem. Are old motherboards still available?
Thank you greetings Morris.


Senior Member
Oct 26, 2017

only TVs with 4K (and with the hardware upgrade kit) do have 3D - and also only the passive 3D TVs.

Did you keep all the hardware parts after the upgrade kit was installed? It is not only the mainboard which was replaced. Also you now have Android TV which is much better, that the old operating system you got before.

[email protected]


New member
Jan 9, 2023

only TVs with 4K (and with the hardware upgrade kit) do have 3D - and also only the passive 3D TVs.

Did you keep all the hardware parts after the upgrade kit was installed? It is not only the mainboard which was replaced. Also you now have Android TV which is much better, that the old operating system you got before.

[email protected]
Hello. Only the kit motherboard and a new Philips remote control were replaced on the TV. The LCD has passive glasses next to it. As I mentioned, the 3D function is active only at the first start, it probably does not detect the player correctly and when I switch to 3D, the image becomes black. I do deep reset and then it works and merges the image, only passive glasses have no depth effect. I am attaching pictures.
Thanks Morris.
video 3d


Senior Member
Apr 29, 2018
Hi everyone,
I am trying to help a friend.
Philips TV 49PUS6561/12
He got online help from Philips support and even by calling him but they couldn't do anything. Nothing!
Few days before this appeared ,he found an IPTV app installed on the TV but he doesn't remember doing it, Then the screen become zoomed,. You Know nothing about what's going on the tv,.

Philips logo screen and the four colored dots is ok.

Any help appreciated.

How to FORCE factory RESET? maybe this could help.

Press power button on the screen for 20 sec >>>> nothing,,, theTV still on.

Upgrade >>>>>>>>>> read data (done) >>>>>>> upgrading doesn't start.
Changing the upgrades filename to "autorun.upg" with/without unzip the file doesn’t make sense.


Senior Member
Apr 29, 2018

what's happening, when he is pressing the HOME button on the RC?

[email protected]
The home menu appears, but we can't see anything. He doesn't know which icon RC stand on. For example If he press OK Netflix starts or something else.

Nobody knows. I mean he doesn’t know what’s going on or which icon is active.
All menus and buttons on RC appear to work normally. Sometimes we see the word settings, so we know that we have opened the settings menu.


Senior Member
Apr 29, 2018

install the latest upgrade_loader.pkg for his TV platform (QM163E). You can find it on my blog.

[email protected]

thanks for help.
Nothing happend when plugging in the usb-flash. Read notification appeared on the screen .

Zip file name: ""
The file has been extracted.
We tried once with the original filenme "autorun_QM163E_U_0.27.70.1.upg" and other with "autorun.upg"
The flash was plugged in during the TV is ON.

NOTE: The picture appears to be rotated 90 d CW.


  • cc4aff83-b6fb-4b61-9bc6-eb4b6482e575.JPG
    283.2 KB · Views: 17

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    firmware decryption + rooting attempts

    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files: kernel + initrd + ramdisk (unknown file format) bootloader (unknown file format) ? maybe recovery (unknown file format) content of /user_setting content of /system (ext4-img) content of /firmware (ext4-img),,, different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.

    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).


    ps: some of the information were dumped on an older firmware and some with the current one
    Steps for install any APK in 2014 Philips Android TV AND1E


    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...