Philips Android TV

Search This thread

Deleted member 11575455


what's happening when you try to install the latest firmware?

[email protected]
pdf file with instructions for flashing and dead mediafire link for the actual upgrade_loader.pkg file. Multiple contacts with customer service have been a joke, they are saying there is no PKG file, that you can't update from the blue screen and basically I made it all up. This apparently is regardless of the fact that they have had multiple updates for the TV and that their own website pretends to give out the update with instructions saying that you can indeed update from the blue screen. They keep trying to refer me to a repair center. I called the repair center and dude hardly had any clue what I was talking about, he said every few months or so Phillips will send him some warranty work or something. The TV is still under warranty, but I don't feel I should have to go that route. I've got a lot of experience with Android devices and the fact that they crippled the hardware Buttons for boot modes seems to be the most anti-consumer thing that they could have done.
Last edited by a moderator:

Deleted member 11575455

I did actually find a zipped update for the device on XDA, it was a zip file with a full firmware inside, unfortunately it's not the original PKG file and when I zip it and rename it to what the TV wants, I do get the blue screen but the update fails. I'm guessing it's not just a renamed zip, some type of security on the file, or maybe it's signed or something. I'm not sure. If they hadn't crippled the hardware buttons, I would just be able to boot right to fast boot and flash the update files from the zip and I'd be off to the races. My only chance right now of getting my tv working again is to hopefully find some nice soul who happened to grab the pkg file before it went offline. I can't currently find my receipt and I'm afraid i'm out almost a thousand dollars and a tv.
Last edited by a moderator:


Jun 14, 2012
I have a strange problem with my Philips 706 OLED.

I watch mostly dvb-c content.

Since firmware TPM211EA_101.000.178.206 I got an issue with the channel list (favorites).

To bring up the list I press either left arrow button, or ok-button on the remote.

When watching a TV channel i could in earlier fw see what's on the other channels without actually switching channel.

Now the channel list just won't update itself.

EPG is populated all ok. Something seems messed up getting information from the EPG to the channel list.

If I roll back to firmware 218 everything works like a charm.

Anyone experience this? Am I the only one still watching linear tv? :)


New member
Jan 28, 2023
Hi all,
I have Philips 58PUS8507/12 (2022) running on Android TV 11 OS latest firmware TPM211EA_R.
I am trying to enable installation from unknown sources (apk files from usb) but it seems that most Philips Android TVs have this option hidden as there isn't any security settings that you can acces to enable this.
So I tried all of THIS from Github but no luck, I am only getting "IO" error. (Or is it "I0" error, not sure, please see photo attached)

Obviously, I'm not an expert but it seems to me that this command wasn't even executed, my guess is that OS is blocking that command or something like that.
Also, maybe all of this wouldn't work anyways, but as I said I'm not an expert so I decided to ask for help here.
Maybe there is a solution for this error, or maybe there is a simple way to enable installation from unknown sources.
Thanks! :)
Jun 6, 2012
@Toengel What file systems for external drives are supported by these TV series 4/5 (for example PUS8804)? I tried a flash drive formatted in exFAT, NTFS and EXT3. None worked. I have video files over 4GB and I can't save them to FAT32. And I don't really like having my computer on all the time to share them over the LAN.


Sep 15, 2017
Hi. I have a PHILIPS 55PUS8007/12 TV, there is no option for voice control on the remote control, even if the TV supports it. You can use a remote control from another TV model that has this function. Has anyone tried this yet? And from which model? Thank you for the info.


New member
Jan 31, 2023
Hi. I have a PHILIPS 43PUS7906/12 which I consider slow mostly on boot, is there any form of root for this model or any other solutions beside deactivate apps

Thank you for the info.


Dec 22, 2010
How can I open the Android app manager in Philips OLED707 Android 11? This option is not visible in Android settings. Is it possible to spawn it through ADB or some other way? How about rooting options? I'm ready to buy a second main board for experiments.


New member
Feb 7, 2023
Hi I have a problem with the sound. If I play any application (Netflix, Youtube ...) so I only play music, but the spoken word is not heard. I found out that if I set the "sound style" to Music, I can hear the voice. With the other settings (Movie, Game, Dialogue, Original, AI mode) the voice is not heard. Do you know where the problem might be? When receiving a signal from dvb-t2, all sound styles work.

Phillips TV 58PUS8536/12, Android v11


Aug 2, 2008
Hi I have a problem with the sound. If I play any application (Netflix, Youtube ...) so I only play music, but the spoken word is not heard. I found out that if I set the "sound style" to Music, I can hear the voice. With the other settings (Movie, Game, Dialogue, Original, AI mode) the voice is not heard. Do you know where the problem might be? When receiving a signal from dvb-t2, all sound styles work.

Phillips TV 58PUS8536/12, Android v11
Hi, I have your same problem. The audio speech of my 55OLED806/12 TV, after the latest firmware update TPM211EA_R., is not heard or, in any case, it is heard very low. I tried resetting everything, but nothing. I believe the update contains a bug about this. I think I'll be forced to call assistance, since the TV is only a few months old.


New member
Feb 7, 2023
We just experience the exact same issue. We have a 58PUS9006/12, and after the TPM211EA_R. update at 17:30 CET tonight, the voice is muffled, except in music mode. Setting to music mode does not work in all apps however.

This must be a bug with the firmware update.


Senior Member
Aug 15, 2011
Sorry to bother you, but I'm wondering if I should try to update the new TPM191E_201.0.215.200 firmware manually, or wait for the official rollout and update via internet.
I have the 50PUS7394 model.

In the news on your website it is mentioned that the 7304 line has already received an official update. This model should be almost identical to mine, so it ought to happen at some point.., or are there major differences that I'm unaware of?

Thanks in advance!


New member
Feb 7, 2023
Hi, I have your same problem. The audio speech of my 55OLED806/12 TV, after the latest firmware update TPM211EA_R., is not heard or, in any case, it is heard very low. I tried resetting everything, but nothing. I believe the update contains a bug about this. I think I'll be forced to call assistance, since the TV is only a few months old.
Fixed, yesterday they released new firmware TPM211EA_R.
  • Like
Reactions: spatum


New member
Jan 21, 2011
Google Pixel 3
I have a 2014 philips tv model 55pus7909/12. I want to sideload apk files. most of the tips I found involve downloading an terminal emulator from playstore and starting security settings with that. Unfortunately it seems that the playstore app on this tv is so old that I can not install anything.
is there another way of enabling adb/untrusted apks?

Kind regards


New member
Jul 22, 2010
I update my Philips TV 50PUS7304 to android 11.

After updated, It begin infinite loop yo android logo.

I fix reset TV. I use physical jostick TV, moving down (to me) , don't press. Plug socket and follow press jostick down over 10 seconds, and release.

TV begin installation Factory reset.

Because someone has broken update yo androidtv 11.

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    firmware decryption + rooting attempts

    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files: kernel + initrd + ramdisk (unknown file format) bootloader (unknown file format) ? maybe recovery (unknown file format) content of /user_setting content of /system (ext4-img) content of /firmware (ext4-img),,, different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.

    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).


    ps: some of the information were dumped on an older firmware and some with the current one
    Steps for install any APK in 2014 Philips Android TV AND1E


    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...