Philips Android TV

Search This thread


New member
Jun 10, 2017
Hello Everyone.
I have 70pus8535 with newest possible software (may 2022). Since last 2 months after every night in "standby mode" i have to reset it/disconnect cable otherwise apps ( like disney+, youtube or netflix ) won't start or freezes. I've tried force stopping apps and cache cleaning - only after reset everything works fine. Any idea what can be the issue?


New member
Sep 4, 2012
Hello Everyone.
I have 70pus8535 with newest possible software (may 2022). Since last 2 months after every night in "standby mode" i have to reset it/disconnect cable otherwise apps ( like disney+, youtube or netflix ) won't start or freezes. I've tried force stopping apps and cache cleaning - only after reset everything works fine. Any idea what can be the issue?
Hi, take a new frimware

I'm update my 8505, before i have a may 2022 too
  • Like
Reactions: st00larz


Nov 2, 2014


New member
Sep 4, 2012
Do you update to Android 11? What changes with the new update?
Yes, I do. Changes : faster - i feel, and something else. Check foto’s. Limit’s of active process can be select and stay after power off


  • B5F5B14F-1D39-4045-992E-6DBBDBF864D8.jpeg
    638.8 KB · Views: 45
  • DDBFA3FB-12A0-47E2-8F63-1D464543BD3B.jpeg
    1.1 MB · Views: 48
  • 19C2E47C-2BBC-49B6-8FF6-8134F595533B.jpeg
    1.1 MB · Views: 46


Oct 13, 2019
Trying to find a replacement for my
55PUS7503 AV-Board 715G8579-M0D-B01-005T
I found a board for a
43PUS7393 AV-Board 715G8579-M0F-B01-005T
to replace it.
I was quite certain it should work and it does, but the screen looks like this:


An upgrade_loader.pkg to for the 55PUS7503 did not fix this problem. However the TV still thought to be a 43PUS7393.

So I am wondering if writing an NVM.bin file for the 55PUS7503 would fix it. What do you think? Can someone supply this file?

Update: I solved it and the TV runs as expected. One needs to install the appropriate NVM.BIN file to the new board so it has correct settings. However... there is no site to download these files and you need to contact Philips support.

I have attached the NVM.bin file I have been using.


  • PH_55PUS7503-12_EUR_MT5596_NVM_66_V0.59_20190222_FFFF.BIN
    32 KB · Views: 17
Last edited:
  • Like
Reactions: BertProesmans


New member
Jun 10, 2017


Apr 18, 2023
I recently (today) bought a 58PUS8507 mainly because of its advertised timeshift feature. But whenever I press the pause button, I receive a notification saying "this feature isn't supported." I tried with multiple flash and hard drives. Has anyone run into this issue before? Thanks


Senior Member
Sep 23, 2008

I have a Philips 50pus8505 android TV. I'm trying to set the resolution to 1440p for playing PC games but when doing that I can see an annoying message like "Video format not supported" in the right down corner of the TV. This is because the TV only supports natively 1080p or 4K but not 2K (1440p). Do you know if it's possible to remove that message? The image shows correctly, only the message is disturbing me.



New member
Aug 9, 2016
Hey guys i have philips PUS5807 and it has Philips remote app which able to turn it ON/OFF via Wifi only.
I thought that its a simple WOL but not.
Is anybody knows what philips using to turn TV on ?
I wanna install this app and connect with SIRI to switch it on/off by voice commands.


New member
Oct 25, 2016
I have pretty much the same problem as the poster here. I've got a 65pfl5604/f7. I got prompted to do the Android 11 upgrade last week. It is now stuck boot looping at the Philips logo. I tried the "hold down the volume down button" while it turns on trick but nothing happens.

I called the customer support number and their only recommendation was to try unplugging it and replugging it in. When that didn't work and they realized it was over a year old, they told me I was out of luck.

The link in that post gives me "File moved or missing" when I try to download it.

When I go to here:

I get a PDF with instructions, but that Mediafire link is gone too! It is like Philips has a conspiracy to make this tougher.

Does anyone have a link to a good firmware for the PFL5604 series? Right now I've got a perfectly good screen but the TV won't even turn on :(

Top Liked Posts

  • There are no posts matching your filters.
  • 1

    send me an email (see blog) and please attach a photo of the plate (sticker) from the back of your TV...

    [email protected]
    Does anyone have a copy of the firmware file from within this PDF? It is for the 65FPL5604 F7

    It links to:

    but Mediafire said that link was removed.
    I second that request. If someone can host the file it would be greatly appreciated!
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    firmware decryption + rooting attempts

    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files: kernel + initrd + ramdisk (unknown file format) bootloader (unknown file format) ? maybe recovery (unknown file format) content of /user_setting content of /system (ext4-img) content of /firmware (ext4-img),,, different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ([email protected]) (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.

    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).


    ps: some of the information were dumped on an older firmware and some with the current one
    Steps for install any APK in 2014 Philips Android TV AND1E


    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...