Philips Android TV

Search This thread
I have pretty much the same problem as the poster here. I've got a 65pfl5604/f7. I got prompted to do the Android 11 upgrade last week. It is now stuck boot looping at the Philips logo. I tried the "hold down the volume down button" while it turns on trick but nothing happens.

I called the customer support number and their only recommendation was to try unplugging it and replugging it in. When that didn't work and they realized it was over a year old, they told me I was out of luck.

The link in that post gives me "File moved or missing" when I try to download it.

When I go to here:

I get a PDF with instructions, but that Mediafire link is gone too! It is like Philips has a conspiracy to make this tougher.

Does anyone have a link to a good firmware for the PFL5604 series? Right now I've got a perfectly good screen but the TV won't even turn on :(
I have the same tv, had a different issue, but if your sure you've got a good screen and are having issues before you "recycle" the Tv you may be able to simply swap out the main board if you think your capable all it takes is an hour or less, remove some screws, install the new board and your tv should boot up... I had to do this when my tv got stuck in a bootloop it would only display the philips logo, the an Androidtv logo and reset repeatedly.
I know it's not a free fix but it's better than being down 3-500$ for a new device!


Jan 15, 2012
i flashed my 55OLED805 TV with the latest firmware from Philips Taiwan :

Translate web page to ENGLISH
Firmware page for XXOLED805 & 75PUH8265/96
Firmware ID : TPM191E

1/ Warning : you must select in the list your language in order to get the right zip file
2/ my file for FRENCH is : 75puh8265_96_fus_fra
3/ Unzip the file to get the following file in the USB KEY Fat32 Root : autorun.upg
4/ Then you go the TV Settings Update from LOCAL USB
it will take few minutes to move from Version 101 to 201 : Attention you should be in the latest 101.xxxx version before to jumpt to Android 11 TPM191E_201.000.215.200 version

Seems to work faster and it solved my LG soundbar connection issues

TPM191E_201.000.215.200 (Date published: 2023-01-03)
- Initial Android R release
- HDMI ARC improvements
- To support IPV6 wifi router
- Disable number digit key to turn on the TV (it needs set via factory mode)
- Stability improvements
- Other general improvements
Last edited:


New member
May 5, 2023
Hello, does someone is able to proxy his Philips Android TV (mine does not allow it) in order to tell me what is the API request that tells if the TV is up to date or not. thank you :)


New member
May 6, 2023
Hello follow members!

Ive got a question about nvm files.

I switched my 65OLED803/12 mainboard and now I need to find the nvm files, where do I download them?

Thanks in advance


New member
May 7, 2023
Hi everyone.
I'm trying to update my philips 804 via usb, I download the file TPM191E_201.0.215.200 from the site ( now I have the TPM191E_101.2.178.0 ) the file I download is called
Is the file I'm downloading called like this?

Thank you!


Senior Member
Oct 26, 2017

it's correct - extract the ZIP and rename it to autorun.upg ... put on empty USB stick and insert it when the TV is running...



New member
Nov 13, 2014

My Philips 65OLED806 /12 runs on a 32-bit Android OS.. Some apps need a 64-bit Android version. Philips will not provide this version. Is there a third-party 64-bit Android version that runs on my 65OLED806 /12?



Senior Member
Aug 19, 2010
  • Like
Reactions: thecal1


New member
May 19, 2023
Any help if possible, Philips 43pus6401 TV was unplugged whilst starting up, got stuck in constant boot loop, originally went to Philips logo then android os screen to reboot, load update, clear cache, tried to update firmware using latest from Philips website and although said successful, still stuck in boot loop, start to load android then goes back to Philips logo, in frustration pulled plug, now stuck on Philips logo won't even boot to os screen, anything I can try/force TV to load from usb or is it bin fodder, thanks


Senior Member
Oct 26, 2017

just search for "6401" on that archive page and download the latest available upgrade_loader ... Upgrade_Loader is a complete ATV image.



New member
May 19, 2023

just search for "6401" on that archive page and download the latest available upgrade_loader ... Upgrade_Loader is a complete ATV image.

Thanks, can I use a bigger memory stick and just size it to 4gb when formatting or do I need to find a smaller capacity one?

I used the blue usb 3 port last time as when tried the black usb 2 it wouldn't read the file was that caused by the above?


New member
May 19, 2023

make sure to use the black port (USB 2) for the upgrade_loader.pkg - format with FAT32

I have got back to where I was now, Philips logo disappears, android starts to load get the coloured circles then resets to Philips logo after 5 goes it goes to os screen

Message in corner says warning: no file_contexts


New member
May 20, 2023

Same problem here with the infinite boot loop after TV upgraded itself. I could access Safe Mode at the beginning but after doing a factory reset boot loop persisted and now it wont let me access Safe Mode again. Does anyone have a firmware file for a 5700 series? 55PFL5766/F6 to be exact. Gracias!

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Guys! To disable Philips Collections bar or also known as Philips Apps Tray at top of Android TV leanback launcher. All you have to do is find leanbackcustomizer in System Apps or Running Apps and turn off its notifications which can be turned off at button of the menu when you click on the service.

    I couldn't find a single source which mentioned these steps to take to disable Philips bloatware. I figured these out on own. I am not aware of any other methods that has the same results.

    Enjoy your less of a pain Android TV by Philips

    Hope this helps.

    ---------- Post added at 02:03 AM ---------- Previous post was at 01:56 AM ----------

    To disable recommendations, disable org.droidtv.nett_launcherapp in system apps or running apps. Hope this also helps debloat your Philips Android TV to a manageable level. However, this doesn't get rid of the recommendations field only apps that shows up.
    firmware decryption + rooting attempts

    WARNING: don't look at the following information nor try to use any of it if you have no clue about linux or android as it is most likely that you are going to break your expensive gadget. For every one else: don't blame philips if you brick your device -> think before actually trying. If you post about vulnerabilities and stuff better cover your ass - who knows what the legal department of philips thinks about your cool stuff.

    So as you decided to ignore my warning, here we go:

    I already spent plenty of time researching the internals of the device in order to get root privileges. Unluckily without the final breakthrough - but at least I found out some very interesting details.

    You might ask what those extended privileges should be good for? Well in my eyes android - a project available as open source with uncountable possibilities for developers and users - should not be closed down by profit oriented manufacturers. As those are often forcing the users into their own "crappy" software without given them any chance to escape. I like to develop at system base, use the underlying linux tools and most important check what the manufacturer does (behind my back) in my own living room. Hell I bought this expensive device and have no idea and can't nearly control what is sent to Philips nor Google.

    1. I wrote a tool to decrypt the official firmware. It was created via reverse-engineering the "upgrade.bin" arm-file (thanks for the trace, snoerenberg).

    Some interesting details about the used cryptography:
    - openssl library functions
    - used algorithm: aes-256 in CBC mode
    - the encryption key is generated via "EVP_BytesToKey" using only the first 127 byte of the keyfile + an eight byte salt found near the beginning of every input file

    Source-Code: attachment or pastebin_com / z3nA2r3J
    maybe mirroring this paste and the source would be a good idea (Google for the HASH if link is down)

    The decrypted firmware archive contains the following files: kernel + initrd + ramdisk (unknown file format) bootloader (unknown file format) ? maybe recovery (unknown file format) content of /user_setting content of /system (ext4-img) content of /firmware (ext4-img),,, different binary files - supposedly firmware for these components

    As you see I was not able to extract the most interesting part (kernel + ramdisk) - Hopefully some android experts could help!

    The current and some older firmware files could be downloaded at philips_samipupu_com (thanks for hosting)

    2. General information:
    - Kernel version: Linux version 3.4.70+ ( (gcc version 4.6.x-google 20120106 (prerelease) (GCC) ) #1 SMP PREEMPT Fri Nov 14 01:52:21 IST 2014
    - Kernel cmd-line: androidboot.hardware=AND1E quiet lpj=11935744 root=/dev/ram0 androidboot.console=ttyS0 console=ttyS0,115200 init=/init vmalloc=448M quiet macaddr=00:00:00:00:00:00 emmc_ts.dev_id=1 emmc_ts.size=16777216 emmc_ts.erasesize=524288 emmc_ts.writesize=512
    - lsmod:
    usb8797 359014 3 - Live 0x00000000
    usb97mlan 290809 1 usb8797, Live 0x00000000 (P)
    mbtusbchar 52685 0 - Live 0x00000000
    usbfwdnld 8530 0 - Live 0x00000000
    fusion 96777 0 - Live 0x00000000 (O)
    tpvinput 7132 2 - Live 0x00000000 (O)
    trcext 333860 0 - Live 0x00000000 (O)
    gal3d 161434 16 - Live 0x00000000
    amp_core 72528 2 - Live 0x00000000 (O)
    tzlogger 1199 0 - Live 0x00000000 (O)
    tzd 32013 30 amp_core,tzlogger, Live 0x00000000 (O)

    3. The trcext module seems to be very interesting as a short look with a disassembler revealed that it might be able to read and manipulate process memory of any process. Maybe someone good at kernel-drivers could take a look?

    4. There are two world-readable directories containing very interesting information:
    - /data/debugdump: stack-traces, process-lists, short memory excerpts based on crashes of the native binaries (could be very helpful for exploiting)
    - /data/anr: davlik crash-dumps of android applications

    5. There are 3 SGUID and 1 SUID binaries (visible):
    -rwxr-s--- root inet 5500 netcfg
    -rwxr-sr-x root net_raw 26072 ping
    -rwsr-s--- root shell 9464 run-as

    6. The recovery menu which could be used to install a "new" firmware if the device does not boot properly could be reached via the following steps:
    - unplug the power
    - press and hold the joypad on the backside of the TV downwards
    - replug
    - release the joypad after 10 sec

    7. There is a Customer-Service-Menu at “123654” which contains read only information about the current firmware and so one. However there is also the real service menu (062?96i) which could be used for much more things. But you need to be really careful with this, i already managed to break booting without changing something important.

    8. The settings-app calls the "su" command inside of CSMActivity. If this is no obsolete debug code (i was not able to trigger this part yet) than there could be a "su" inside /sbin. The Manifest also shows this strange "" permission. Therefore i tried to write my own app with the same permission and call "su" which did however not work out (even if I use the same namespace org.droidtv.?)

    9. Every time you pop in an usb stick android creates an backup folder on it. The filenames are "hidden" via base64 and there are some junk bytes at the beginning of the files which you need to crop in order to read them. However the content is quite boring mostly some sqlite3 databases with configuration parameters.

    10. By default the usb sticks you plug in is read-only for user apps. However there is in option in the settings to re-format it. This will result in an XFS formatted, read-write mounted stick where you could even outsource your apps.

    11. There is a soap (http) service running on port 1925 which is used by the philips remote app and allows different things for example starting one of the installed apps. More details could be found if you decompile the XTV-App.

    Hope some of you guys could do something fancy with those information.
    @snoerenberg(xda): did you manage to send commands over your cable yet - If you do rooting should be quite easy from this point (maybe /system/bin/run-as).


    ps: some of the information were dumped on an older firmware and some with the current one
    Steps for install any APK in 2014 Philips Android TV AND1E


    For install any application in 2014 Philips Android TV AND1E :

    1º You must download "Developer Settings" from "Google Play" and enable "Usb Debugging" in "Developer options".
    2º Connect ADB via WIFI -> adb start-server" , adb connect IP:5555
    3º Install APK -> adb install "app.apk" (download apk from google play with evozzi apk downloader in web or in chrome extension)

    I've tried it in 55PUS8909 and it works!.

    I've tried for root framaroot, towelroot and vroot and exploits not run.
    I've tried all for "Unknown Sources" and nothing.

    sorry for my english....thanks, regards!
    [GUIDE] How to root 2015 Philips Android TV

    [GUIDE] How to root 2015 Philips Android TV moved to separate thread here

    Please vote regardless you were successful with rooting or not...