phone freezing with immersive mode?

jordando

New member
Oct 19, 2017
2
0
0
I just RMA'd my phone after thinking this was a hardware issue. I use the custom navigation bar app by paphonb and my phone lags trying to unlock it using both fingerprint reader and hardware power button. Sometimes not even unlocking after multiple attempts. Is there any command i can run through adb to fix this issue?
 

skiely666

Senior Member
May 26, 2011
555
162
73
I tried to use the global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox command however it keeps returning an error reading that the command is not an identifier
The 4th last comment on the link above is a Tasker method that works flawlessly. It sets navigation on when screen is off so when you unlock your phone it's not in immersive mode so it unlocks as normal plus you can have or not whichever apps you like in immersive or not. I never used Tasker until I read that comment, I couldn't live without it now ;)

Sent from my Pixel XL using XDA Labs
 

jeff5347

Senior Member
Feb 29, 2012
923
311
0
Mass
I downloaded Tiles off of the play store. I had tried shortcutter and that worked but the phone wouldn't wake up or would take forever to wake when full immersive mode was enabled. Got rid of shortcutter and got https://play.google.com/store/apps/details?id=com.rascarlo.quick.settings.tiles. Have to enter the adb command but works flawlessly. Screen wakes as normal and no bugs. I'm stock non root


Sent from my Pixel XL using Tapatalk
 

noidea24

Senior Member
May 27, 2012
512
202
63
Atlanta
Ive been trying to work around issues similar to this myself.
Ive already noticed screen burn on my pixel, due to the (almost constantly) black navigation bar.

Originally i used oreo tiles in the app store (as mentioned above)to enable immersive mode, but had horrible response time when trying to wake my phone up (common problem).

Then i tried enabling immersive through terminal emulator in the app store by typing "su" and then "settings put global policy_control immersive.navigation=apps,-com.google.android.googlequicksearchbox" and for the most part it worked, but i would often get stuck in apps. i would swipe up to press the back button and instead of sending the back action the nav bar would immediately hide again. this would leave me to swipe up and trying to double tap back super quick before it went hidden.

For the third attempt i used the twrp Oreo aroma mod installer in the themes and apps section to completely disable the nav bar and attempted to use LMT for navigation, but LMT would occasionally crash and not allow me to return to the app drawer to restart the service. So that was a failure.

I ended up using "nav bar apps" to simply recolor the nav bar based on the application that is open, so instead of stationary black, it changes colors.

Just sharing my experiences, maybe youll catch something out of it that will help you.