[PIE] [9.0] [Nougat - Pie] OmniSwitch Flashable Zip - Universal

Search This thread

Fr1day_13

Member
Mar 10, 2021
30
1
Android Wear
I was missing OmniSwitch when I finally went custom ROM on my OnePlus 8T. In the past crDroid has always had OmniSwitch but I guess things have changed since "my old days".

I tried the various items attached by ThatDamnFrog. The standalone apks didn't work. The flashable zip, OmniSwitch-11NewV2, is not A/B system-as-root ready. It flashes to /system instead of /system/system. Remember having to edit a similar zip on my Essential Phone before.
Also the requisite permissions file (needed for apps in priv-app) is not included so it probably wouldn't work if flashed properly anyway.

The Magisk package, OmniSwitchForA10A11Experimentalv2, works perfectly. I am so jazzed. It also includes the needed permissions file.

With OmniSwitch in place now I feel at home. Was reluctant to own a modern Android device.

Would be running OmmiROM itself but it seems it doesn't quite work with my 8T KB2007 variant (modem issue I think).
Its not working for my Oneplus 8 with Stock Rom, after installing it as a magisk module its running in "restricted mode" and its not working at all, sadly.

anyone who fixed that restriced mode? didnt got it to work on my op8 on A10 and A11 :-/
 

marcdw

Senior Member
Sep 24, 2014
5,751
2,894
59
Baldwin Park
Yeah, I'm kind of bummed out. I mentioned it works great on crDroid but when I went to CarbonROM I had no such luck. Despite the inclusion of the permissions file, App Manager shows that some of the necessary permissions have been "revoked".
Oh how I dislike modern Android. 😑
 

asdf2345

Senior Member
Feb 3, 2018
161
17
I can't find a version that works on my S7 running LineageOS 18.1. It always crashes when trying to open the switcher.
 

willybarca

Senior Member
Apr 7, 2010
425
129
sydney
Thank you so much for the info, I will switch to another rom and try it out! :D
Have you used This method?
I flash the magisk module . The only catch is that build doesn't work on 12 so I have this slightly updated omni switch APK I pulled from omni os from android 12 builds, which after the phone boots up I replace the original omni switch in the system app folder to the one I have . Also you need the yellow smiley app to enable signature verification . But yeh I made a magisk module using the one I have but it didn't work idk why . So after every boot I need to replace the apks , a bit annoying but then again I don't reboot my phone in weeks some times
 

Attachments

  • OmniSwitch.apk
    1.1 MB · Views: 94

creeve4

Senior Member
Jan 5, 2011
2,845
580
Bountiful
Hey, delighted to see that OmniSwitch is still alive and well. I've just moved to LineageOS 18.1 from Temasek 13 (Android 6) on my Samsung Note 3.

I've flashed the Magisk Module and got OmniSwitch installed but am getting an error notification when I try to open the switcher by swiping.

The error message says "OmniSwitch restricted mode - failed to gain system permissions"

Anyone have any ideas how I could remedy this? I miss my pretty and functional app switcher, the default carousel in Android 11 is NASTY!

cheers

Update: I've also tried signing the apk from the Magisk module and then installing the module fresh....didn't make any difference unfortunately...
Did you find a solution?
 

Neodimon

New member
Aug 13, 2018
3
1
Hi to all! OmniSwitch for android 11. Pulled out of some (I don't remember anymore) firmware on android 11. For "manual" installation (system/priv-app or system/app). It does not contain an error: "failed to gain system permissions", respectively, does not require manipulation with lucky patcher.
 

Attachments

  • OmniSwitch_11.zip
    1.3 MB · Views: 100
  • Screenshot_20220910-180259.jpg
    Screenshot_20220910-180259.jpg
    631.3 KB · Views: 64
Last edited:
  • Like
Reactions: Lord Sithek

Nath_h57

Member
Nov 10, 2022
47
12
I'm trying it, thank u, the whole world still needs a super recent apps app as a zip installer for all those AOSP roms though, maybe someone will make such a thing with man options and all
 

Nath_h57

Member
Nov 10, 2022
47
12
thx for your help, I
Here is A13 compatible OmniSwitch APK. I got it working on my ROM using the suggestion here but without smiley face.
thank you

no success for me though, I have tried to flash the zips but it doesn't flash in recovery or magisk

I have tried copying the folder in /priv-apps but it doesn't work either, nothing happens and it gets deleted.
sadly !
 
Here is A13 compatible OmniSwitch APK. I got it working on my ROM using the suggestion here but without smiley face.
Hello. Could you please give a step by step on how you got this woking, I've tried the direction in the post you linked and everything else I can think of and it just ends up forcing a reboot usually. I'm running evox 13. Thanks
 

nickelnine

Senior Member
Sep 24, 2013
251
81
HTC One (M8)
LG G5
Hello. Could you please give a step by step on how you got this woking, I've tried the direction in the post you linked and everything else I can think of and it just ends up forcing a reboot usually. I'm running evox 13. Thanks
Hi, I flashed the OmniSwitchForA10A11Experimentalv2.zip then reboot, then open and enable OmniSwitch and apply your preferences, then manually copy the A13 OmniSwitch zip to /system/priv-app/OmniSwitch and it should open and function properly. You might have to wait a little bit after the copy for it to start showing up. For added flavor, I personally mapped the recent key to open OmniSwitch using A13 fork of GravityBox.
 
Hi, I flashed the OmniSwitchForA10A11Experimentalv2.zip then reboot, then open and enable OmniSwitch and apply your preferences, then manually copy the A13 OmniSwitch zip to /system/priv-app/OmniSwitch and it should open and function properly. You might have to wait a little bit after the copy for it to start showing up. For added flavor, I personally mapped the recent key to open OmniSwitch using A13 fork of GravityBox.
Thank you thank you. I'm gonna try it. I tried that gravity box 13 you posted in another thread and my phone went into a bootloop. Had to format. I'm using lsposed zygist. Do you have any sense why it would have happened?
 

Top Liked Posts