Pixel 5 Stuck on boot loop

Search This thread

WFHbot

Member
Apr 5, 2021
10
0
Hi All,

I'm hoping someone will be able to help as I've spent most of the day chasing my tail it seems.

My 'stock' (non-rooted/non-flashed) Pixel 5 went into a boot loop randomly last night.

I've restarted, I've gone into the recovery mode and have tried to flash an OTA via ADB (which may not sound like much but is an achievement for someone with my limited technical skills), it's getting to 94% and then I'm receiving an error on the cmd prompt saying 'adb: failed to read command: No error' but on the phone itself it says that is was a 'success' status 0.

I've tried the current OTA and the developer version and I'm getting the above issue on both.

I tried copying the 'zip' to a USB stick and have plugged that in using the USB A to USB C dongle that comes with the pixel but I'm receiving an error stating that it cannot be initiated.

Can anyone suggest a possible next step? I have some files that I've realised don't go to my cloud backup and they are important to me so I'd like to if possible not have to wipe the device.

Many thanks.
 

l7777

Senior Member
May 2, 2007
545
174
Are you using the latest ADB from the android SDK?

You can always try the factory image and remove the -w from the flash-all.cmd file.
 
  • Like
Reactions: ridobe

WFHbot

Member
Apr 5, 2021
10
0
Are you using the latest ADB from the android SDK?

You can always try the factory image and remove the -w from the flash-all.cmd file.
Hi, thanks for taking the time to respond. Everything was downloaded yesterday so is up to date. I re-downloaded just now and checked again and am still getting the same.

(~94%) adb: failed to read command: No error on cmd
Install from ADB completed with status 0 on the phone.

Is there a simple guide on how to flash-all (for someone as not technical as me) that you can point me towards?
 

WFHbot

Member
Apr 5, 2021
10
0
Are you using the latest ADB from the android SDK?

You can always try the factory image and remove the -w from the flash-all.cmd file.
Hi, thanks for this, I'll try another sideload with the April update and attempt it from another laptop, if that still doesn't work then I'll try the flash as you suggest.
 
Hi, no not yet. I think this will be the last step before I factory reset. Will try another cable, laptop and the April OTA this evening when I have time.

Thanks.
Also a note on trying to use the web flash utility. Make sure to look at the advanced options on the installation page, it gives you an option to flash the latest update without wiping your device at all.

That could help in getting the phone running again so you can recover your important files, before deciding to do a compete wipe, if that's what you have planned.

Just look around the settings carefully before flashing and everything should go well 🙂👍.
 
  • Like
Reactions: WFHbot

Chad_Petree

Senior Member
Apr 2, 2009
3,318
486
The same thing happened to me, it must have been the April update, I updated my phone, everything seemed to work and then all of the sudden I was watching a video last night and the phone rebooted itself and kept being stuck in boot, it won't load the os but it keeps restarting itself.

I tried accesing recovery mode but on the bootloader screen it won't let me use the volume keys to start the phone in recovery mode or to try and hard reset it, while on the bootloader screen it resets itself... :/ I'll give google a call
 
Last edited:

WFHbot

Member
Apr 5, 2021
10
0
The same thing happened to me, it must have been the April update, I updated my phone, everything seemed to work and then all of the sudden I was watching a video last night and the phone rebooted itself and kept being stuck in boot, it won't load the os but it keeps restarting itself.

I tried accesing recovery mode but on the bootloader screen it won't let me use the volume keys to start the phone in recovery mode or to try and hard reset it, while on the bootloader screen it resets itself... :/ I'll give google a call
That sucks. Hopefully they'll be able to do something more than just a factory reset.

I've tried sideloading the April update and that also failed at 94%. Will try another laptop in a while and see if that works, then try the flash as suggested above, if not then it's a factory reset for me.
 

WFHbot

Member
Apr 5, 2021
10
0
Also a note on trying to use the web flash utility. Make sure to look at the advanced options on the installation page, it gives you an option to flash the latest update without wiping your device at all.

That could help in getting the phone running again so you can recover your important files, before deciding to do a compete wipe, if that's what you have planned.

Just look around the settings carefully before flashing and everything should go well 🙂👍.

Thanks, will have a look around and see what I can work out. It's looking like I'll have to go this route...

DO I need to unlock the bootloader do do this flash?
 

l7777

Senior Member
May 2, 2007
545
174
Thanks, will have a look and see if this works.

DO I need to unlock the bootloader do do this flash? If so, would this wipe the device?
You do not need to bootloader unlock to use official firmware. You've been trying to do an OTA update, you can try the factory images above. Use the "link" to get a download, unzip, edit the flash-all.bat file, remove the -w from the fastboot flash update line.

Code:
fastboot -w update image-redfin-rq2a.210405.005.zip
Code:
fastboot update image-redfin-rq2a.210405.005.zip
 

WFHbot

Member
Apr 5, 2021
10
0
You do not need to bootloader unlock to use official firmware. You've been trying to do an OTA update, you can try the factory images above. Use the "link" to get a download, unzip, edit the flash-all.bat file, remove the -w from the fastboot flash update line.

Code:
fastboot -w update image-redfin-rq2a.210405.005.zip
Code:
fastboot update image-redfin-rq2a.210405.005.zip

Thanks, I tried that. Edited the file and tried running the flash-all.bat file but it's giving me an error:

Setting current slot to 'b' FAILED (remote: 'Fastboot command (set_active: ) is not allowed when locked')
fastboot: error: Command failed

Not sure what I'm doing wrong. Am I missing a step? Should the phone be on a certain menu when running the bat file?
 

bobby janow

Senior Member
Jun 15, 2010
5,718
1,872
You do not need to bootloader unlock to use official firmware. You've been trying to do an OTA update, you can try the factory images above. Use the "link" to get a download, unzip, edit the flash-all.bat file, remove the -w from the fastboot flash update line.

Code:
fastboot -w update image-redfin-rq2a.210405.005.zip
Code:
fastboot update image-redfin-rq2a.210405.005.zip
Is that a fact? I haven't had a bl unlock for many years now but I thought I could only do an OTA flash from fastboot with a locked bootloader. I know I can factory reset but other than that .. So if I loaded the beta 12 I could go back and flash a factory image? I would certainly flip the OEM switch first just in case.
 

l7777

Senior Member
May 2, 2007
545
174
Is that a fact? I haven't had a bl unlock for many years now but I thought I could only do an OTA flash from fastboot with a locked bootloader. I know I can factory reset but other than that .. So if I loaded the beta 12 I could go back and flash a factory image? I would certainly flip the OEM switch first just in case.
That's a good question. I assumed it was possible otherwise why have a factory image available. The consensus seems to be mixed though.

OP: I just did an update from January to April and yes I also got the error at 94% from ADB but the phone reported status 0. Booted up no problem. Have you tried booting into safe mode? Is USB Debugging on? Can you get a logcat of the attempted boot?
 

WFHbot

Member
Apr 5, 2021
10
0
That's a good question. I assumed it was possible otherwise why have a factory image available. The consensus seems to be mixed though.

OP: I just did an update from January to April and yes I also got the error at 94% from ADB but the phone reported status 0. Booted up no problem. Have you tried booting into safe mode? Is USB Debugging on? Can you get a logcat of the attempted boot?

Hi,

I've tried booting into safe mode by keeping the volume down button pressed but no luck.

I'm pretty sure that the USB debugging is enabled, but not 100% certain.

How would I go about getting logcat of the attempted boot?

Thanks for all the help thus far.
 

xunholyx

Recognized Contributor
Dec 3, 2012
7,640
5,211
Vancouver
Google Pixel 2 XL
Google Pixel 5
Hi,

I've tried booting into safe mode by keeping the volume down button pressed but no luck.

I'm pretty sure that the USB debugging is enabled, but not 100% certain.

How would I go about getting logcat of the attempted boot?

Thanks for all the help thus far.
You'll have to factory reset in recovery. I had something similar happen yesterday morning. The reboot was done by me on the way to work though. A factory reset fixed it. Of course all user data was wiped, but Google backups did a good job of restoring almost everything I wanted restored (except for apps not on the G Play Store of course). You'll need to sign into everything again, but most things won't be lost including root.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Are you using the latest ADB from the android SDK?

    You can always try the factory image and remove the -w from the flash-all.cmd file.
    1
    Hi, no not yet. I think this will be the last step before I factory reset. Will try another cable, laptop and the April OTA this evening when I have time.

    Thanks.
    Also a note on trying to use the web flash utility. Make sure to look at the advanced options on the installation page, it gives you an option to flash the latest update without wiping your device at all.

    That could help in getting the phone running again so you can recover your important files, before deciding to do a compete wipe, if that's what you have planned.

    Just look around the settings carefully before flashing and everything should go well 🙂👍.