Question Pixel 6 Pro network keeps dropping randomly

Search This thread

singh7

Member
Mar 4, 2016
5
3
Hi,
I never had any issue with the Pixel 6 Pro so far unlike other users but it all started few months ago when I noticed that the network kept dropping randomly, sometimes I used to get "no service" in an area where I used to get 4G at full speed. I did wait for the July update to solve the issue but it never did. Right now I am on the August update that has been released recently but I see no difference. I cannot do a smooth phone call on my data as the network keeps dropping continually. Sometimes I am on 4G, the second later I am on H. I did think that maybe it was the network I was on, Vodafone at that time, so I switched to EE, here in the UK it is considered to be the best one. Still I am facing the same issue, then I can assume it is the phone. I have tried to follow every guide I have found on the web, but nothing seems to work for me. It is annoying that when you need to get something on the phone I need to wait for the phone to go randomly back on 4G hoping that I will stay on it until I get what I need. I have attached the video that I have recorded where I am in the town centre, where I can easily get 5G but the phone keeps dropping the network.
I use ESIM as well, and I have the same issue with it.
Has anyone had the same issue? How can I solve it? Has anyone tried Android 13 Beta? Does it solve some bugs that we have right now on Android 12?
I am really annoyed because of this issue I am facing right now, I love this phone but I am seriously thinking to sell it due to this bug.



 

bunny0007

Senior Member
Jun 14, 2006
218
50
Randers
Google Pixel 6 Pro
In denmark, mine also randomly get the no service and no sim, but it is the imr registration ther fails and i beeing kicked off the celluar network. that is thanks to googles phone are not sold in your country, so you got the finger by google...

I will work with jailbreak and so on, but many apps will stop working,.
For now my pixel 6 pro, are living a sad life in its box, replaced by a oneplus 10 pro, without any of theese issues..

it is a bit sad, the pixel 6 pro is at god phone, but google giving pepole the finger, if you buy the phone somwhere google are not selling it, i dont get it.. it is basic stuff expecting to work, the culluar no mattewr where you buy it.
 
Last edited:
  • Like
Reactions: singh7

thedarkmunk

Senior Member
Dec 9, 2010
175
40
I have a P6Pro, also on EE in the UK.
I had spotty network performance in the early days, but after jumping to the 13 beta it's worked flawlessly.
Unsure if this is because of A13 or due to EE "doing work in my area" as they're often prone to doing.

I'd speak to EE first, then perhaps speak to Google via the support button in settings - they offered to swap my handset out for me (I didn't swap it out in the end).
 
  • Like
Reactions: singh7

singh7

Member
Mar 4, 2016
5
3
I have a P6Pro, also on EE in the UK.
I had spotty network performance in the early days, but after jumping to the 13 beta it's worked flawlessly.
Unsure if this is because of A13 or due to EE "doing work in my area" as they're often prone to doing.

I'd speak to EE first, then perhaps speak to Google via the support button in settings - they offered to swap my handset out for me (I didn't swap it out in the end).
When I was on Vodafone I had the same text from them, still after their ' solved ' the network issues, nothing really changed for me. My friend who is on EE in the area as me does not face any problem. I hope that A13 solves the issue. It is not normal that a 800£ phone struggles with the network this much
 

danw_oz

Senior Member
Jul 12, 2011
1,437
386
Brisbane
Hi,
I never had any issue with the Pixel 6 Pro so far unlike other users but it all started few months ago when I noticed that the network kept dropping randomly, sometimes I used to get "no service" in an area where I used to get 4G at full speed. I did wait for the July update to solve the issue but it never did. Right now I am on the August update that has been released recently but I see no difference. I cannot do a smooth phone call on my data as the network keeps dropping continually. Sometimes I am on 4G, the second later I am on H. I did think that maybe it was the network I was on, Vodafone at that time, so I switched to EE, here in the UK it is considered to be the best one. Still I am facing the same issue, then I can assume it is the phone. I have tried to follow every guide I have found on the web, but nothing seems to work for me. It is annoying that when you need to get something on the phone I need to wait for the phone to go randomly back on 4G hoping that I will stay on it until I get what I need. I have attached the video that I have recorded where I am in the town centre, where I can easily get 5G but the phone keeps dropping the network.
I use ESIM as well, and I have the same issue with it.
Has anyone had the same issue? How can I solve it? Has anyone tried Android 13 Beta? Does it solve some bugs that we have right now on Android 12?
I am really annoyed because of this issue I am facing right now, I love this phone but I am seriously thinking to sell it due to this bug.

Yeah I have the same issue as you are reporting, three drops in city on the train on the way to work. Just get the exclamation mark, does not seem to self recover, I go into the SIM and disable it, then enable it again, and it instantly jumps to full 5G signal. I do note that it is more reliable for me when I turn off 5G completely, and just use 4G, then it drops back to 3G but doesn't completely stop.

I think majority of connectivity on this device is crap. WIFI is hit and miss. Bluetooth is atrocious, super slow to connect to some older devices, was fine when the phone first came out with early firmware. Pairing devices is hit and miss and also new pairing.
 

singh7

Member
Mar 4, 2016
5
3
Yeah I have the same issue as you are reporting, three drops in city on the train on the way to work. Just get the exclamation mark, does not seem to self recover, I go into the SIM and disable it, then enable it again, and it instantly jumps to full 5G signal. I do note that it is more reliable for me when I turn off 5G completely, and just use 4G, then it drops back to 3G but doesn't completely stop.

I think majority of connectivity on this device is crap. WIFI is hit and miss. Bluetooth is atrocious, super slow to connect to some older devices, was fine when the phone first came out with early firmware. Pairing devices is hit and miss and also new pairing.
I do agree with you for the connectivity, it feels like they have picked random parts for the phone just to launch it as soon as they could. The money they spent on advertisement could have been spent better on the hardware.
Do you use dual sim? As I have read, the phone struggles more with two sims
 
  • Like
Reactions: danw_oz

danw_oz

Senior Member
Jul 12, 2011
1,437
386
Brisbane
I do agree with you for the connectivity, it feels like they have picked random parts for the phone just to launch it as soon as they could. The money they spent on advertisement could have been spent better on the hardware.
Do you use dual sim? As I have read, the phone struggles more with two sims
I have only had one SIM acitvated at a time at this stage, was having issues with trying to activate my Samsung smart watch activating 4G, so switched to physical sim, for easier troubleshooting with other mobile devices, maybe physical SIM is worse in this device
 

therock3181

Senior Member
Jun 25, 2010
588
232
Montreal
Google Pixel 6 Pro
Hi,
I never had any issue with the Pixel 6 Pro so far unlike other users but it all started few months ago when I noticed that the network kept dropping randomly, sometimes I used to get "no service" in an area where I used to get 4G at full speed. I did wait for the July update to solve the issue but it never did. Right now I am on the August update that has been released recently but I see no difference. I cannot do a smooth phone call on my data as the network keeps dropping continually. Sometimes I am on 4G, the second later I am on H. I did think that maybe it was the network I was on, Vodafone at that time, so I switched to EE, here in the UK it is considered to be the best one. Still I am facing the same issue, then I can assume it is the phone. I have tried to follow every guide I have found on the web, but nothing seems to work for me. It is annoying that when you need to get something on the phone I need to wait for the phone to go randomly back on 4G hoping that I will stay on it until I get what I need. I have attached the video that I have recorded where I am in the town centre, where I can easily get 5G but the phone keeps dropping the network.
I use ESIM as well, and I have the same issue with it.
Has anyone had the same issue? How can I solve it? Has anyone tried Android 13 Beta? Does it solve some bugs that we have right now on Android 12?
I am really annoyed because of this issue I am facing right now, I love this phone but I am seriously thinking to sell it due to this bug.



View attachment 5682195
Yup had this. Ask for a replacement. Never happen again since the phone was replaced.
 
  • Like
Reactions: danw_oz

singh7

Member
Mar 4, 2016
5
3
4G on the second sim is always off. I will try to test it turning the sim off and will let you know, thanks.
Update: the signal improve drastically on the main sim by keeping 2G or 3G on the eSIM but that generates a new problem, the eSIM drops the network on normal phone calls, it is not stable at all, if I call a number it rings after 10-15 seconds. I do not receive calls sometimes. It is just a mess.
 

Scalee

Senior Member
Aug 21, 2009
195
250
Had the same problem, calls droppping or not being able to answer calls.
I had KPN as a physical sim and Simyo as a eSim.

I did resolve the issue, I understand this is not an actual "fix", but thought i'd mention it.
I changed providers from Simyo to Simpel, now I have Simpel as physical and KPN as eSim.

Since then no more problems also the option to turn on wifi calling showed up, so I think the p6p just wasn't playing nice with that specific provider.
 

MacGuy2006

Senior Member
Sep 15, 2006
925
113
I get random total drops of data and voice connection. If I hit Airplane mode on and off, it reconnects. Maybe the phone doesn't switch well between towers? I am on Google Fi.

Between the glitches and the lack of timely updates, and the abysmal battery life, I think this will be my last Pixel phone.

It barely lasts a full day with relatively light use, but if I use Maps and listen to Youtube (screen off) ad take photos in a new town, it dies within 6 hours or less. It has a great camera, but it's not useful for travel, because it dies so quickly.
 
  • Like
Reactions: danw_oz

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi,
    I never had any issue with the Pixel 6 Pro so far unlike other users but it all started few months ago when I noticed that the network kept dropping randomly, sometimes I used to get "no service" in an area where I used to get 4G at full speed. I did wait for the July update to solve the issue but it never did. Right now I am on the August update that has been released recently but I see no difference. I cannot do a smooth phone call on my data as the network keeps dropping continually. Sometimes I am on 4G, the second later I am on H. I did think that maybe it was the network I was on, Vodafone at that time, so I switched to EE, here in the UK it is considered to be the best one. Still I am facing the same issue, then I can assume it is the phone. I have tried to follow every guide I have found on the web, but nothing seems to work for me. It is annoying that when you need to get something on the phone I need to wait for the phone to go randomly back on 4G hoping that I will stay on it until I get what I need. I have attached the video that I have recorded where I am in the town centre, where I can easily get 5G but the phone keeps dropping the network.
    I use ESIM as well, and I have the same issue with it.
    Has anyone had the same issue? How can I solve it? Has anyone tried Android 13 Beta? Does it solve some bugs that we have right now on Android 12?
    I am really annoyed because of this issue I am facing right now, I love this phone but I am seriously thinking to sell it due to this bug.



    1
    Of all the stuff people complain about, this is the only problem I have. The signal on this phone is an absolute disgrace. I lose signal where I used to get it on my Droid X back in the day. Not sure how they screwed it up that bad, but they did LOL
    1
    In denmark, mine also randomly get the no service and no sim, but it is the imr registration ther fails and i beeing kicked off the celluar network. that is thanks to googles phone are not sold in your country, so you got the finger by google...

    I will work with jailbreak and so on, but many apps will stop working,.
    For now my pixel 6 pro, are living a sad life in its box, replaced by a oneplus 10 pro, without any of theese issues..

    it is a bit sad, the pixel 6 pro is at god phone, but google giving pepole the finger, if you buy the phone somwhere google are not selling it, i dont get it.. it is basic stuff expecting to work, the culluar no mattewr where you buy it.
    1
    I have a P6Pro, also on EE in the UK.
    I had spotty network performance in the early days, but after jumping to the 13 beta it's worked flawlessly.
    Unsure if this is because of A13 or due to EE "doing work in my area" as they're often prone to doing.

    I'd speak to EE first, then perhaps speak to Google via the support button in settings - they offered to swap my handset out for me (I didn't swap it out in the end).
    1
    Yeah I have the same issue as you are reporting, three drops in city on the train on the way to work. Just get the exclamation mark, does not seem to self recover, I go into the SIM and disable it, then enable it again, and it instantly jumps to full 5G signal. I do note that it is more reliable for me when I turn off 5G completely, and just use 4G, then it drops back to 3G but doesn't completely stop.

    I think majority of connectivity on this device is crap. WIFI is hit and miss. Bluetooth is atrocious, super slow to connect to some older devices, was fine when the phone first came out with early firmware. Pairing devices is hit and miss and also new pairing.
    I do agree with you for the connectivity, it feels like they have picked random parts for the phone just to launch it as soon as they could. The money they spent on advertisement could have been spent better on the hardware.
    Do you use dual sim? As I have read, the phone struggles more with two sims