Question Pixel 6 Pro Stuck in Bootloop

Search This thread

dgstarcraft

Member
Dec 17, 2010
13
4
Hello All,

I would really appreciate your support.

My Pixel 6 Pro is stuck in a boot loop. Its just showing the google logo and white background.

I am able to access Fastboot, Recovery, etc.

I am using a MAC, and I can flash with fastboot.

Bootloader is unlocked.

Pixel is bought from Google Canada.

I tried following this tutorial
Using the Pixel 6 Pro factory images.
It flashes all the files, but then still stuck at the google logo.

Which Factory image do I flash?
 
Last edited:

roirraW "edor" ehT

Forum Moderator
Staff member
It doesn't really matter which image you flash as far as if one doesn't work to fix your boot issue then none of them will. Are you flashing the November images or the December ones which Google removed?

For the most recent November .037 images, there are only two available to choose from - one for Verizon and one for everything else. If you want to know which December image to flash, I couldn't tell you for sure since they've removed them, although I have alternate links in my thread at the top of my signature below for downloading the US Carriers December image. I know that might not be the technically correct image - I'm assuming the correct one for you was again the one that was for "everywhere else", but not sure.

The only other December image we provide download links for are I believe for the UK.

Are you using the very latest Platform Tools from Google? (Unfortunately, the site SDK Platform Tools for that doesn't appear to be working right now). I know the Windows version was r31.0.3 - I assume they keep the same version # for Mac.

Maybe you should try Official Google Android Flash Tool.
 
  • Like
Reactions: galaxys

dgstarcraft

Member
Dec 17, 2010
13
4
Here are my current steps. I am using the December or November update. I flash the bootloader, then the radio, then the factory image.
After that the device reboots to android and then stuck at the white screen with the google logo, and nothing happens. I can power off and toggle power button, into recovery or fastboot.

fastboot devices
fastboot --slot=all flash bootloader
Make sure the CMD window is selected before pressing enter!
fastboot reboot bootloader
fastboot --slot=all flash radio
fastboot reboot bootloader
fastboot --skip-reboot --slot=all update
Enter Recovery (Select this Option)
Wipe Data/Factory Reset
Reboot to Android
 

dgstarcraft

Member
Dec 17, 2010
13
4
So i flashed the November update .36.
I am able to see that when I am in the recovery screen at the top.
When I try to boot it up, it still gives me the warning that the boot loader in unlocked. Should I lock the bootloader via ADB/fastboot, and then try to power the pixel on again? Or is this not recommended, as there is a risk I wont be able to unlock it again?
can the factory image start with the boot loader unlocked?
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Awesome.

    I was just about to tell you definitely don't lock the bootloader, since you couldn't fix it with it locked. 😁

    That online method is becoming quite a savior to many folks in this section.
    3
    I got it working. Thanks. I used the google online tool.
    1
    It doesn't really matter which image you flash as far as if one doesn't work to fix your boot issue then none of them will. Are you flashing the November images or the December ones which Google removed?

    For the most recent November .037 images, there are only two available to choose from - one for Verizon and one for everything else. If you want to know which December image to flash, I couldn't tell you for sure since they've removed them, although I have alternate links in my thread at the top of my signature below for downloading the US Carriers December image. I know that might not be the technically correct image - I'm assuming the correct one for you was again the one that was for "everywhere else", but not sure.

    The only other December image we provide download links for are I believe for the UK.

    Are you using the very latest Platform Tools from Google? (Unfortunately, the site SDK Platform Tools for that doesn't appear to be working right now). I know the Windows version was r31.0.3 - I assume they keep the same version # for Mac.

    Maybe you should try Official Google Android Flash Tool.