• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

General Pixel Experience Plus v11

Search This thread

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Did anyone else notice choppy/robotic-like audio when playing ringtones/music on PE v309? Oddly enough, audio works great when placing a phone call, but there's obviously something wrong with playback with respect to other sounds.
Yes when connect to pc usb port make the same noice for 2-3 seconds.
Haven't tried other usage,having trouble with root,and trying to figure the cause of issue.
I had root for few minutes after a few minutes it was lost by itself for unknown reason,reboot system and never boot.

Now re flashing again PE to try for a second time to gain root access.

Does dt2w works on you or not btw?
Not for me.
 
Last edited:

vctrmtlnd

Senior Member
Jul 26, 2016
57
17
I hope that the developer comes up with a fix for the audio issues! I wonder if the latest firmware makes any difference?

(I haven't tried dt2w)
 

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Back to eu 12.5.2. as can't get root access.

First attempt patched boot img reboot system but never got root working.
Repeat flashing patched boot img never boot normally,it stuck to mi logo(bootloop)
Screenshot 2021-06-21 225909.png


It supposed this buld resolve the Magisk installation bug but it hasn't been fixed eventually.
Until being fixed in next build i'm out of PE.
 
Last edited:
  • Like
Reactions: rayman95

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Installed the new build many features and customization added but again not able get root.
 

Attachments

  • Screenshot_20210622-224106_Settings.png
    Screenshot_20210622-224106_Settings.png
    117.6 KB · Views: 55
  • Screenshot_20210622-224041_Settings.png
    Screenshot_20210622-224041_Settings.png
    144.2 KB · Views: 55
  • Screenshot_20210622-224018_Settings.png
    Screenshot_20210622-224018_Settings.png
    117.7 KB · Views: 55

vctrmtlnd

Senior Member
Jul 26, 2016
57
17
Looks like the most recent build is for PE Plus, whereas the previous build was for PE standard. Was the garbled audio bug still present when you flashed the latest PE Plus build, @paatha13 ?
 

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Looks like the most recent build is for PE Plus, whereas the previous build was for PE standard. Was the garbled audio bug still present when you flashed the latest PE Plus build, @paatha13 ?
The audio bug remains but only form the speaker,from bluetoth headset tried listening music all normal with the sound but the most good news, battery drain of previoius build has been fixed with the new one.
Left the phone overnight for 7 hours airplane mode and still the battery was 100%

Now only dropped to 99% after using the phone for 2-3 minutes.

I will stay with PE for now hoping new build fixed the Magisk installation and audio playback bug.

Another minor issue is that the lowest level of brightness is higher than it shoud ,but i i have third party app to resolve and minimze the level of minimal brighness.
Dt2w still not working though.
Also phone operates at 60hz no 90hz available at all.
 

Attachments

  • Screenshot_20210622-140841_Settings (1).png
    Screenshot_20210622-140841_Settings (1).png
    131.1 KB · Views: 30
Last edited:

vctrmtlnd

Senior Member
Jul 26, 2016
57
17
Thanks for sharing, @paatha13 ! It's promising to hear that some of these issues have already been resolved in the latest v309 PE Plus. I'll try to stay in touch with everyone here throughout these early builds to share my experience too.

I'm on v309 of PE Standard and have been using it as a daily driver since 06/21. Issues so far:
- RCS messages come through, though SMS messages are only received when the SIM card is removed and reinserted.
- Significant battery drain (100% to 50% in ~8hrs)
- Adaptive brightness higher than it should be, and during sunrise/sunset, brightness adjustments ramp up and down repeatedly until the ambient light environment is stable
- Phone call audio is ok, though music and notification sounds are choppy/garbled. If I connect to a Bluetooth audio device, the same applies.
- When accepting a phone call, speakerphone is active and I need to manually toggle speakerphone off so that I can put the phone to my ear and hear the caller speak privately
- Occasionally, the boot process gets stuck on the Mi logo, and I'll have to go into recovery and select reboot to system in order to boot. Alternatively, I've found that instead of rebooting, a power off and power on often results in a successful boot.

Is anyone in touch with the developer, Ponces?
 

vctrmtlnd

Senior Member
Jul 26, 2016
57
17
Good news! I was able to connect with the developer, Ponces, and he was able to suggest some fixes from phhusson's work and I can confirm that they work!

Garbled/choppy audio & speakerphoneissues:
Settings -> Phh Treble Settings -> Misc features -> Disable audio effects
Settings -> Phh Treble Settings -> Qualcomm features -> Use alternate audio policy

SMS messages not received:
Settings -> Phh Treble Settings -> Qualcomm features -> IMS features -> Install IMS APK for Qualcomm vendor


Has anyone tried to flash any of the latest global firmware to see if this makes any difference with the remaining issues?
 
Last edited:
  • Like
Reactions: paatha13

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens

Attachments

  • Screenshot_2021-06-27-16-14-46-868_com.android.settings.jpg
    Screenshot_2021-06-27-16-14-46-868_com.android.settings.jpg
    220.7 KB · Views: 30
  • IMG_20210627_161524.jpg
    IMG_20210627_161524.jpg
    161.7 KB · Views: 31
Last edited:

vctrmtlnd

Senior Member
Jul 26, 2016
57
17

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Has anyone tried to flash any of the latest global firmware to see if this makes any difference with the remaining issues?

When you say that PE only boots when coming from the 12.5.2 MIUI base ROM, does that also imply that upgrading to any newer firmware bundles may prevent the device from booting?
We can't answer for sure for future miui build.
Let's see when 12.5.3 eu stable release to check it
I will check it.

Can you asked the developer if having solution or workaround getting magisk installation works and gain root access or we have to wait next PE Plus build??
 
Last edited:

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Miui eu stable 12.5.3 is released today installed it and on top of that installed PE Plus all ok with with the second, boot normally without issue.

But unfortunately still the Magisk installation issue remains.


All other issue remains too like phone works only at 60hz and no 90hz,also dt2w still not working.
 

Attachments

  • Screenshot_2021-06-22-17-33-35-069_com.android.settings.jpg
    Screenshot_2021-06-22-17-33-35-069_com.android.settings.jpg
    197.3 KB · Views: 39
  • Screenshot_2021-06-22-17-33-19-710_com.android.settings.jpg
    Screenshot_2021-06-22-17-33-19-710_com.android.settings.jpg
    226.2 KB · Views: 39
Last edited:

kangxicome

New member
Mar 12, 2009
2
2
Xiaomi Mi 6
Xiaomi Mi Pad 4
Looks like there's a new build up as of 2021-06-19 (v309). For everyone receiving the "Partition not found" error, here is the solution to get the system image to flash.

- Reboot to fastboot
- From a terminal, type: fastboot reboot fastboot
- The device should now be in FASTBOOTD mode. Note, the D after FASTBOOT!
- Now, you can flash by typing the following at a terminal: fastboot flash system PixelExperience_arm64-ab-11.0-20210619-UNOFFICIAL.img
- fastboot reboot recovery
- Select format data
- Reboot to system




I'm not sure if both system_a and system_b partitions need to be flashed. Maybe someone else with more experience with GSIs can chime in?

It works. Have to use latest fastboot in SDK Platform Tools. The one in XiaoMi Flash Tools is old, and do NOT support "fastboot reboot fastboot"
 

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
Finally with today PE build, Magisk installed properly without any issue.
 

Attachments

  • Screenshot_20210714_074538.png
    Screenshot_20210714_074538.png
    108.4 KB · Views: 24
  • Screenshot_20210714_075842.png
    Screenshot_20210714_075842.png
    63.1 KB · Views: 24
  • Screenshot_20210714_075834.png
    Screenshot_20210714_075834.png
    156.9 KB · Views: 17
  • Screenshot_20210714_080239.png
    Screenshot_20210714_080239.png
    305.1 KB · Views: 24

paatha13

Senior Member
Jul 27, 2016
2,089
809
Athens
any issues with PE in general? I guess only 60hz, no 90hz refresh rate?
Unfortunately same bugs or missing features 2 months now like 90hz not existing at all, dt2w does not work on any build, automated brightness is very bad(too bright even on slightly light condition indoor and too bright on dark environments at night.

Vibration feels somehow weird and cheap.

The sound bug remaims too and need the workaround in order to work mention previously post.

Battery is good, very good but at 60hz operation that is the just normal, 90hz is mandatory and must be added.

Those are basic bugs like 90hz or dt2w shouldn't exist at all.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    To be claim, i am NOT the maintianer.

    Today, i want to share a GSI for every use of this phone and try to give everyone the lightest feeling of system to match the weight of this phone. So after hunders of fastboot flash, i succeesfully boot in system after flash, hope everyone can try and if any issue, you can commit this thread or pull a issue to this gsi github.

    CLICK Guthub TO DOWNLOAD the "PixelExperience_Plus_arm-ab-11.0-xxxxxxxx-UNOFFICIAL.img.xz"

    Three steps to flash:
    1,Backup all your data and unzip the file you downloaded from github BTW.
    2,If you want to get Magisk, flash Magisk before you flash PE. Without flash new bootimg, Magisk will be permanent.(option)
    2,connect to computer and use command <adb reboot fastboot> or press vol- and power to rebbot to the fastboot mode.
    3,use command<fastboot flash system xxx.img> to flash PEPlus, <fastboot reboot> to boot into system.

    BTW, I am the people who are not native speakers of English, so if i use some wrong word, just let it go if didn't confuse you.

    Hope you success.

    If feedback of this rom is good, i will base on it to maintain the ROM that only for Mi11 Lite.
    3
    Looks like there's a new build up as of 2021-06-19 (v309). For everyone receiving the "Partition not found" error, here is the solution to get the system image to flash.

    - Reboot to fastboot
    - From a terminal, type: fastboot reboot fastboot
    - The device should now be in FASTBOOTD mode. Note, the D after FASTBOOT!
    - Now, you can flash by typing the following at a terminal: fastboot flash system PixelExperience_arm64-ab-11.0-20210619-UNOFFICIAL.img
    - fastboot reboot recovery
    - Select format data
    - Reboot to system


    $ fastboot flash system PixelExperience_arm64-ab-11.0-20210619-UNOFFICIAL.img
    Resizing 'system_a' OKAY [ 0.004s]
    Sending sparse 'system_a' 1/14 (262140 KB) OKAY [ 10.507s]
    Writing 'system_a' OKAY [ 0.655s]
    Sending sparse 'system_a' 2/14 (262140 KB) OKAY [ 10.230s]
    Writing 'system_a' OKAY [ 0.582s]
    Sending sparse 'system_a' 3/14 (262140 KB) OKAY [ 9.928s]
    Writing 'system_a' OKAY [ 0.616s]
    Sending sparse 'system_a' 4/14 (262140 KB) OKAY [ 9.031s]
    Writing 'system_a' OKAY [ 0.617s]
    Sending sparse 'system_a' 5/14 (262140 KB) OKAY [ 8.220s]
    Writing 'system_a' OKAY [ 0.584s]
    Sending sparse 'system_a' 6/14 (262140 KB) OKAY [ 7.821s]
    Writing 'system_a' OKAY [ 0.595s]
    Sending sparse 'system_a' 7/14 (262140 KB) OKAY [ 8.438s]
    Writing 'system_a' OKAY [ 0.582s]
    Sending sparse 'system_a' 8/14 (262140 KB) OKAY [ 7.481s]
    Writing 'system_a' OKAY [ 0.615s]
    Sending sparse 'system_a' 9/14 (262140 KB) OKAY [ 8.163s]
    Writing 'system_a' OKAY [ 0.605s]
    Sending sparse 'system_a' 10/14 (262140 KB) OKAY [ 8.062s]
    Writing 'system_a' OKAY [ 0.582s]
    Sending sparse 'system_a' 11/14 (262140 KB) OKAY [ 7.877s]
    Writing 'system_a' OKAY [ 0.584s]
    Sending sparse 'system_a' 12/14 (262140 KB) OKAY [ 7.901s]
    Writing 'system_a' OKAY [ 0.615s]
    Sending sparse 'system_a' 13/14 (262140 KB) OKAY [ 8.012s]
    Writing 'system_a' OKAY [ 0.564s]
    Sending sparse 'system_a' 14/14 (151444 KB) OKAY [ 4.686s]
    Writing 'system_a' OKAY [ 0.386s]
    Finished. Total time: 124.552s

    I'm not sure if both system_a and system_b partitions need to be flashed. Maybe someone else with more experience with GSIs can chime in?
    1
    Hi, which version to download, a only or ab??? Is there a way to debloat it before flashing??? Does it wipe data???
    Thanks
    Download ab version.
    I don't think we con debolat it before flash
    And yes it will wipe all your data.
    1
    Thanks for your answer...what's the vndklite and is there advantage...I would like the more debloat, or with R/W....
    I did finding a way to get R/W according to patch the ROM without TWRP
    1
    Good news! I was able to connect with the developer, Ponces, and he was able to suggest some fixes from phhusson's work and I can confirm that they work!

    Garbled/choppy audio & speakerphoneissues:
    Settings -> Phh Treble Settings -> Misc features -> Disable audio effects
    Settings -> Phh Treble Settings -> Qualcomm features -> Use alternate audio policy

    SMS messages not received:
    Settings -> Phh Treble Settings -> Qualcomm features -> IMS features -> Install IMS APK for Qualcomm vendor


    Has anyone tried to flash any of the latest global firmware to see if this makes any difference with the remaining issues?