Playing Music Cuts On Lock Screen

Search This thread

nigsy116

Member
Apr 25, 2010
38
8
Hi;

Just set the phone up but am having issues with music playback with any app.
As soon as the black lock screen comes up the music stops; if I then wake the screen up by touching a button the music restarts; anyone come across this issue? Or have a fix?
**Update**
Ok it only seems to work with the stock music app - not player pro / vlc or anything else. Is this a permissions issue?
 
Last edited:

djlukas1983

Senior Member
Aug 20, 2009
783
179
Hi;

Just set the phone up but am having issues with music playback with any app.
As soon as the black lock screen comes up the music stops; if I then wake the screen up by touching a button the music restarts; anyone come across this issue? Or have a fix?
**Update**
Ok it only seems to work with the stock music app - not player pro / vlc or anything else. Is this a permissions issue?
I think it's related to a battery saving options.

Sent from my htc_m8 using XDA Labs
 

CrzMtz

New member
May 29, 2018
1
0
I have the same issues with my P20 lite. I think that the battery management has something to do about this. I looked into the battery and apps settings to allow my music player (BlackPlayer) all the permissions, but still having the music stopped. It's really annoying
 

nigsy116

Member
Apr 25, 2010
38
8
Fixed!!

I have the same issues with my P20 lite. I think that the battery management has something to do about this. I looked into the battery and apps settings to allow my music player (BlackPlayer) all the permissions, but still having the music stopped. It's really annoying

You're right it's a battery issue. If you go to settings > Battery > App Launch and set the apps you want to 'Manage Manually' you can leave them running in the background; this gets you over the issue.
This fixed several apps not running as I'd expected. The default action close the apps down as soon as the screen locks to save power.
 

A.Pul

Member
Oct 3, 2018
6
0
You're right it's a battery issue. If you go to settings > Battery > App Launch and set the apps you want to 'Manage Manually' you can leave them running in the background; this gets you over the issue.
This fixed several apps not running as I'd expected. The default action close the apps down as soon as the screen locks to save power.
Yes, we can fix by using 'Manage Manually' setting but I see that some other apps, such as Google Play Music, Zing MP3...still play music in background normally without setting it.
I wonder how they can pass this issue? Or Huawei has different treatments for each apps?
 
Last edited:

jonboi

Senior Member
Jul 23, 2010
88
14
Yes, we can fix by using 'Manage Manually' setting but I see that some other apps, such as Google Play Music, Zing MP3...still play music in background normally without setting it.
I wonder how they can pass this issue? Or Huawei has different treatments for each apps?

I had to do this with spotify. It's an android thing, not specifically a huawei issue. I had this issue on an S9 i had on loan too.

As mentioned, it's just a power saving option. Just manage the app manually and it will continue to play.
 
  • Like
Reactions: A.Pul

A.Pul

Member
Oct 3, 2018
6
0
I had to do this with spotify. It's an android thing, not specifically a huawei issue. I had this issue on an S9 i had on loan too.

As mentioned, it's just a power saving option. Just manage the app manually and it will continue to play.

Thanks for your answer. Can we check if the app has been managing automatically? If yes, I want to show a dialog to guide user go to the setting screen. (Because user may not know this setting)
 

gd6noob

Senior Member
Apr 29, 2011
1,805
268
Anyone figured this out?
I'm using YouTube music with premium subscription.
I have edit the battery settings to Manage Manually and enabled all 3 sub options. After screenlock, msuci stop. I dnt have any battery saving options set
 

maff90

Senior Member
Jan 12, 2009
73
2
Okay I know this is an old thread, but thought I'd post what I found on my mate 20 pro, it's quite hidden away!
Settings -> Apps -> Apps -> 3 dot menu -> Special Access -> Battery Optimisation
Select 'All apps' from the drop down, and then select 'Don't allow' on the app you want to stop huawei from quitting
 

pat_1234567

New member
Mar 10, 2021
1
0
It works for me, try this.
beside your app in the "allowed" battery optimization list. the Google Play Service too must be exampt.

Battery Optimization > Google Play Service > Not Allowed (it drains battery)
- do the same for the music app.

App Launch > 3 dots on top right corner > Show System process > Google Play Service > Manage Automatically.
- do the same for your music app

i hope it works as it did for me
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Fixed!!

    I have the same issues with my P20 lite. I think that the battery management has something to do about this. I looked into the battery and apps settings to allow my music player (BlackPlayer) all the permissions, but still having the music stopped. It's really annoying

    You're right it's a battery issue. If you go to settings > Battery > App Launch and set the apps you want to 'Manage Manually' you can leave them running in the background; this gets you over the issue.
    This fixed several apps not running as I'd expected. The default action close the apps down as soon as the screen locks to save power.
    1
    Yes, we can fix by using 'Manage Manually' setting but I see that some other apps, such as Google Play Music, Zing MP3...still play music in background normally without setting it.
    I wonder how they can pass this issue? Or Huawei has different treatments for each apps?

    I had to do this with spotify. It's an android thing, not specifically a huawei issue. I had this issue on an S9 i had on loan too.

    As mentioned, it's just a power saving option. Just manage the app manually and it will continue to play.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone