Please help... ADB is stuck "waiting for any device"

Search This thread

Privacydroid

Member
Aug 10, 2022
23
2
For 8 hours i have been trying to install TWRP recovery on my Sony Xperia XA2 Pioneer H3113.
On PC i installed UniversalAdbDrivers from here https://adb.clockworkmod.com/ and platform-tools_r33.0.2-windows from here https://developer.android.com/studio/releases/platform-tools
I also downloaded the latest twrp-3.6.2_9-0 here https://eu.dl.twrp.me/pioneer/twrp-3.6.2_9-0-pioneer.img.html and LineageOS here https://wiki.lineageos.org/devices/pioneer/

When i try to boot the phone in recovery mode by pressing volumedown and power it vibrates 3 times and then does nothing. Is the recovery damaged or wtf is going on?
When i press volumeup and power the phone boots normally to system instead of downloadmode or sometimes it vibrates once and then reboots.
If i remember correctly i was able to boot into recoverymode aswell as downloadmode and now none of them works but i did not make any changes to the phone.

So pressing volumeup and connecting the phone to the pc is nothing but a huge mess, sometimes the LED is green, sometimes to display goes on saying SONY, sometimes it shows the battery status and eventually if im lucky the LED goes blue meaning i should be in downloadmode... When i then open the CMD to type adb devices it starts the daemon.
However this might be a cable issue im not sure but the phone will randomly be disconnected from the pc (windows makes that sound always), meaning sometimes when i type adb devices it starts the daemon but most of the time the cmd gives no output. So i tried immediatly after the daemon started to execute the command "fastboot flash recovery twrp-3.6.2_9-0-pioneer.img"
CMD output is ALWAYS the exact same: "waiting for any device".
This **** is driving me mad, i'f been searching for a fix on many websites reading tons of articles and watching tons of youtube videos, nothing worked.
After all that i beleve the issue has something to do with windows drivers. I should mentioned that the windows device manager shows the phone as unknown usb device with a yellow error mark. I can't find USB drivers for the Xperia XA2, no idea if that exists...
Im starting to think a phone repair shop or the sony companion program might be the only solution...

I saw so many people having the same "waiting for any device" issue, but none had a real solution... really hope someone here can help..

fk.PNG

Can anyone help? What am i doing wrong that other people with XA2 didn't?

1.PNG

2.PNG
 
Last edited by a moderator: