[PLEASE HELP] Sony's Last FW & Flashtool Problem with Xperia™ XZ

Search This thread

Mazellat

Senior Member
Mar 25, 2012
1,739
1,319
0
30
Konya
Hi dear friends. I have a interesting problem with Flashtool and Sony's last OREO update.

I want to flash 41.3.A.2.58 with flashtool. If I use old version of flashtool v0.9.23.2, I can connect my phone flash mode, but I can't flash last oreo update from Sony I get "NULL" error.. If I use newest version of flashtool 0.9.24.2, The FW was preparing to flash but my phone doesn't connect with flash mode so this time I get this "ERROR - Device connected in flash mode but driver is too old". I installed driver which is in the folder of newest Flashtool.I didn't understand what I did wrong. I am using Flashtool many years but I can't solve this problem. Please check the pictures.

FLASHTOOL v0.9.23.2
Z9Dgag.png



FLASHTOOL v0.9.24.2
BLMmgV.png
 
Last edited:

Mazellat

Senior Member
Mar 25, 2012
1,739
1,319
0
30
Konya
v9.24.2 is the latest version. You may update your drivers from C:\Flashtool\drivers\Flashtool-drivers.exe and select the correct drivers you need (capture in attachment).

I am using last version too. And I installed last version driver but no luck you can see the pictures up :(
 

koekoek91

Senior Member
Mar 7, 2016
1,246
516
143
29
I am using last version also but I get old driver error...

Oh nevermind I now see your second screenshot is from the latest version.

Have you tried reinstalling drivers?
And have you tried redownloading the firmware or a different firmware maybe?
 
Last edited:

Mazellat

Senior Member
Mar 25, 2012
1,739
1,319
0
30
Konya
Oh nevermind I now see your second screenshot is from the latest version.

Have you tried reinstalling drivers?
And have you tried redownloading the firmware or a different firmware maybe?

Bro I tried to install again and again Flashtool and drivers. But no luck...
 

G-UN1T

Senior Member
May 15, 2016
95
42
0
Vranje
boot ur phone in to download (flash) mode, go to device manager, expand universal serial bus controllers, then find somc device. "uninstall" delete the driver software. than unplug usb and repeat againg, boot into flashmode (not need flashtool any time) go into device manager, expand universal s b c, look for somc devices, or "semc device" if find delete again, if u see in un/recognized "android" u are done. now go to drivers from flashtool and install flashmode... i was installed flashmode and fastboot. while u installing that drivers look at "Android" now is again "somc device" and already version like a last flashmode driver. but different now is, now u can flash ur phone with latest flashtool by "ANDROXYDE" sorry about bad english, but i hope u understand me.
 

NoReason456

New member
Feb 5, 2018
1
1
0
As G-Un1t say, start in flash mode and unistall all "semc" devices, and do that until u get the "semc" unrecognized, then disconnect, reinstall the flashmode and fastboot drivers again and then once again connect in flash mode.

Works for me on triying upgrade a Sony C5 Ultra(for latin america) From Lollipop to Mashmallow.
 
  • Like
Reactions: leopoel

Fanadez

New member
Feb 19, 2018
1
0
0
U have to repeatedly uninstall the SOMC devices, then SEMC devices till you see an "Android Driver" with a yellow ? mark..... Your are good to go after that...... thanks G-UN1T
 

SuryaHamtaro

New member
Feb 24, 2018
1
0
0
Try this one

1. Download the relevant driver package from developer.sonymobile.com/downloads/drivers/. Make a note of the package folder name and of where you unzip the files.
2. Open Device Manager. You can do this by clicking Start, and then typing device manager. Then click Device Manager.
3. In Device Manager, right-click the name of your computer at the top of the device list, then click Add legacy hardware.
4. In the Welcome to the Add Hardware Wizard dialog, click Next.
5. Select the Install the hardware that I manually select from a list option, and then click Next.
6. Highlight Show All Devices and click Next.
7. Click Have Disk....
8. In the Install From Disk dialog, click Browse, and then find (see your note from step 1) and select the driver file ending with adb (written as xxxxxadb, where xxxxxx is the unique file name). Click Open.
9. In the Install From Disk dialog, click OK.
10. Highlight the Sony xxxxxx ADB Interface Driver file, then click Next twice. The installation starts.
11. Click Finish and then restart your computer.

hope this one help you guys
 

richardt75

Member
Jun 26, 2017
15
3
3
Samsung Galaxy Note 9
on this thread i finally found my problem solver for Device connected in flash mode but driver is too old, thank you

i just deleted SEMC driver on Device Manager of my 7-64bit, install driver from the folder of Flashtool,
Checklist Fastboot, Flashmode Drivers, and also Xperia Z3+ drivers, followed the instruction about 2012 method, and its worked

mine is E6553 Single...almost lost hope and thinking about suicide.

solved my undetected Sim Card problem too, after trying many Custom ROMs without any luck..
but some problem of noise sounds like sound of mouse while accessed internet or transmitted data was still unsolved

im using this one..E6553_32.3.A.0.372_R3D_Customized RU_1295-0592.ftf
all Nougat custom roms that i found cannot solved my undetected simcard was RR, and LA

now im going to put TWRP and root this one...

btw, i found that this Stock Rom made my Z3+ coolest that any Nougat Custom Roms, is so conform like never before
 
Last edited:
  • Like
Reactions: Willocse17

pijes

Senior Member
May 21, 2010
1,101
269
113
I had similar issue last week, turns out the cable was connected to the usb3 port on my laptop. once I plug it into usb2 port then it was fine.
 
  • Like
Reactions: gl3nborj

danielgrigori

New member
May 26, 2018
2
0
0
Hi dear friends. I have a interesting problem with Flashtool and Sony's last OREO update.

I want to flash 41.3.A.2.58 with flashtool. If I use old version of flashtool v0.9.23.2, I can connect my phone flash mode, but I can't flash last oreo update from Sony I get "NULL" error.. If I use newest version of flashtool 0.9.24.2, The FW was preparing to flash but my phone doesn't connect with flash mode so this time I get this "ERROR - Device connected in flash mode but driver is too old". I installed driver which is in the folder of newest Flashtool.I didn't understand what I did wrong. I am using Flashtool many years but I can't solve this problem. Please check the pictures.

FLASHTOOL v0.9.23.2
Z9Dgag.png



FLASHTOOL v0.9.24.2
BLMmgV.png




I have the same issue! ERROR - Device connected in flash mode but driver is too old.
 

jojorov

Member
Dec 1, 2013
7
0
0
Hi, I had the same issue. I solved it by plugging into a USB 2.0 port instead of 3.0. I 'm not sure why but this is what works for me all the time. Hope it works for someone too.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    boot ur phone in to download (flash) mode, go to device manager, expand universal serial bus controllers, then find somc device. "uninstall" delete the driver software. than unplug usb and repeat againg, boot into flashmode (not need flashtool any time) go into device manager, expand universal s b c, look for somc devices, or "semc device" if find delete again, if u see in un/recognized "android" u are done. now go to drivers from flashtool and install flashmode... i was installed flashmode and fastboot. while u installing that drivers look at "Android" now is again "somc device" and already version like a last flashmode driver. but different now is, now u can flash ur phone with latest flashtool by "ANDROXYDE" sorry about bad english, but i hope u understand me.
    4
    v9.24.2 is the latest version. You may update your drivers from C:\Flashtool\drivers\Flashtool-drivers.exe and select the correct drivers you need (capture in attachment).
    1
    There is an update for flashtool. I suggest you update and try again :)

    I am using last version also but I get old driver error...
    1
    As G-Un1t say, start in flash mode and unistall all "semc" devices, and do that until u get the "semc" unrecognized, then disconnect, reinstall the flashmode and fastboot drivers again and then once again connect in flash mode.

    Works for me on triying upgrade a Sony C5 Ultra(for latin america) From Lollipop to Mashmallow.
    1
    on this thread i finally found my problem solver for Device connected in flash mode but driver is too old, thank you

    i just deleted SEMC driver on Device Manager of my 7-64bit, install driver from the folder of Flashtool,
    Checklist Fastboot, Flashmode Drivers, and also Xperia Z3+ drivers, followed the instruction about 2012 method, and its worked

    mine is E6553 Single...almost lost hope and thinking about suicide.

    solved my undetected Sim Card problem too, after trying many Custom ROMs without any luck..
    but some problem of noise sounds like sound of mouse while accessed internet or transmitted data was still unsolved

    im using this one..E6553_32.3.A.0.372_R3D_Customized RU_1295-0592.ftf
    all Nougat custom roms that i found cannot solved my undetected simcard was RR, and LA

    now im going to put TWRP and root this one...

    btw, i found that this Stock Rom made my Z3+ coolest that any Nougat Custom Roms, is so conform like never before
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone