poco m3 does not turn on anymore

Search This thread

ogy_j

Senior Member
Jul 9, 2011
181
27
Hi !
I've remove the shield protector but the phone react the same as before

Phone is discharge, when i plug the charger the screen show battery
Then i've got Poco animation for 3 seconds then i've got charging amination

When i'm trying to power on the phone, the screen goes black
Then i have to wait the battery to discharge again
I also tried to charge until 20% then try to power on :(

Before and after removal the shield the phone react the same way

I've sucessfully start the phone one time but i don't remember what exactly i did....
 
  • Like
Reactions: sarabbafrani
Apr 19, 2022
5
0
Hi !
I've remove the shield protector but the phone react the same as before

Phone is discharge, when i plug the charger the screen show battery
Then i've got Poco animation for 3 seconds then i've got charging amination

When i'm trying to power on the phone, the screen goes black
Then i have to wait the battery to discharge again
I also tried to charge until 20% then try to power on :(

Before and after removal the shield the phone react the same way

I've sucessfully start the phone one time but i don't remember what exactly i did....
How did you discharge the battery?
 

leofa

Senior Member
Jan 7, 2008
52
7
Hi !
I've remove the shield protector but the phone react the same as before

Phone is discharge, when i plug the charger the screen show battery
Then i've got Poco animation for 3 seconds then i've got charging amination

When i'm trying to power on the phone, the screen goes black
Then i have to wait the battery to discharge again
I also tried to charge until 20% then try to power on :(

Before and after removal the shield the phone react the same way

I've sucessfully start the phone one time but i don't remember what exactly i did....
I was having the exact same problem. But prior to shield removal, it wasn't even charging (showing charge animation or anything like that).

After removing, it was behaving like yours but after one our checking, I realized that I wasn't assembling the board correctly and the board wasn't touching the buttons conectors on the botton left side of the board, near where the buttons are located on the phone. after checking that, phone worked like a charm. Rebooted multiple times, turned off and on and no problems at all so far.

Thanks @sarabbafrani !
 
Last edited:

ogy_j

Senior Member
Jul 9, 2011
181
27
For the first charge, how many % of battery did you turn on the phone ?
When i'm pressing power button for 4 secondes, the phone turn black screen
I tried 2% 5% 10% 15% 20% 30%
for the moment nothing is working :(


edit : damnnn i've just broke the power button..
 
Last edited:

sarabbafrani

Senior Member
Dec 20, 2012
56
48
isfahan-IRAN
For the first charge, how many % of battery did you turn on the phone ?
When i'm pressing power button for 4 secondes, the phone turn black screen
I tried 2% 5% 10% 15% 20% 30%
for the moment nothing is working :(


edit : damnnn i've just broke the power button..
For the first charge, how many % of battery did you turn on the phone ?
When i'm pressing power button for 4 secondes, the phone turn black screen
I tried 2% 5% 10% 15% 20% 30%
for the moment nothing is working :(


edit : damnnn i've just broke the power button..
Do like me
Your phone will power up IMG_20220427_150150.jpgIMG_20220427_150718.jpg
 
  • Like
Reactions: ogy_j and Sus_i

ogy_j

Senior Member
Jul 9, 2011
181
27
No more battery sign, since the power buton is broken. Everything seems well plugged

Before, when battery is not plug in the motherboard, and i plug the charger, i have battery sign on the screen but no more now... :(
Capture.PNG

I can't press it anymore it
 
  • Like
Reactions: sarabbafrani

ogy_j

Senior Member
Jul 9, 2011
181
27
Yes i've order a new one, but without this, the phone won't show battery sign on the LCD..
I hope this is it otherwise there is something wrong on the motherboard
 
  • Like
Reactions: sarabbafrani

sylvio2000

Member
Nov 2, 2016
21
4
Hi.
Just a quick info for you (hope I can translate it correctly to english):
On monday I have sent my poco m3 to xiaomi. They said, if it is a hardware error they repair it for free. If not, they tell what the repair will cost.
Today (thursday) they wrote that they have to order a spare part to repair it.

Somebody here wrote xiaomi changed the mainboard of his phone. Maybe they do the same with mine. I never would have thought that they really repair such a cheap smartphone. I thought they just give me a new one 😁
 
Apr 19, 2022
5
0
Guys, how long do i have to wait for battery to fully discharge?.
It's a week and some days now, when i connect my phone to PC it still indicate by making the windows sound.
Before it was making double sound but now it only makes a single sound, the method I'm using to discharge is tying rubber bound with a piece of paper to the power button.
 

ANerdyNub

Member
Apr 16, 2022
8
0
Guys, how long do i have to wait for battery to fully discharge?.
It's a week and some days now, when i connect my phone to PC it still indicate by making the windows sound.
Before it was making double sound but now it only makes a single sound, the method I'm using to discharge is tying rubber bound with a piece of paper to the power button.
depends on how much the battery was when you turned it off but for me it still took 3 days when I had 2% so I'm not sure
 

Linuxkek

Senior Member
May 29, 2019
380
64
Afaik wifi antenna connects automatically, if you add the backcover. There are two spring connectors in the back/top of the phone.

The antenna for 3g/4g mobile data signal, there is a small connector with a wire and we need to connect this manually...
So it can be the antenne if Wifi and 2G works but no 4G? But how it can find 4G network (see screenshot)?

I get my M3 back (warranty case) and anything works but no 4G. I also try to set it LTE only with *#*#4636#*#* but than no signal at all.
 

Attachments

  • Screenshot_2022-04-30-23-20-35-711_com.android.phone.jpg
    Screenshot_2022-04-30-23-20-35-711_com.android.phone.jpg
    242.1 KB · Views: 10

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    permanent and ultimate fix. just remove shield
    then reassemble phone

    * There is no isolation ( inner side of shield)
    To prevent contact between capacitor and shield then we can isolate it or just removing that shield

    Just do it with edl (Qualcomm 9008) condition (your pc will detect it when installing that driver in device manager ports)

    After that all if any problem persistent connect with my WhatsApp i will answer
    +989131074612

    youtube:
    any questions? connect with my WhatsApp
    i will tell details
    4
    - CONFIRMED! -

    I was little suspicious about @sarabbafrani advice, but it actually worked!

    My Poco M3 went nuts after shutting down the alarm clock, only few symbols visible on the screen but otherwise totally unusable. I was able to power up the screen or shut it down but couldn't access the phone software. Only option was to reboot or shutdown with power button.

    After reboot, the phone went totally dead. Couldn't boot up, not with long press power or power + volume up (or down). Plugging in the charger didn't do anything, no vibrations, nothing.

    I did that phone disassembly, remove battery connector, push power button and plug battery again = normal boot. After this happened about 3 times within a month, I decided to try sarabbafrani solution.

    Tear down the phone, remove plastic main board cover, took all 3 cameras away, disconnected antenna and took the main board away.

    I had only hot air gun and decided to cover other parts with aluminium foil. First, I tried speed 1, but no success. Then full power, 5-10 sec blowing 10cm distance, firm grip with pliers and heat shield was out. It almost fell down. Do not use excessive force!

    After cooling down I put motherboard back in and tried that same procedure with power button + battery cable in = nothing :( I thought I fried the whole thing. But when I plugged in the charger it showed the Poco logo and battery level - that's new. Decided to put everything back together.

    It required a long press for power button and the phone started normally! I even did a software restart and it started normally. Charging works also normally.

    I've been using it now only for few hours but hopefully the fix is permanent.

    2.jpg


    1.jpg
    3
    If the draining battery method worked for you, you should do the mentioned fix...
    Otherwise the deadboot can happen anytime again. Worst case, in between an update or something like that.
    It depends on distance between shield and capacitor
    In some cases these two contacted all times
    In other cases if main board gets warm then capacitor connects to shield it will gets warmer and more battery usage
    I didn't have a soldering station or a heat gun available and since the alternative was to throw everything in the garbage, I removed the shield in a somewhat barbaric way. I took a fixed screwdriver with a wide tip and inserted it in the middle and with a little pressure the shield came off
    🤦🤦🤦 Do not attack in this way
    I should tell it for all owners
    1.Take off all cameras 2. Be careful about plastic parts 3. Cover all other parts from heating 4. Carefully heat that ic shield about 380-400°C 5. Carefully picking up vertically with Tweezers (be careful for shaking , pcb is hot with parts under shield ic and caps)
    Heat untill shield base solder gets weaker
    Pick it up without force because pcb ways may broken and affects on mobile network amplifier
    You can test mobile network with this code
    *#*#4636#*#* gsm only lte only and wcdma only
    Image attached, pcb damage after removing shield cold
    3
    permanent and ultimate fix. just remove shield
    then reassemble phone
    youtube:
    any questions? connect with my WhatsApp
    i will tell details
    Thnx my Poco M3 is now able to restart even shutdown. It always Boot.
    3
    FIX , FIX, FIX. My poco m3 stopped booting up/recovery/bootloader. Tried disconnecting battery connector, display connector, reheating but nothing worked permanent. Only solution was to wait for the battery to drain after which charge it enough to boot it. That worked but i couldn`t use recovery or bootloader until battery discharged and then booted it to recovery/bootloader as first boot. I contacted my friend from whom i bought the device from. He said its possibly due to some short circuit and all i had to do was clean the charging port (where the charger is connected) and the ear phone plug port with a tooth brush (bristles of tooth brush should be straight) dipped in 3-4 drops of petrol. At the time my phone was dead and was waiting for the battery to drain. However i followed my friends instructions and cleaned the charging and ear phone ports. After allowing the ports to dry i tried to boot the phone. It didn`t boot remaining dead. I had to wait a day+ for the battery to drain. I then charged it until it booted. I then tried to reboot it into bootloader and it WORKED. I treid recovery and it WORKED. Now AlhamdoLILLAH my phone is good as new except the marks on the cover made when i removed the cover. Try your luck Gentlemen.