Question POCO X4 Pro 5G AMOLED screen shows some bright spots on dark/black images.

Search This thread
first go to a dark room and do this
1- open a plane black image in gallery
2- make sure auto brightness turned off and adjust the brightness into specific level where you face the
dark white issue leave the brightness level to that point
3- apply this plane image as your lock screen wallpaper
4- reboot the device
5- once it reboot into lock screen the lock screen wallpaper become completely black but after a second the problem comes black become a light dark color
do this couple of times and I feel the same
thats why i am confused whether its a software bug
 

Attachments

  • 2131.jpg
    2131.jpg
    10.9 KB · Views: 72

HfTFranz

Member
Mar 7, 2022
8
3
first go to a dark room and do this
1- open a plane black image in gallery
2- make sure auto brightness turned off and adjust the brightness into specific level where you face the
dark white issue leave the brightness level to that point
3- apply this plane image as your lock screen wallpaper
4- reboot the device
5- once it reboot into lock screen the lock screen wallpaper become completely black but after a second the problem comes black become a light dark color
do this couple of times and I feel the same
thats why i am confused whether its a software bug
Yep. That is also why I thought it would be a software issue, since I have observed exactly what you have observed as well. In fact, it works with any wallpaper. Upon the first seconds after boot, the wallpaper shows a very color accurate version. Then it becomes very bright and the issue returns.

Even if it is fixable through software, it doesn't explain why this is only present on some phones.

Either way, I have already received my refund and I am buying a different phone. Staying away from Xiaomi until they fix their quality control issues. Good luck with your issue.
 

Danny Sia

Member
May 19, 2022
15
2
Hello everyone! I just got my POCO X4 Pro 5G phone yesterday. I absolutely love using it to bits.
However, I noticed that while browsing through content on medium (40 - 50%) brightness, the phone does not actually go fully dark. Some parts are lit up while others are not. (On dark videos and imagery, it is noticeable enough to really bother me even on just my first day of use.)
To elaborate on my point, I have downloaded a completely black picture and displayed it on my phone.

I have attached the photos below.



View attachment 5562541
Setup. (This is the phone displaying a completely black image on my gallery)

View attachment 5562537
Lights off (Captured on my Samsung A50 normal mode)

View attachment 5562539
Lights off (Captured on Night Mode)

I have tried to capture it on video, but it is simply not visible enough on video to be worth your time. You'll simply have to trust that I indeed downloaded a completely black image and displayed it on my gallery. (I wouldn't be posting here for no reason if I was lying, wouldn't I?)



Anyway, it is worth noting that on both higher (60-70%) and lowest (0-10%) brightness, the issue disappears completely (e.g. the screen completely shuts off as expected.) but then some of it return on maximum brightness.

Now I can definitely use the screen all the time on these settings, but I also want to ensure the longevity of my AMOLED screen, and it would suck to always be watching content on effectively only two brightness settings.



I have tried using AMOLED Fixer apps on Google Play but to no avail.

Does anyone else have this issue? Do you think it is fixable through software? Should I return the phone to POCO before it's too late?

Thank you for any responses in advance.
Same here. The AMOLED panel on the Poco X4 Pro 5G doesn't go fully dark when I set to around 15 - 60% brightness but when I set to 15% lower and 60% - 70% higher, the issue disappear complete.

I also noticed when my phone on recovery mode and poco logo boot, issue also disappear.

I think it was a software issue. Xiaomi must fix it!


Here's I already attacted the pictue below
IMG_20220503_003422.jpg
 
Last edited:

Danny Sia

Member
May 19, 2022
15
2
first go to a dark room and do this
1- open a plane black image in gallery
2- make sure auto brightness turned off and adjust the brightness into specific level where you face the
dark white issue leave the brightness level to that point
3- apply this plane image as your lock screen wallpaper
4- reboot the device
5- once it reboot into lock screen the lock screen wallpaper become completely black but after a second the problem comes black become a light dark color
do this couple of times and I feel the same
thats why i am confused whether its a software bug
What you say is right,

1- I apply a pure black as lock screen wallpaper

2- Next step is I press the reboot button

3- Once it reboot into lock screen, the lock screen wallpaper become completely but after 3 - 5 seconds the problem comes black.


I don't know why is this happen but i sure that its a software bug. AMOLED screen must be black right?
 

razr96

Senior Member
Jul 29, 2016
202
78
This issue was occurring when I was on MIUI, but now doesn't show up on Pixel Experience. It's definitely a pure software issue that Xiaomi has to fix.
 

Danny Sia

Member
May 19, 2022
15
2
Have anyone already do a custom ROM? If so, can someone compare their display between stock miui and a custom ROM to see if still have display issue.
 

razr96

Senior Member
Jul 29, 2016
202
78
you tried pe? how s the experience? is that solved?
Pixel experience works fine except for two bugs: the proximity sensor is not working and Bluetooth calling is apparently broken (I have not tried that yet). Both bugs seems to require Xioami to release the kernel source if they are to be fixed.

Yes the display issue is solved.
 
  • Like
Reactions: Danny Sia
Same here. The AMOLED panel on the Poco X4 Pro 5G doesn't go fully dark when I set to around 15 - 60% brightness but when I set to 15% lower and 60% - 70% higher, the issue disappear complete.

I also noticed when my phone on recovery mode and poco logo boot, issue also disappear.

I think it was a software issue. Xiaomi must fix it!


Here's I already attacted the pictue below
View attachment 5618217
did you ever factory reset your mobile?
 
  • Like
Reactions: Danny Sia

Vincent Foxx

Senior Member
Jun 18, 2020
93
22
Brawley
Checked this on my redmi note 11 pro 5g, has the same issue. Below a certain brightness the pixels turn off.

Maybe a software bug from xiaomi roms. I haven't had the chance to test this on any other than Xiaome.eu and Stock.
But i've noticed when the system built in AoD works like it should pixels turn off.
 
  • Like
Reactions: Danny Sia

Danny Sia

Member
May 19, 2022
15
2
Checked this on my redmi note 11 pro 5g, has the same issue. Below a certain brightness the pixels turn off.

Maybe a software bug from xiaomi roms. I haven't had the chance to test this on any other than Xiaome.eu and Stock.
But i've noticed when the system built in AoD works like it should pixels turn off.
Really? At the first I thought this issue was only happens on the x4 pro but i guess redmi note 11 pro 5g also have this issue.
 
Hello, I'm chiming in to say that I am able to replicate the issue on my Redmi Note 11 Pro 5G. The purple-ish tone on blacks I can only notice on certain apps like youtube, though. It's not that big of a deal, because on my most used brightness setting it's not present, but it is a bit inconvenient.

Definitely a software issue. I urge everyone to file a report to Xiaomi so this gets fixed ASAP. It's a shame because I'm pretty happy with the phone besides this issue.
 

Danny Sia

Member
May 19, 2022
15
2
Hello, I'm chiming in to say that I am able to replicate the issue on my Redmi Note 11 Pro 5G. The purple-ish tone on blacks I can only notice on certain apps like youtube, though. It's not that big of a deal, because on my most used brightness setting it's not present, but it is a bit inconvenient.

Definitely a software issue. I urge everyone to file a report to Xiaomi so this gets fixed ASAP. It's a shame because I'm pretty happy with the phone besides this issue.
I already file a complaint about display issue. Let's see if Xiaomi will fix this issue ASAP.
 

Attachments

  • Screenshot_2022-05-25-23-36-13-216_com.miui.bugreport.jpg
    Screenshot_2022-05-25-23-36-13-216_com.miui.bugreport.jpg
    372.9 KB · Views: 52

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Just disable 120hz and it goes back to showing pure blacks.
    Absolutely NOT true.
    ... At least in my case
  • 3
    Guys, try this app called Oreo colorizer. This solves the issue.

    It forces the display to shift its color space to DCI-P3 instead of the default sRGB according to the below XDA thread.

    So the issue is software related. NOT HARDWARE. Hope Xiaomi solves this issue by software update.


    2
    Hello everyone! I just got my POCO X4 Pro 5G phone yesterday. I absolutely love using it to bits.
    However, I noticed that while browsing through content on medium (40 - 50%) brightness, the phone does not actually go fully dark. Some parts are lit up while others are not. (On dark videos and imagery, it is noticeable enough to really bother me even on just my first day of use.)
    To elaborate on my point, I have downloaded a completely black picture and displayed it on my phone.

    I have attached the photos below.



    275513745_1129114954488978_6138308308493212417_n.jpg
    Setup. (This is the phone displaying a completely black image on my gallery)

    275570781_464626962076332_7702657492806435969_n.jpg
    Lights off (Captured on my Samsung A50 normal mode)

    275709035_499222575038636_1820128928702185979_n.jpg
    Lights off (Captured on Night Mode)

    I have tried to capture it on video, but it is simply not visible enough on video to be worth your time. You'll simply have to trust that I indeed downloaded a completely black image and displayed it on my gallery. (I wouldn't be posting here for no reason if I was lying, wouldn't I?)



    Anyway, it is worth noting that on both higher (60-70%) and lowest (0-10%) brightness, the issue disappears completely (e.g. the screen completely shuts off as expected.) but then some of it return on maximum brightness.

    Now I can definitely use the screen all the time on these settings, but I also want to ensure the longevity of my AMOLED screen, and it would suck to always be watching content on effectively only two brightness settings.



    I have tried using AMOLED Fixer apps on Google Play but to no avail.

    Does anyone else have this issue? Do you think it is fixable through software? Should I return the phone to POCO before it's too late?

    Thank you for any responses in advance.
    1
    I am not able to reproduce this on my device. I've tried all brightness levels, no weird spots on my end. Maybe you should RMA your device. But let's wait and see if anyone else is having this issue.
    1
    I am not able to reproduce this on my device. I've tried all brightness levels, no weird spots on my end. Maybe you should RMA your device. But let's wait and see if anyone else is having this issue.
    Thanks for your input. I did find someone on reddit having a similar problem to mine, on his mi 11 lite. Unfortunately, the solution offered on his replies does not exist on my phone's settings (I can't find P3 anywhere).

    https://www.reddit.com/r/Xiaomi/comments/ouqbws
    This makes me feel like it could be a software issue, and I'm really liking everything else about the phone so far so I'm still thinking twice about going through the return process. But I still have some time to think about it for now. Please let me know if you find a similar problem with a potential solution!
    1
    Just disable 120hz and it goes back to showing pure blacks.
    Absolutely NOT true.
    ... At least in my case