Question POCO X4 Pro 5G AMOLED screen shows some bright spots on dark/black images.

Search This thread

Khan Subhaan

Member
Jul 10, 2022
8
0
Hello everyone! I just got my POCO X4 Pro 5G phone yesterday. I absolutely love using it to bits.
However, I noticed that while browsing through content on medium (40 - 50%) brightness, the phone does not actually go fully dark. Some parts are lit up while others are not. (On dark videos and imagery, it is noticeable enough to really bother me even on just my first day of use.)
To elaborate on my point, I have downloaded a completely black picture and displayed it on my phone.

I have attached the photos below.



View attachment 5562541
Setup. (This is the phone displaying a completely black image on my gallery)

View attachment 5562537
Lights off (Captured on my Samsung A50 normal mode)

View attachment 5562539
Lights off (Captured on Night Mode)

I have tried to capture it on video, but it is simply not visible enough on video to be worth your time. You'll simply have to trust that I indeed downloaded a completely black image and displayed it on my gallery. (I wouldn't be posting here for no reason if I was lying, wouldn't I?)



Anyway, it is worth noting that on both higher (60-70%) and lowest (0-10%) brightness, the issue disappears completely (e.g. the screen completely shuts off as expected.) but then some of it return on maximum brightness.

Now I can definitely use the screen all the time on these settings, but I also want to ensure the longevity of my AMOLED screen, and it would suck to always be watching content on effectively only two brightness settings.



I have tried using AMOLED Fixer apps on Google Play but to no avail.

Does anyone else have this issue? Do you think it is fixable through software? Should I return the phone to POCO before it's too late?

Thank you for any responses in advance.
I had the same issue u had turns out that mi screens adjust their display because of the amount of light is reflecting on the screen and is indeed a software issue mi team doesn't have the solution for this yet , idk when they will fix this ( I'm posting this comment on my poco x4 pro 5g )
 

MmahrabSshaon

Member
Jun 10, 2020
7
1
Hello everyone! I just got my POCO X4 Pro 5G phone yesterday. I absolutely love using it to bits.
However, I noticed that while browsing through content on medium (40 - 50%) brightness, the phone does not actually go fully dark. Some parts are lit up while others are not. (On dark videos and imagery, it is noticeable enough to really bother me even on just my first day of use.)
To elaborate on my point, I have downloaded a completely black picture and displayed it on my phone.

I have attached the photos below.



View attachment 5562541
Setup. (This is the phone displaying a completely black image on my gallery)

View attachment 5562537
Lights off (Captured on my Samsung A50 normal mode)

View attachment 5562539
Lights off (Captured on Night Mode)

I have tried to capture it on video, but it is simply not visible enough on video to be worth your time. You'll simply have to trust that I indeed downloaded a completely black image and displayed it on my gallery. (I wouldn't be posting here for no reason if I was lying, wouldn't I?)



Anyway, it is worth noting that on both higher (60-70%) and lowest (0-10%) brightness, the issue disappears completely (e.g. the screen completely shuts off as expected.) but then some of it return on maximum brightness.

Now I can definitely use the screen all the time on these settings, but I also want to ensure the longevity of my AMOLED screen, and it would suck to always be watching content on effectively only two brightness settings.



I have tried using AMOLED Fixer apps on Google Play but to no avail.

Does anyone else have this issue? Do you think it is fixable through software? Should I return the phone to POCO before it's too late?

Thank you for any responses in advance.
Yes bro, u are right.. but it have a solution.. i gave this feedback to support center.. here it is:


in full dark mode or on a black image it doesn't shows amoled black. it looks like lcd black screen on top and bottom side of the phone. it's so annoying that and amoled screen is leaking backlit on a pure black screen. it's a software issu... because there is a solution for it with a third party app called oreo colorize. but it eats my cpu gpu and battery.. you should fix this as soon as possible. there is another prove that on fastboot mode and recovery mode, it shows pure black, on poco and android logo it shows pure black, but while it starts up and comes on miui logo the top sides pixels emitting lights. Please fix this issu... here is the xda link of this problem everyone faces: https://forum.xda-developers.com/t/...ark-black-images.4417039/page-3#post-87122853

Please fix this.. otherwise experience is getting worst with poco 😓
I hope you will make an update and fix this problem soon.. Love poco ❤️
 
  • Like
Reactions: SFG006

stone_henge

Senior Member
Sep 10, 2014
281
249
POCO X4 Pro
Using a Redmi Note 11 Pro 5g (Global) (veux) I can confirm this issue exists, and in the exact similar way OP described in his posts and comments.
I hope they fix it in the upcoming updates. Although I can not be too hopeful as they give little to no attention to these type of "minor" user objections -_-
 

fmrogonhantu

Member
Apr 15, 2012
12
1
I thought im the only one having this problems.hopes Xiaomi can come with a fix soon

Never had these kind of problems on my previous devices.note 10 pro,poco f3,a51
 

SFG006

New member
Aug 5, 2022
1
0
Absolutely NOT true.
... At least in my case
Same i my case too

How can we fix this bright spot in dark Black issue?

Yes bro, u are right.. but it have a solution.. i gave this feedback to support center.. here it is:


in full dark mode or on a black image it doesn't shows amoled black. it looks like lcd black screen on top and bottom side of the phone. it's so annoying that and amoled screen is leaking backlit on a pure black screen. it's a software issu... because there is a solution for it with a third party app called oreo colorize. but it eats my cpu gpu and battery.. you should fix this as soon as possible. there is another prove that on fastboot mode and recovery mode, it shows pure black, on poco and android logo it shows pure black, but while it starts up and comes on miui logo the top sides pixels emitting lights. Please fix this issu... here is the xda link of this problem everyone faces: https://forum.xda-developers.com/t/...ark-black-images.4417039/page-3#post-87122853

Please fix this.. otherwise experience is getting worst with poco 😓
I hope you will make an update and fix this problem soon.. Love poco ❤️
Having the same issue bro, can u help me?
 

Vincent Foxx

Senior Member
Jun 18, 2020
108
23
Brawley
Anyone have any news for a fix for this so far? Having the same issue with my x4 pro
Disable 120hz go to 60hz. This works for me,
or the oreo colorizer works for 120hz enabled, but makes color little bad.

i just leave it at 120hz all day without the oreo colorizer, i'm always on a bright room so the blacks are way better than lcd screens.
 

Khan Subhaan

Member
Jul 10, 2022
8
0
Disable 120hz go to 60hz. This works for me,
or the oreo colorizer works for 120hz enabled, but makes color little bad.

i just leave it at 120hz all day without the oreo colorizer, i'm always on a bright room so the blacks are way better than lcd screens.
Oreo Colourizer fixes the screen bleeding but it doesn't fix the Screen flickering issue the screen doesn't flicker on 60hz but does flicker when it's on 120hz hope poco would fix these issues....
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Android 12 still not fixed..
    Do they even know about the issue?
  • 3
    Guys, try this app called Oreo colorizer. This solves the issue.

    It forces the display to shift its color space to DCI-P3 instead of the default sRGB according to the below XDA thread.

    So the issue is software related. NOT HARDWARE. Hope Xiaomi solves this issue by software update.


    2
    Hello everyone! I just got my POCO X4 Pro 5G phone yesterday. I absolutely love using it to bits.
    However, I noticed that while browsing through content on medium (40 - 50%) brightness, the phone does not actually go fully dark. Some parts are lit up while others are not. (On dark videos and imagery, it is noticeable enough to really bother me even on just my first day of use.)
    To elaborate on my point, I have downloaded a completely black picture and displayed it on my phone.

    I have attached the photos below.



    275513745_1129114954488978_6138308308493212417_n.jpg
    Setup. (This is the phone displaying a completely black image on my gallery)

    275570781_464626962076332_7702657492806435969_n.jpg
    Lights off (Captured on my Samsung A50 normal mode)

    275709035_499222575038636_1820128928702185979_n.jpg
    Lights off (Captured on Night Mode)

    I have tried to capture it on video, but it is simply not visible enough on video to be worth your time. You'll simply have to trust that I indeed downloaded a completely black image and displayed it on my gallery. (I wouldn't be posting here for no reason if I was lying, wouldn't I?)



    Anyway, it is worth noting that on both higher (60-70%) and lowest (0-10%) brightness, the issue disappears completely (e.g. the screen completely shuts off as expected.) but then some of it return on maximum brightness.

    Now I can definitely use the screen all the time on these settings, but I also want to ensure the longevity of my AMOLED screen, and it would suck to always be watching content on effectively only two brightness settings.



    I have tried using AMOLED Fixer apps on Google Play but to no avail.

    Does anyone else have this issue? Do you think it is fixable through software? Should I return the phone to POCO before it's too late?

    Thank you for any responses in advance.
    2
    Just disable 120hz and it goes back to showing pure blacks.
    Absolutely NOT true.
    ... At least in my case
    1
    I am not able to reproduce this on my device. I've tried all brightness levels, no weird spots on my end. Maybe you should RMA your device. But let's wait and see if anyone else is having this issue.
    1
    Android 12 still not fixed..
    Do they even know about the issue?