• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Poor Reception

Search This thread

OuncE718

Senior Member
Feb 27, 2010
2,227
361
32
DC by way of BK
I am getting worse reception with my OPO than my m7. Additionally my signal continues to fluctuate much more often (meaning switching from 3g,3g+ and LTE). I'm on T-mobile, is anyone else having this issue?

You're definitely not the only one. I have the same issue. Even my WiFi reception isn't as strong as my Nexus 5 used to be. I guess we can't complain since the phone isn't officially released yet. We're basically beta testers.

Sent from my One using XDA Premium 4 mobile app
 
  • Like
Reactions: kyleallen5000

stephenta

Senior Member
Jul 11, 2010
87
8
Also have major issues. It could be poor hardware but I am hoping a software fix will help. On my N5 i had full bars of LTE at my work desk. On the oneplus my phone goes from LTE to HSPA+ to HPSA at my desk... somrthing needs to be fixed :(
 
  • Like
Reactions: kyleallen5000

DirtyDroidX

Senior Member
Jan 7, 2011
343
257
Pittsburgh
If anyone is on ATT I was getting 1.7 average download speeds. Go into settings and make sure your APN is set to this ↓

a8ame8as.jpg



This put me at 25-30mbps [emoji3]

Sent from my One using Tapatalk
 

d4fseeker

Senior Member
Oct 16, 2010
1,300
437
I am getting worse reception with my OPO than my m7. Additionally my signal continues to fluctuate much more often (meaning switching from 3g,3g+ and LTE). I'm on T-mobile, is anyone else having this issue?

The signal is significantly better than my S3, both in WIFI and mobile (3G) data.i don't know about the M7 but the Nexus 5 is known for it's excellent connectivity so it's pretty hard to top that.
 

coolguy949

Senior Member
Nov 4, 2008
294
51
Orange County, CA
I am having the same issue. My OPO has trouble holding LTE and switches between H and H+ constantly. It causes data to lag, noticeable when scrolling through social networking feeds or using remote desktop. My speed tests are also much slower than my S4 using my SIM. Here my friend who also has AT&T LTE met me and we tested speeds on the same server. He has the M8. We are both on the same APN.

5ugyvy7u.jpg
 

randaddy

Senior Member
Jun 19, 2006
117
22
Bay Area, CA
Same for me, in the same places my Xperia Z1 and LG G2 both got much better LTE reception. CM11s is more conservative in regards to bars/dbm on the status bar...which is fine. BUT the constant switching between HSPA and LTE is causing me to miss some SMS messages, and that's unacceptable. Also, crap LTE speeds on AT&T (when I can actually hold on to a LTE signal long enough).

Keep in mind, I'm in the SF Bay Area, we have LTE EVERYWHERE.

I've had my RMA open since 7/20, all they've done is email me once a day with questions regarding where I'm using it/what cases I have on the phone. No resolution.
 
Last edited:

ap1618

Senior Member
Sep 10, 2010
536
31
Los Angeles
For the constant network switching issue between lte and hspa, dial *#*#4636#*#*,then click phone information. In there, select your band selection to be "lte/gsm auto PRL"... That should make the lte connection much more stable.
 
  • Like
Reactions: wingedpanther

Tired of the Bull

Senior Member
Jun 22, 2010
188
50
Virginia Beach
There is a real problem here, maybe more than one.

My signal strength is horrible in areas where other phones are fine. I'm on T-Mobile usually connecting to LTE Band 4. At home my phone is always -117db or worse and disconnects frequently. When it disconnects from LTE it doesn't switch to the available GSM even though setup for LTE/GSM auto PRL. I can force a connection to GSM but the levels are still bad at -95 or worse but stays connected.
 

galaxys3some

Senior Member
May 6, 2014
52
2
I have metro PCs so when I do *#*#4636#*#* it does nothing to correct the problem. I use to get late everywhere with no drop in signal with my Samsung mega and when I converted over to the one I've had nothing but issues and makes me regret buying the phone and selling my mega. Whats a great phone if you can't get stable lte service.

Sent from my A0001 using XDA Premium 4 mobile app
 

playya

Senior Member
Jan 12, 2007
6,873
2,514
Florida
I am assuming you guys have all tried the different radios and different roms available to you in the forum? I know it may not work for some but have you guys tried? T-Mobile customers can get the tower in there house if you have bad reception there. So some issues can be resolved maybe not all of them
 

yosef_a

Member
Jul 30, 2012
13
2
Hey
*#*#3646#*#*
Helped me
On phone setting there are 3 dots there I selected the right frequency for my carrier
Hope I helped

Sent from my A0001 using XDA Free mobile app
 

dburckh

Senior Member
Jan 26, 2011
260
91
Hey
*#*#3646#*#*
Helped me
On phone setting there are 3 dots there I selected the right frequency for my carrier
Hope I helped

Sent from my A0001 using XDA Free mobile app

So, what's interesting is that the phone does not list 1700/2100, which is T-Mobile (In Denver). It only lists 1900 (AT&T). Could that be part of the problem?

FYI: It's *#*#4636#*#*
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I am getting worse reception with my OPO than my m7. Additionally my signal continues to fluctuate much more often (meaning switching from 3g,3g+ and LTE). I'm on T-mobile, is anyone else having this issue?

    You're definitely not the only one. I have the same issue. Even my WiFi reception isn't as strong as my Nexus 5 used to be. I guess we can't complain since the phone isn't officially released yet. We're basically beta testers.

    Sent from my One using XDA Premium 4 mobile app
    1
    Also have major issues. It could be poor hardware but I am hoping a software fix will help. On my N5 i had full bars of LTE at my work desk. On the oneplus my phone goes from LTE to HSPA+ to HPSA at my desk... somrthing needs to be fixed :(
    1
    For the constant network switching issue between lte and hspa, dial *#*#4636#*#*,then click phone information. In there, select your band selection to be "lte/gsm auto PRL"... That should make the lte connection much more stable.