• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Poor touchscreen latency?

Do you experience poor touchscreen latency (input lag) with the Nexus 5X?

  • Yes

    Votes: 83 67.5%
  • No

    Votes: 40 32.5%

  • Total voters
    123
Search This thread

ianmc_uk

Member
Dec 5, 2011
9
1
Has anyone else found the scroll/swipe speed to be slow on the Nexus 5X compared to other handsets? Annoyingly, I can't find any settings for this.

The issue is global and not limited to one app. With pointer trails on, there is visible lag between my finger's input and what happens on-screen. I've never seen this on any other device.

Thanks,
Ian
 

ianmc_uk

Member
Dec 5, 2011
9
1
Ah, I hadn't spotted that! I've tested, it is significantly worse when charging. Barely noticeable / normal on battery.

Sent from my Nexus 5X using Tapatalk
 

Evo_Shift

Senior Member
Jan 17, 2011
2,347
482
Yikes...the fact it changes with charging would make me nervous that it is a hardware defect, like bad grounding or something.
 

james7dean

Member
Nov 19, 2010
22
3
My phone is unusable whilst charging due to the touch screen lag!!!

---------- Post added at 09:25 PM ---------- Previous post was at 08:48 PM ----------

This could be a real deal breaker for me as I use my phone frequently whilst plugged in and charging. I will give it approximately a week to find a solution otherwise back it goes under the distance selling regulations.: (
 

qwerty12601

Senior Member
May 29, 2009
312
82
Been an LG problem since the G2. Buggy, stuttering laggy response from display while charging. Nexus 5 did it, G2, G3 etc. Some people report different chargers affect how bad it can be or possibly cure it. But that's a challenge when everything is proprietary to the 5x.

That's the worst news I've heard about this device so far. Lots of things can be dealt with. But when you HAVE to use it while charging this could be a deal breaker. Damn.
 

thesoldier

Senior Member
Nov 18, 2012
1,419
357
29
Baltimore
I've noticed this happens on a number of devices (including an iPhone 5s) and found it's due to a cheap wall charger that can't regulate voltage properly. Anybody happen to have aftermarket wall chargers or can plug it into a USB 3.0 port? Maybe somehow the stock chargers have a defect.

Sent from my SM-G920V using Tapatalk
 

james7dean

Member
Nov 19, 2010
22
3
I have tried charging with a USB A to USB C cable and this fixes the touch screen lag so it does appear to be an issue with the supplied charger or cable.
 

chamdogg

New member
Oct 21, 2015
3
0
I'm experiencing the same issue when the phone is charging using the supplied charger.

Just tried a separate cable I bought and plugged it into a USB 3 port and it seems to be better.

Not the best start to owning a brand new phone....
 

oscillik

Senior Member
Mar 19, 2009
960
155
Widnes
am I correct in thinking that in order for an electrical device to be 'grounded', it must have an 'earth' pin in the plug?

generally, USB power adapters to not have an earth - US ones don't, and UK ones do not either (they have a plastic pin instead of an actual metal pin).

I could be barking up the wrong tree, of course but still... may be a factor?
 

ref1ux

Senior Member
Aug 21, 2009
252
36
Mine does this when charging. Seems to be worst in the bottom right of the screen. Annoying.
 

james7dean

Member
Nov 19, 2010
22
3
I took my 5X back to Carphone Warehouse due to this issue and another audio problem. The assistant whom helped me was great and the replacement 5X no longer has the issues I was suffering. I am typing this whilst charging right now something that was almost impossible on the previous device. I urge all others with this problem to exchange their device.
 

Hayth

Senior Member
Feb 15, 2012
388
141
Leicester
I find it only occurs when I'm fast charging, has the issue gone for you on both slow and fast charging?

Sent from my Nexus 5X using Tapatalk
 

ianmc_uk

Member
Dec 5, 2011
9
1
That sounds positive james7dean. I'd be interested to hear if this issue doesn't appear to be present on later units (later than day 1 purchases anyway) for others too - it would be a pain to return the handset and start again, but worth doing if its going to work!

Thanks,
Ian
 

dbrohrer

Senior Member
Nov 21, 2012
212
111
Austin
My 5x was manufactured Oct 2015 and I don't have this issue.

The devices manufactured in September 2015 seem to have more problems (yellow screen, poor performance, etc). I wander if there is a correlation here.
 

ianmc_uk

Member
Dec 5, 2011
9
1
My 5x was manufactured Oct 2015 and I don't have this issue.

The devices manufactured in September 2015 seem to have more problems (yellow screen, poor performance, etc). I wander if there is a correlation here.
Thanks! How do you find out the manufacture date?

Sent from my Nexus 5X using Tapatalk
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Help Google to Solve This Issue

    For those following this unfolding, I've been campaigning and investigating this issue across Reddit and the Google Product Forums, and we now have an actual Googler who worked on the 5X's touchscreen looking into this with his team. The Googler in question assures me they are actively investigating this internally and deciding what to do, and are acquiring chargers and carrying out tests to see what's going on 'in the wild'.

    We also have the attention of a very knowledgable moderator/volunteer on the Google Product Forums who has the ability to pass information directly to the Nexus phone engineers. However, he reports that they need data. So please, if you have a 5X and are experiencing strange touchscreen behaviour whilst Rapid Charging, go to this post on the Google Product Forums and answer the following questions (my comments in square brackets):

    • There is a metal ring around the fingerprint sensor on the back of the phone. Does continuously touching the fingerprint ring on the back make the issue go away? [most reports suggest this works, as it grounds the device]
    • Do you see the issue with both high-speed charging and low/no-speed charging? For example, if battery is low vs full, do you see a difference? [most reports find this issue only noticeable in Rapid Charging state]
    • Try different outlets in your home/office/etc - do they all fail equally?
    • Do you see the issue with any other chargers? If so, which?
    • Which cord are you using to charge? The official one, or a third-party cable?
    • Specific details, such as the build date of your phone would help (This is the first 3 numbers of your S/N [printed on the label on the box your phone came in], usually starting 5__ )
    • What is the serial number printed on your charger?

    The more people that can answer these questions on that thread, the more that Google have to work with and the faster they'll be able to diagnose what's going on here.

    Cheers
    1
    I find it only occurs when I'm fast charging, has the issue gone for you on both slow and fast charging?

    Sent from my Nexus 5X using Tapatalk
    After replacing my 5X I have no issues with the touchscreen whilst charging rapidly. I urge all others with this issue to seek a replacement.
    1
    To all those that decided to send the device back due to this issue - did they send you a new one or were they attempting to repair it?
    The problem lies with the charger - I exchanged my phone for a new one and have the same problem. The Google product forum for this issue has more detail.

    Sent from my Nexus 5X using Tapatalk
    1
    There's a long thread on the Google Nexus Support Forums which has pretty conclusively confirmed is the supplied OEM chargers in some territories lack of a proper earth/ground in combination with insufficient shielding on the screen that causes this problem. Multiple reports that the Google Store generic 3amp USB C charger which has a proper earth/ground does not cause this lag. One or two reports of retailers acknowledging this and offering partial refunds for the end user to purchase the Google Store charger.

    I've got a UK device, the lag is bad with the OEM charger. But I rarely use the device when charging so I don't really care.