• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Poor USB Connection

Search This thread

kRYySTy

Senior Member
May 16, 2012
210
29
Timisoara
Did anyone else experiencing poor/unreliable usb connection on htc one? I mean it keeps disconnecting randomly while connected to pc, and imediatly connect back again. I wanted to s-off the phone but not succed because of this problem. Tried 2 computers and also 2 usb cables. Should i send it to repair?
 

nkk71

Inactive Recognized Developer / Contributor
May 26, 2010
8,743
7,572
50
Beirut
Did anyone else experiencing poor/unreliable usb connection on htc one? I mean it keeps disconnecting randomly while connected to pc, and imediatly connect back again. I wanted to s-off the phone but not succed because of this problem. Tried 2 computers and also 2 usb cables. Should i send it to repair?

Try cleaning the phone's USB port first (for example using a compressed air can, or any other method you find suitable), maybe it's just some debris in there.

If that doesn't fix it, then yes, off to repair, because it will only get worse over time.
 

nkk71

Inactive Recognized Developer / Contributor
May 26, 2010
8,743
7,572
50
Beirut
The problem is that if i charge the phone with that cable it doesn't disconnect at all.

I would say it's cause the PC connection, uses different/more pins, than a normal charger... so for the time being the charging ones are still good, but not the ones to "talk" to your PC.... since it does "come and go", it could just be debris in there.

Or it could be a hardware problem that could get worse over time.
 
  • Like
Reactions: kRYySTy

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    The problem is that if i charge the phone with that cable it doesn't disconnect at all.

    I would say it's cause the PC connection, uses different/more pins, than a normal charger... so for the time being the charging ones are still good, but not the ones to "talk" to your PC.... since it does "come and go", it could just be debris in there.

    Or it could be a hardware problem that could get worse over time.