(PORT) (4.0+) (All Devices) (PS4 Remote Play Port)

Search This thread

Rican

Member
Nov 25, 2008
25
6
Happy and thankful to announce my T-Mobile Note 4 running Darth Stalker v2 is running like a dream with this. Made sure remote play settings were good to go, installed app, already had sixaxis so I enabled game pad and made the button changes, hooked it up to my ps4 controller via an otg kit someone posted here (mega dream mobile phone clamp with otg cable off of amazon) and badabim badaboom everything worked great. Have not been able to try it with the ps4 at home, but I'm positive it will be even better. Right now I'm running the ps4 off of my note 4 hotspot at work and the lag is very minimal. Was able to play cow mw zombies and still get through a couple of rounds without a hiccup. Found that I can't long press ps button or samsung's s finder pops up on the phone. Workaround, use screen virtual buttons for long pressing ps button. Thank you so much op "clicky thanks"
 

voetbalremco

Inactive Recognized Developer
Jan 6, 2012
4,623
1,879
gelderland
Once again, this has been mentioned quite some times in this tooic already, but this version is outdated.

New and active version can be found here:
http://forum.xda-developers.com/android/apps-games/ps4-remote-play-t2929147

It includes a lot of fixes including the root check removed, no need to delete superuser or use xposed + root cloak any more in order to get remote play to work.
Also, the speed checks have been removed so the connection should be more stable.
The controller is still a pain in the ass but connection works trough the Sixaxis app.

All with all, the other version is newer, better, gets updates , and also is much more easily to install.

Please stop posting in this thread and move on to the new one:
http://forum.xda-developers.com/android/apps-games/ps4-remote-play-t2929147

Once more, head over to the new thread.
That version has been updated more recently and works much better.
 

voetbalremco

Inactive Recognized Developer
Jan 6, 2012
4,623
1,879
gelderland
Please stop, I just followed your link and the thread has been closed. This is the main thread now.

Sent from my Nexus 5 using XDA Free mobile app

Sorry, my old post still linked the old thread, wich has been closed.
This might sound confusing but the actual main thread is this, wich is the one I meant to link:

http://forum.xda-developers.com/android/apps-games/ps4-remote-play-android-thread-t3068225

That is the main thread now.
No root disabling needed, playable over 4G/LTE, Native OTG DS4 controller support and so on.
 

theseventensplit

Senior Member
Jul 1, 2012
211
27
North Bay
Sorry, my old post still linked the old thread, wich has been closed.
This might sound confusing but the actual main thread is this, wich is the one I meant to link:

http://forum.xda-developers.com/android/apps-games/ps4-remote-play-android-thread-t3068225

That is the main thread now.
No root disabling needed, playable over 4G/LTE, Native OTG DS4 controller support and so on.

My apologies, thanks for clearing it up

Sent from my Nexus 5 using XDA Free mobile app
 

Mars104

Senior Member
Apr 8, 2008
68
16
Lag tip/fix

Amazing port :) thanks

Have two android devices. On high quality settings on the same network:

LG g4 = virtually no lag
Galaxy tab pro 10.1 = ~1 second lag


Figured it was unlikely due to network as both support my wireless ac network.
Tested the tab pro on standard setting which were much better so concluded that the older cpu/gpu might be the problem.

I reduced the resolution of the tablet to 220dpi using texdroider_dpi hoping to reduce some strain on the gpu/cpu and hey presto the lag was virtually gone on high quality settings. The new reduced 220dpi (from 320dpi) is still greater than 720p so ample for hq remote play.

I intend to try a few tips others have posted on here but it's now more than playable on my tablet.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 168
    Hey guys,
    After the Z3 was announced in IFA 2014 in Berlin. I noticed there was no major change other than the new PS4 Remote Play feature. The feature that allows you to use your Xperia Device as a Second Screen for the PlayStation 4 anytime and anywhere. I was pretty sad that other devices might not get the feature. But it wasn't long until I ported and figured out the necessary files needed to get remote play to any and all Android Devices with Version 4.0 (Ice Cream Sandwich). So now we can get Remote Play in our devices too as soon as Sony releases the PS Remote Play APP. But now, it will be compatible with our devices as well.
    So the requirements:
    1. CWM (ClockWorkMod) Recovery
    2. The flashable zip I created
    3. PS APP (Download Link will be given below)
    4. Common Sense and a wee bit of patience.

    So here we go:
    Instructions:

    Download the Flashable Zip from this link:
    https://www.mediafire.com/?5xjqaxipkfc4bsz

    And this specific PlayStation APK from here:
    http://www.mediafire.com/download/zvqrvgzcgdu7pq4/playstationapp.apk

    Copy them to your Phone.
    Enter CWM Recovery.
    Flash the ZIP.
    Wipe Cache and Dalvik Cache.
    Reboot.
    Then install the PS App normally.
    After you install the App, when you go to the "Connect to PS4" Tab, you will notice that there will be a small logo for Remote Play which isn't there normally. Screenshot is given below:
    http://www.mediafire.com/view/z3mgmok8ynfxzvm/Screenshot_2014-09-05-11-59-44.png

    Then, when you press on it, this is what it will say:
    http://www.mediafire.com/view/11d1ztnk7c4kbls/Screenshot_2014-09-05-11-59-48.png

    So it should work when the app is here. But this is what you will need to get the app running.
    When the app comes. It might be incompatible at first but with a port or some changes to the build.prop. We'll be able to get Remote Play Running on your Android Device.



    A NOTICE FOR XPERIA Z1 USERS ONLY.
    When the "PS Remote Play App" comes, if Play Store says it's incompatible, this build.prop( link given below) might make it compatible for the Xperia Z1.
    Here is the build.prop: https://www.mediafire.com/?2x6hr5fcovvlbot
    Copy this build.prop to your system folder using a root exploring app and set permisssions to 0644



    Please PRESS THANKS and give it a THUMBS UP if this helped you in anyway.
    If anyone could share this to the General Android Development and Hacking Forum, It would be very NICE
    38
    Okay, since I have been getting some questions about quick tips on how I got Remote Play to work on My LG G2 I am going to write out a little tutorial with file downloads. You will most likely need root, and grant root access to a file manager to accomplish this, unless you are a cmd line guru, which I doubt you would be reading this if you know how to access root through ADB. Anyway,

    Starting out,


    • 1) I would go ahead and Force Stop the PS App, as well as uninstall it. (This is, of course, only if you have it installed before this.)
      2) Download this APK
      3) Open up File Manager of your choice, Copy/Move the .apk you just downloaded into the '/System/App/ ' Directory on your phone.
      4) Change the Permission of that .apk to RW-R-R

      5) Download this .dex and Move/Copy it to the '/Data/Dalvik-Cache ' Directory. Same as above you need to change permissions to RW-R-R.

      6) Download these two xml files: one, two. Now, move/copy these two files to the '/System/etc/permissions/ ' Directory. Once again, change the permissions to... RW-R-R.

      7) okay, now for the important files, .jar's, if you know java lol. File one, File Two

      After you download those two files, once again, More copy/moving. Copy these two files to the '/System/Framework/ ' Directory. After they have been successfully copied them, change the permissions to RW-R-R.

      8) Now, Reboot!

      9) Go to play store download PS App.

      10) Go back to the location where you downloaded the Remote Play .apk and click the .apk to install like normal. Now, the installation should finish. Great.

      Update, if you moved the remote play .apk from step 3, then just go to the /System/app directory and click on the .apk file from there. You just need to open the Install prompt and install the app for the force close to dissipate.

      11) go back into PS App, and under the 'Connect to PS4' you should now see a Remote Play button to the right.

      12) Clicking it should open the Remote Play app, if you get the Error 8800.... whatever, Then you need to uninstall SuperSU or whatever the app is that controls your Root Permissions.

    I know in SuperSU, I used the option, "Reinstall - Cleanup for reinstallation from Google Play" and then just never reinstalled, until I need root again.


    Hopefully this helps some people.

    EDIT: Click on Save Link as for the XML files, they show up as literal XML files for me, Not sure about your guys lol
    18
    n4xtmr.jpg
    10
    Guys i made this flashable zip that installs RemotePlay app, libs, jars and dex files with just one click. I recommend it to users that wants a quick way to install it.

    Also, if you can't get RemotePlay app to work or even to get it to show inside the app drawer, you should install it with my installer.

    Please do a Nandroid Backup before installing that zip... Better safe than sorry!

    Link: https://mega.co.nz/#!xRRFFCzI!OkZ8_x_l4VKQguXvmRh83LHpmj_n2MI2auh2UvPm23Q


    P.S. It should work on any device
    P.S.2. You still need to unroot or to hide root in order to use it.
    9
    I just wonder why Samsung/HTC/ LG users doing here if this is a Sony Cross Device Development,
    Is ya'll forum not good enoung ?
    Buy next time a Sony device then !

    Send From My "Personal" MoonWalker Revolution
    Buy yourself a domain, a hosting, build a forum and start being a moderator there