[PORT RECOVERY][AML DEVICES] Amlogic Flash Tool and recovery porter [V2.2]

papla83

Senior Member
May 13, 2012
123
10
38
toulon
ok so, the twrp flash correctly by this app ( i must click a lot of time on connect button), reboot in recovery mode do nothing on the box (the box doesn't receive the instruction) if i connect by generique adb plateform and ask an adb rebbot recovery then the box restart and stuck on T95zplus logo.

I push by your app the 3.1.1 TWRP on the box.

This is the result :
Flashing started.
Do not turn off or disconnect device

Please wait..
Sending custom-recovery.img to device..
File sent

Flashing recovery..
26940+0 records in 26940+0 records out 13793280 bytes transferred in 1.579 secs (8735452 bytes/sec)

SUCCESS!
 
Last edited:

Ricky Divjakovski

Recognized Developer / Recognized Contributor
Feb 4, 2013
5,214
7,598
263
25
Sydney
ok so, the twrp flash correctly by this app ( i must click a lot of time on connect button), reboot in recovery mode do nothing on the box (the box doesn't receive the instruction) if i connect by generique adb plateform and ask an adb rebbot recovery then the box restart and stuck on T95zplus logo.

I push by your app the 3.1.1 TWRP on the box.
Re-Uploaded and fixed, just open the program, connect and click reboot recovery
 
  • Like
Reactions: flipmode_11

papla83

Senior Member
May 13, 2012
123
10
38
toulon
no need to launch it by as an administrator ?

---------- Post added at 02:10 PM ---------- Previous post was at 02:06 PM ----------

ok the reboot in recovery mode button works now, but the box is again stuck on t95zplus logo...
I'm talking about that with whiteak and he says he have the same trouble when he try to put a twrp for 16Gb version on a 32Gb box, maybe i can try to flash with 16Gb twrp whitout risk ?
 

Ricky Divjakovski

Recognized Developer / Recognized Contributor
Feb 4, 2013
5,214
7,598
263
25
Sydney
no need to launch it by as an administrator ?

---------- Post added at 02:10 PM ---------- Previous post was at 02:06 PM ----------

ok the reboot in recovery mode button works now, but the box is again stuck on t95zplus logo...
I'm talking about that with whiteak and he says he have the same trouble when he try to put a twrp for 16Gb version on a 32Gb box, maybe i can try to flash with 16Gb twrp whitout risk ?
go to settings>about and send me your build number
also send me the version inside about too
 

papla83

Senior Member
May 13, 2012
123
10
38
toulon
strange because my set top box is a t95zplus ( start logo, on the box)

Do you think we have any solution ?

---------- Post added at 02:40 PM ---------- Previous post was at 02:35 PM ----------

Wrong device, thats why it wasnt working
i readed some one did the flash with the h96+ and other with a tanix tx9pro... so i don't understand why the hardware is important, this morning i opened the box and every things is look like than other t95Z plus.
 

whiteak

Senior Member
Jan 29, 2018
430
201
0
Gold Coast
strange because my set top box is a t95zplus ( start logo, on the box)

Do you think we have any solution ?

---------- Post added at 02:40 PM ---------- Previous post was at 02:35 PM ----------



i readed some one did the flash with the h96+ and other with a tanix tx9pro... so i don't understand why the hardware is important, this morning i opened the box and every things is look like than other t95Z plus.
Install terminal emulator on your box from the Play store and dd your recovery for me by running this code:

dd if=/dev/block/recovery of=/sdcard/stockrecovery.img bs=4096

File (stockrecovery.img) will be saved in sdcard folder, access that through a file explorer, copy it to a usb stick and upload it to me or link it to me and I'll see if I can port it sometime tommorrow or the next day, It's just gone past midnight here where I am. Gotta get some sleep.
 
  • Like
Reactions: papla83

papla83

Senior Member
May 13, 2012
123
10
38
toulon
Install terminal emulator on your box from the Play store and dd your recovery for me by running this code:

dd if=/dev/block/recovery of=/sdcard/stockrecovery.img bs=4096

File (stockrecovery.img) will be saved in sdcard folder, access that through a file explorer, copy it to a usb stick and upload it to me or link it to me and I'll see if I can port it sometime tommorrow or the next day, It's just gone past midnight here where I am. Gotta get some sleep.
I have a message after the first line : permission denied I think is because the Su isn't activated?