[PORT] White Balance for Z1 ported from SO-01F

Search This thread

AndroPlus

Senior Member
Japanese version of Xperia Z1 SO-01F got white balance settings today and I ported it to our Z1 C69xx !

vMzk0Vp.png



Download flashable zip from here and install it with recovery.

At the moment we need to open white balance setting on each reboot to apply settings.
Someone please help me to fix it!

→ monx® found the solution, it was really easy...
just add line
Code:
display_color_calib
in the last line of install-recovery.sh or init.d scripts, or hw_config.sh

I uploaded ftf of SO-01F.
SO-01F 14.1.H.1.281 1278-7126 R14A
https://mega.co.nz/#!ak5hzQDa!L8HPmHQMMlxm9WoA687FxT4zsv1JD4g6Gqs9KKHgKiU
 
Last edited:

fer2503

Senior Member
Nov 7, 2012
1,545
141
fantastic!!! thanks a lot for this! i hope it works also with new update 4.3 .290
 

Wolfbreak

Inactive Recognized Developer
Aug 8, 2010
4,243
11,508
At the moment we need to open white balance setting on each reboot to apply settings.
Someone please help me to fix it!

Maybe its a bug that is easy to solve like i had with Xperia P and Small Apps it reverted back to stock every Reboot and i solved it with creating the Folder where it locates the Saves of Small Apps and giving it the right Permissions. Might be worth a try to look if its the same Problem here.
 

fer2503

Senior Member
Nov 7, 2012
1,545
141
Maybe its a bug that is easy to solve like i had with Xperia P and Small Apps it reverted back to stock every Reboot and i solved it with creating the Folder where it locates the Saves of Small Apps and giving it the right Permissions. Might be worth a try to look if its the same Problem here.

can you do that?
 

emompong

Senior Member
Jan 25, 2012
692
370
LUCENA CITY
I can confirm that its working fine.
Im just curious why it has different sliders compared to those on Xperia Z.. only Hue and Saturation.

Anyways, this is helpful for those who got yellow tint.
 
  • Like
Reactions: marcyff2

zyxel25

Senior Member
Oct 27, 2011
326
34
How about if the screen has a
Yellow tint? Any suggested settings?

Sent from my C6903 using xda app-developers app
 

ahomad

Senior Member
Jul 11, 2011
178
84
Can someone please explain how is this better than any screen filter available in the play store.
 
Last edited:

ckchan08

Senior Member
Jan 2, 2013
68
6
How about if the screen has a
Yellow tint? Any suggested settings?

Sent from my C6903 using xda app-developers app

i just installed it. no need to adjust any settings. run the white balance, it will auto set red, green, blue to 0 value and your screen will be white as snow. of course u can also manually adjust the value to your own likings. i just leave everything to 0,

---------- Post added at 10:15 AM ---------- Previous post was at 10:10 AM ----------

Can someone please explain how is this better than any screen filter available in the play store.

this one looks better. it adjust the colour without adding a layer of filter on the screen.
 

paniczklos

Senior Member
Sep 15, 2009
101
13
Kraków
i just installed it. no need to adjust any settings. run the white balance, it will auto set red, green, blue to 0 value and your screen will be white as snow. of course u can also manually adjust the value to your own likings. i just leave everything to 0,

---------- Post added at 10:15 AM ---------- Previous post was at 10:10 AM ----------



this one looks better. it adjust the colour without adding a layer of filter on the screen.

ok, I'm going back from the newest 4.3 to the old 1.534 firmware to root the phone and flash this tool ;p I hope you're right ! ;)
 

paniczklos

Senior Member
Sep 15, 2009
101
13
Kraków
Let us know how it goes

Sent from my Xperia Z1 using Tapatalk

It doesn't work ;/

Additionally after going back form 4.3 to 1.534 I've lost IMEI and phone can't connect to the network ;/ (after flashing newest .ftf back it works again)

I'll try playing with the sliders, maybe it'll help.
 

Attachments

  • Screenshot_1970-01-20-22-56-17.png
    Screenshot_1970-01-20-22-56-17.png
    68.7 KB · Views: 702

zohaib0001

Senior Member
May 3, 2011
1,652
3,547
Lahore
forum.xda-developers.com
Japanese version of Xperia Z1 SO-01F got white balance settings today and I ported it to our Z1 C69xx !

vMzk0Vp.png



Download flashable zip from here and install it with recovery.

At the moment we need to open white balance setting on each reboot to apply settings.
Someone please help me to fix it!


I uploaded ftf of SO-01F.
SO-01F 14.1.H.1.281 1278-7126 R14A
https://mega.co.nz/#!ak5hzQDa!L8HPmHQMMlxm9WoA687FxT4zsv1JD4g6Gqs9KKHgKiU
Please provide these folder from system

bin
etc
framwork
libs
vendor


i can download whole ftf pack
 

Top Liked Posts

  • There are no posts matching your filters.
  • 41
    Japanese version of Xperia Z1 SO-01F got white balance settings today and I ported it to our Z1 C69xx !

    vMzk0Vp.png



    Download flashable zip from here and install it with recovery.

    At the moment we need to open white balance setting on each reboot to apply settings.
    Someone please help me to fix it!

    → monx® found the solution, it was really easy...
    just add line
    Code:
    display_color_calib
    in the last line of install-recovery.sh or init.d scripts, or hw_config.sh

    I uploaded ftf of SO-01F.
    SO-01F 14.1.H.1.281 1278-7126 R14A
    https://mega.co.nz/#!ak5hzQDa!L8HPmHQMMlxm9WoA687FxT4zsv1JD4g6Gqs9KKHgKiU
    3
    This file is located in dir /etc.
    Simply edit this file using any file explorer (I prefer Solid Explorer) and add this line

    Code:
    display_color_calib

    at the bottom of file.
    2
    Someone said to edit install-recovery.sh, someone hw_config.sh, so what file exactly must be edited ?

    On stock .290 doing it from hw_config.sh didn't work for me but running it from install-recovery.sh did.
    2
    Here you go...

    Rickard (Sony Xperia Support) said:
    Glad to hear that it's working.

    A white balance setting will also be added to C690x but it's not in the update that's rolling out now. It's planned for an update in the beginning of next year. So you don't need to modify the phones software to get this, just wait for the update.
    2
    monx® found the solution to apply setting on reboot!
    I was trying almost same code, but I had to make it simple...

    Just add line
    Code:
    display_color_calib
    in your install-recovery.sh or init.d