[POSSIBLE FIXES] Battery drain 5.1.1

Has android wear 5.1.1 affected the battery life?

  • Made it worse

    Votes: 166 89.2%
  • Improved battery life

    Votes: 20 10.8%

  • Total voters
    186
Search This thread

skriefal

Member
Sep 9, 2009
49
5
Salt Lake City, Utah
I turned off WiFi on the watch and the battery drain hasn't occurred ever since. Someone should try to see if they get the same results.

Didn't work for me. How long has it been since you've turned wi-fi off? If less than 3 or 4 days, then just wait. The drain will be back. It's obvious at this point that this is an O/S or driver issue on the watch. We need to wait for a software update from Google.
 

princeasi

Senior Member
Sep 16, 2006
1,475
201
44
Los Angeles
Didn't work for me. How long has it been since you've turned wi-fi off? If less than 3 or 4 days, then just wait. The drain will be back. It's obvious at this point that this is an O/S or driver issue on the watch. We need to wait for a software update from Google.
Did you shutdown the WiFi thru the watch or the companion app?
 

princeasi

Senior Member
Sep 16, 2006
1,475
201
44
Los Angeles
I disabled all wifi and cloud sync options on the watch. Couldn't locate any wifi settings in the companion app, but there is a cloud sync setting there that I disabled.
The "cloud sync" thru the companion app is where you disable it. If the problem still persisted afterwards, then yes there's still a problem...... So far I haven't experienced any battery drain along with the heat up issues for 3 days after disabling. I'll report if it surfaces again for me.
 

Roftnai

New member
Nov 3, 2011
1
0
First of all: Sorry for my bad English !:eek:

For me, using android-wear-1-1-1-1901499 like post 300 suggest seems to be to solution.

Tried everything on the Watch before that (screen always on = off, wrist gesture off, wifi (clound sync via app on phone) and location off, factory reset the Watch). Nothing seems to do a difference. The problem came back every 5-6 hours and I had to reboot the Watch to solve the issue.

So, I uninstalled the Android Wear app on phone, reboot phone, factory reset Watch, installed android-wear-1-1-1-1901499. Since then (four days), no trouble (hope this stay like that). I leave all the option by default except:
Screen brightness: 1
Localisation: Off
Screen Always on: Off

Yesterday, from 10am to 9pm, with light use, the battery drop from 99% to 87% (in 11 hours)
 

dan-htc-touch

Senior Member
Dec 6, 2007
688
148
calgary
Rediculous
uploadfromtaptalk1435592037728.png

Sent from my HTC One_M8 using Tapatalk
 

lekofraggle

Senior Member
Oct 10, 2010
753
213
First of all: Sorry for my bad English !:eek:

For me, using android-wear-1-1-1-1901499 like post 300 suggest seems to be to solution.

Tried everything on the Watch before that (screen always on = off, wrist gesture off, wifi (clound sync via app on phone) and location off, factory reset the Watch). Nothing seems to do a difference. The problem came back every 5-6 hours and I had to reboot the Watch to solve the issue.

So, I uninstalled the Android Wear app on phone, reboot phone, factory reset Watch, installed android-wear-1-1-1-1901499. Since then (four days), no trouble (hope this stay like that). I leave all the option by default except:
Screen brightness: 1
Localisation: Off
Screen Always on: Off

Yesterday, from 10am to 9pm, with light use, the battery drop from 99% to 87% (in 11 hours)

Thanks for this post. It gives me hope. I tried that too, and one thing that rolling back the Wear app did for me was save my phone from dying just as quick as the watch. It also allowed me to go from 4 hours to 12-24.

I am noticing a 4% suck from wear battery stats.
 

matejdro

Senior Member
Jul 9, 2009
1,360
146
OK based on my logs and logs people gave I think I figured out what the issue is: bug is in Android Wear app (on the watch). When watch is ticking in ambient mode (when it updates in every minutes), sometimes it gets stuck and holds wakelock.

That would explain why SW3 seems more affected, because using ambient mode is much more prevalent on our watch. Is there anyone with this bug that does not use ambient mode?

EDIT: Watch is also apparently "ticking" in non-ambient mode. So there goes my SW3 theory.
 

chrissss91

Senior Member
Jan 5, 2012
434
103
Paris
First, you need Tasker and AutoWear (setup is kind of a pain).
I set up a task to pull the battery level, save it to a variable, subtract the previous battery level from the current one, and alert based on the difference.

Here's the exported "description"
http://hastebin.com/efoqagales.vbs


Here's the xml file:
https://drive.google.com/file/d/0B5PMjvK8GGL0dUVpVUJDQnVxSkk/view?usp=sharing
Works like a charm, I just had a drain 5 minutes ago and it was detected by your task.
So I rebooted instantly :good:.
You check every hour, I've modified it to 30 minutes but I think I'll reduce it to 15 minutes because it hate around 13 % in 30 minutes.

Thanks again.
 
  • Like
Reactions: zard

dellbell

Member
Dec 1, 2011
8
1
TX
First, you need Tasker and AutoWear (setup is kind of a pain).
I set up a task to pull the battery level, save it to a variable, subtract the previous battery level from the current one, and alert based on the difference.

Here's the exported "description"
http://hastebin.com/efoqagales.vbs


Here's the xml file:
https://drive.google.com/file/d/0B5PMjvK8GGL0dUVpVUJDQnVxSkk/view?usp=sharing


That's all well and good for sophisticated users.

For the great unwashed--like me--there's WatchMaker Premium, which lets you put one of four battery indicators (slightly different graphics) on your customized watchface. And then you can see if it's getting low.
 

chrissss91

Senior Member
Jan 5, 2012
434
103
Paris
That's all well and good for sophisticated users.

For the great unwashed--like me--there's WatchMaker Premium, which lets you put one of four battery indicators (slightly different graphics) on your customized watchface. And then you can see if it's getting low.
Yes, that's what I did before, but you have to constantly check your watch, remember the percentage, and watch again ...
With Breakfall Tasker Profile, I've got a popup 15minutes after it starts to drain :good:
 

supac

Senior Member
May 29, 2005
313
34
Same here

Bull****

---------- Post added at 10:53 PM ---------- Previous post was at 10:53 PM ----------

Since I've taken to rebooting every day, after fully charging, I've not had the rapid discharge issue.

Sent from my SM-N910G using XDA Free mobile app

Yeah..suuuuure

---------- Post added at 10:55 PM ---------- Previous post was at 10:53 PM ----------

Sony or Google need to fix this [email protected] this, this fixed this and this fixed that....problem does not go away...until they update firmware.
 

senectus

Senior Member
Dec 14, 2004
1,326
175
Perth
0.o

why on earth do you question this.

I'm being 100% legit.

Since I started rebooting the watch once a day, every day, I haven't had the rapid drain issue.

I even have gestures on and wifi set to auto...

This is not to say its a solution.. its just a temp work around. I still want Sony to fix the ****ing problem. I should have to remember to reboot the damned watch every day.
 
  • Like
Reactions: Zoidy

Top Liked Posts

  • There are no posts matching your filters.
  • 28
    Hi all,

    My name is Johan and I work for Sony Mobile. I would like to inform you that our SmartWatch team is looking into this as we speak but it would be great if you guys would be willing to help them out by providing bug reports from the watch.

    Please do only take and share reports of when the battery drain is happening.

    Here is two ways of taking the report.

    * From the Android Wear app on the phone:

    * Tap the hamburger menu (3 vertical dots) and select "Report wearable bug"
    * Wait for the notification on the watch saying "Bug report captured"
    * On the watch swipe the notification left and select "Open"
    * Read the information and if you agree, tap "OK"
    * You will get a notification on the phone, when you tap it is possible to (for example) upload the bugreport to Google Drive and share the link on xda

    * From the watch, using the UI:

    * Enable Developer options
    * Go into "Settings"->"About"
    * Tap "Build number" until you see "You are now a developer"
    * Go into "Settings"->"Developer options"
    * Enable "Bug report in menu"
    * Go back to the watchface
    * Swipe left 3 times to get to the "Speak now" screen
    * Swipe all the way down and tap "Take bug report"
    * Wait for the notification on the watch saying "Bug report captured"
    * On the watch swipe the notification left and select "Open"
    * Read the information and if you agree, tap "OK"
    * You will get a notification on the phone, when you tap it is possible to (for example) upload the bugreport to Google Drive and share the link on xda
    8
    Thank you all for contributing with bug reports. The SmartWatch team have recevied the information they need so they don't need any more logs.

    So now you can remove your bug reports from Google Drive, which I suggest that you do.

    If any more information is required or when I have any status updates on the investigation I will get back to you.

    Thank you all!
    8
    Hi all,

    Google have finally confirmed this is an issue and they are working on a fix:
    https://productforums.google.com/d/msg/android-wear/SulEHMS1ETk/TVh25aK6e2AJ

    Note, This issue affects multiple watches:
    https://productforums.google.com/fo...source=footer#!topic/android-wear/SulEHMS1ETk

    However, the SW3 seems to have the most people complaining - not sure if it's the most affected watch, or just that more people own it...

    thanks,
    Charlie
    4
    Today I've disinstalled battery mix and I reinstalled it when the smartwatch was in battery drain, in this manner I've resetted the data and I've found what are the process that causes battery draining...
    screen.png
    4
    • It is not reception or Bluetooth (happens without phone connection / airplane mode)
    • it is not wifi (or cloud sync or anything else related, people tried with wifi off)
    • It is not Android Wear phone app (tried with old app, still got random drops. Also happens on airplane mode when no phone app can affect the watch.)
    • It is not specific wear app (people have this bug with various app configurations. Also rogue user app would show up on battery historian).
    • It is not faulty system install (reinstalled from scratch using PC Companion, same thing).

    To conclude it, I don't think it is anything we can control, something is messed up in system/drivers. I don't want to sound negative, but it seems only thing we can do is switch to 5.0.1 and wait for Sony to hopefully fix this.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone