• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Possibly Faster Boot] Disable Boot Animation

Search This thread

kingofnice

Senior Member
Jun 2, 2012
1,172
925
This is very simple. Any noob can follow this and most of you know of this tweak.

1)Open a Root Explorer app or any file manager with root permissions.

2)Go to /system

3)Mount folder in R/W and open build.prop in text editor

4)Scroll to the very bottom and enter


Code:
debug.sf.nobootanimation=1


5)Save and Exit. A full reboot is required to see that this works.

You can change =1 to =0 to disable this. Or simply delete the line that was added.


Pressing the thanks button is very appreciated.

P.S. I think this results in a faster boot up time. Let me know what you think.

Sent from my HTC One X+
 
Last edited:

boulder2016

New member
Aug 21, 2012
3
1
It does work.

I've tested this in hopes that some build.prop tweaks are worth it. Well this one is...my Samsung Galaxy Nexus booted from 3-5 seconds faster when the boot animation was disabled. It was noticeable that when the phone intially turned it took longer to get to the animation b/c it had to load it. However it is sort of scary to have my phone suddenly just 'turn on'.. oh well. less clutter
 
  • Like
Reactions: kingofnice
Jun 21, 2013
41
5
Thanks!

Thank you!
Works great for me...

My Device: Samsung Galaxy Ace (S5830)
Android 4.2.2: Cyanogenmod 10.1
Editor: TotalCommander

The Device starts 2-3 seconds faster... And the Interfaces (Touchscreen + Keys) respons faster after turning on, not so laggy!
I can enter my pin faster :silly:

Result:
Minimal effect nevertheless nice!
Try it guys! :eek:
 
Last edited:

Haerviu

Member
Jan 11, 2013
15
1
Alexandria
This is very simple. Any noob can follow this and most of you know of this tweak.

1)Open a Root Explorer app or any file manager with root permissions.

2)Go to /system

3)Mount folder in R/W and open build.prop in text editor

4)Scroll to the very bottom and enter


Code:
debug.sf.nobootanimation=1


5)Save and Exit. A full reboot is required to see that this works.

You can change =1 to =0 to disable this. Or simply delete the line that was added.


Pressing the thanks button is very appreciated.

P.S. I think this results in a faster boot up time. Let me know what you think.

Sent from my HTC One X+

Nice tip :good:
 
  • Like
Reactions: mgh1982

hackervin

New member
Jan 10, 2014
2
0
help

This is very simple. Any noob can follow this and most of you know of this tweak.

1)Open a Root Explorer app or any file manager with root permissions.

2)Go to /system

3)Mount folder in R/W and open build.prop in text editor

4)Scroll to the very bottom and enter


Code:
debug.sf.nobootanimation=1


5)Save and Exit. A full reboot is required to see that this works.

You can change =1 to =0 to disable this. Or simply delete the line that was added.


Pressing the thanks button is very appreciated.

P.S. I think this results in a faster boot up time. Let me know what you think.

Sent from my HTC One X+


sir,
i deactivated my boot animation using an app called boot animation and i didn't make any backup.
now i want to re-enable a boot animation sadly the app is not letting me re-enable it.
how can i do that?
please help. thank you.
 

kingofnice

Senior Member
Jun 2, 2012
1,172
925
sir,
i deactivated my boot animation using an app called boot animation and i didn't make any backup.
now i want to re-enable a boot animation sadly the app is not letting me re-enable it.
how can i do that?
please help. thank you.

Follow the guide and change the build.prop value to 0.

Also check to see if you even have a boot animation in /system/customize/resources/ or /system/media/
 
  • Like
Reactions: hackervin

shubk

New member
Jan 16, 2014
4
0
I followed your steps and my bootanimation got disabled. but it takes that much time only to reboot. now i want to enable bootanimation but its got getting. i tried deleting those lines but still no bootanimation...plzz HELP
 

kingofnice

Senior Member
Jun 2, 2012
1,172
925
No i didnt delete it but dont it doesnt work. I tried making it with a bootanimation software and now it works. thanks anyways.
but if it wuld have worked what i made myself by .zip i wuld b happy. :) does it depends on frame rate. and i also used notepad++ and in .txt

Boot animations cannot be compressed. So zip with 0 compression (store).
 

webfeind

Senior Member
May 27, 2010
51
13
I followed your steps and my bootanimation got disabled. but it takes that much time only to reboot. now i want to enable bootanimation but its got getting. i tried deleting those lines but still no bootanimation...plzz HELP

Your boot animation was likely deleted, moved, or renamed by the app you used. The boot animation file can be placed in many locations for use at startup. I would look in the /system/media folder for a file named bootanimation.zip, however the app may have renamed it. So it may not have the .zip at the end if that's the case then rename it back to bootanimation.zip and then give that a shot. If you don't find it there it could be in /system/customize/resources or even in the /data partition or moved to the SD card. Make sure the boot animation file exists before you attempt to fix anything.
 

dlewando

Senior Member
Jan 4, 2011
331
109
is it possible to enable bootmessages?

yea,
thx 4 that. works with stock 4.4.2 on galaxy s3 neo (i9301i). does anyone know how to enable bootmessages? it will maybe slow down boot-time, but i'm interested in watching bootmessages on boot.
 
  • Like
Reactions: linolino

Top Liked Posts

  • There are no posts matching your filters.
  • 67
    This is very simple. Any noob can follow this and most of you know of this tweak.

    1)Open a Root Explorer app or any file manager with root permissions.

    2)Go to /system

    3)Mount folder in R/W and open build.prop in text editor

    4)Scroll to the very bottom and enter


    Code:
    debug.sf.nobootanimation=1


    5)Save and Exit. A full reboot is required to see that this works.

    You can change =1 to =0 to disable this. Or simply delete the line that was added.


    Pressing the thanks button is very appreciated.

    P.S. I think this results in a faster boot up time. Let me know what you think.

    Sent from my HTC One X+
    2
    Thanks!

    Thank you!
    Works great for me...

    My Device: Samsung Galaxy Ace (S5830)
    Android 4.2.2: Cyanogenmod 10.1
    Editor: TotalCommander

    The Device starts 2-3 seconds faster... And the Interfaces (Touchscreen + Keys) respons faster after turning on, not so laggy!
    I can enter my pin faster :silly:

    Result:
    Minimal effect nevertheless nice!
    Try it guys! :eek:
    2
    Is it possible to disable the boot logo of the company that pops up during phone start?

    That's called the splashscreen, can't change that unless your device is S-Off unfortunately
    1
    made no difference whatsoever on my att hox+. all the boot anims still played.
    but i'm not deodexed yet so that might be playing a role in that.
    1
    It works...

    Thank you! It works on a Lenovo A606, if anyone is trying out on this device.