Pre-Rooted Firmwares for Samsung SM-G531F Galaxy Grand Prime VE

Search This thread


Jun 27, 2017
Hi. How can I go back to original firmware from this. It says write operation failed whenever I try to flash from Odin. Same error goes with TWRP. I really want this phone to get working.


New member
Aug 3, 2017
grand prime 531f

After rooting using this pre rooted firmware it worked.but when i uninstall an app my phone restarts automatically..why???


New member
Aug 29, 2014
Thank you so much, I was struggling with a sandroid warning, I was not able to get into TWRP, by installing this rom I can continue!
I messed up something with csc by installing different roms and I was so stupid to format the sd card with the back up from my stock rom and the stock rom from my country ( the Netherlands) is not available anywhere on the internet. So, I am happy now! Took me really many hours less sleep the passed days because I have the bad habbit that something must be solved while I was going to restaurant yesterday for the price of a new phone :)) Just I can't stand I messed up.

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    Hello All

    Here I will Share the Pre-Rooted Firmwares for

    Samsung Galaxy Grand Prime VE SM-G531F


    These Pre-Rooted Firmwares can be flashed via Odin3 flasher, Just select the file in AP Field, Like you flash any Stock ROM of this model.

    - Make sure your phone is SM-G531F before flashing.
    - Do this on your own responsibility.

    Pre-Rooted SM-G531F Firmwares:

    - G531FXXU1AOH1: Download AFH Link
    Solution for FRP ON error in download mode while installing recovery via Odin

    This assumes you have made access to the settings UI by some method.

    1. Enable developer options by taping on build number repeatedly, from Settings>About
    2. Enable OEM unlock from Settings>Developer Options
    3. Remove the existing google account from Settings>Accounts ( You can add it after flashing recovery )
    This is the only method to Turn OFF FRP according to SAMSUNG :confused:
    4. Reboot to Download mode: FRP will be OFF now.
    5. Now flash the recovery via Odin. (Remember to untick Auto Reboot, and pull the battery out after flashing)
    6. All done :p:p
    Hi, can someone tell me are these firmwares delete user data?
    No..I have not get any userdata changed after flashing with odin.
    I have rooted sucessfully with G531FXXU1AOH1_Prerooted_System_v5.1.1...

    My existing build No

    My existing baseband No

    After flashing pre-rooted rom i got changed
    My New build No
    My New baseband No

    I got an new app named SuperSU and Security clean master in app menu..
    Then i Updated SuperSU binaries..

    After that i prompted as " security notice...Unauthorised actions found and click to restart for undo actions".
    I gave it k ,Bcz it going on prompting me again and again...
    But After restart also its same...any help?:(

    ---------- Post added at 07:21 PM ---------- Previous post was at 07:16 PM ----------

    Found solution for Security Notice Problem after root.
    Download any "system app remover"
    Open it and scroll down till you see " security log agent"
    Long click on it
    Click on "disable" or else unistall it.

    Now am Having my Samsung Galaxy grand Prime 4G SM-G531F is fully rooted and working fine.
    I got rid of sd card security permission problem by,:cool::cool:
    TWRP v2.8.7.0 for Grand Prime SM-G531M, no TWRP for the G531F..? One may try this TWRP variant, the pre-rooted firmware works great on the G531M variant, similar TWRP may work also for the G531F variant if you guys dont have a custom recovery..

    Here >>

    sent by my: SM-G531M-57 Grand Prime (or) my: SM-N910C Note 4 (Lollipop 5.1.1)
    View attachment 3495074

    Select on dev options "manufacturer unlock".

    Sent from my SM-G531F using Tapatalk
    Can You check status in download mode?