• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Problem running/Installing TWRP on LG G7 ThinQ LM-G710AWM Canadian

Search This thread
Oct 16, 2017
I have an ongoing issue with this phone, I want to install TWRP and eventually a custom ROM on my Canadian LG G7 ThinQ LM-G710AWM.

I have been able to root by patching boot_a and boot_b with majisk and using QFIL to modify/write to the partitions.

I was also able to unlock the bootloader by following this post:

After deleting both the lafs in QFIL to get fastboot back, I tried flashing several TWRP images which are recommended for my model, and i get an error [fastboot:error "cannot get boot partition size"]
I've tried flashing it to boot_a,
I've tried flashing it to boot_b,
I've tried fastboot boot "TWRP IMAGE" to boot into TWRP temporarily but it shows 'download mode' for about 10 seconds and then reboots normally

I initially crossflashed then refurbished from Android 9 Pie to Android 8 Oreo, using LM-G710AWM, basically a downgrade, for reasons, and still Ive hit a solid wall with this.
Any help would be greatly appreciated, there seems to be no way to get into TWRP.


  • IMG_20210804_164202.jpg
    7.1 MB · Views: 3
  • IMG_20210804_164506.jpg
    6.2 MB · Views: 3
  • IMG_20210804_164356.jpg
    5.5 MB · Views: 3
Last edited: