• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Problem with push notifications

Search This thread

Tdjee

Senior Member
Aug 5, 2012
425
222
I searched XDA, Google and the official site of LeEco. I have found similar problems with push notification(Whatsapp, Email.) But no direct solution for the leEco max 2.
I've tried different roms, chinese and india, because of the EUI layout that i like.
I tried all the settings that are mentioned: Priority notification on, no battery saving, no clearing of tasks, installing Push notification fixer, reinstalled from scratch, and now on stock indian 5.8.19S.
But still no push notification when the phone is in sleep mode. After 30 minutes no use. Only after manualy activation of the phone.:crying:
Has anybody a solution for the EUI Rom? Or is the only option to try CM on the phone?
I appreciate all the help. Big Thanx in advance.:fingers-crossed:
 
  • Like
Reactions: peregon2

anameeeen

Senior Member
Jul 5, 2012
149
23
Jerusalem
In addition to what you have mentioned, you should put these apps in auto launch mode+app protection from phone manager.
Make sure that you have also enabled auto-sync data from account management.

Whatsapp and messenger notifications are working fine with these settings on indian rom 19s. However, I faced problems with Gmail notifications in other customs roms.
 
  • Like
Reactions: Tdjee

Tdjee

Senior Member
Aug 5, 2012
425
222
Hi,

Infos : there is 2 Hidden Menu :

1- tap on dialer : *#*#4636#*#* --> Menu test
2-tap on dialer : *#*#46360000#*#* --> Settings plus
;)

Settings plus, did it for me.
The Enable background resource control in the hidden menu.........I switched it off............no problem anymore for me with notifications. Whatsapp, Gmail, etc..... @sdevaux Thanx for the useful tip. @lukam01 and @anameeeen for helping out
 

n3g4t1v3

Member
Nov 6, 2010
7
3
This looks like a global sync issue that I've been trying to solve for almost a month now. Coming from the Xiaomi Mi Note Pro, I've been experiencing the same exact auto sync problems on both the Note Pro, and the Le Max 2. Gmail and Yahoo mail (or any other email client that I've tried) won't sync and give notifications unless I open the apps manually and refresh. I tried pretty much everything I could find on the internet to no success. Whatsapp works most of the time, but every once in a while it start's doing the same.

Power management is off, the apps involved have all the required permissions, they're set to auto launch, global sync is enabled (tried turning it off and on again to no effect), and of course, sync is also enabled in each individual app. Background resource control is off (hidden menu).
I have removed my accounts from both devices countless times, cleared the cache, data, uninstalled/reinstalled the apps, re-added the accounts individually...
I don't know what's going on, but I'm talking about 2 different devices and 2-3 different roms on both (the devices were set up as new every single time, not restored with Ti Backup), so I'm pretty sure it's a global issue.
 
Last edited:

xphyle1971

Senior Member
Apr 25, 2012
429
104
Same issues here. In addition, some apps just plain don't work if the phone is asleep. I prefer using Google Clock for my alarms, and textra for my text messages. However, if the phone is asleep, the alarm will NEVER sound and I will NOT get text messages. I'm not just talking about not getting notifications for text messages, I'm talking that if someone sends me a text message I will not EVER get it. They only way to fix is to use the STOCK clock and text apps. Crazy.
 

Tdjee

Senior Member
Aug 5, 2012
425
222
Same issues here. In addition, some apps just plain don't work if the phone is asleep. I prefer using Google Clock for my alarms, and textra for my text messages. However, if the phone is asleep, the alarm will NEVER sound and I will NOT get text messages. I'm not just talking about not getting notifications for text messages, I'm talking that if someone sends me a text message I will not EVER get it. They only way to fix is to use the STOCK clock and text apps. Crazy.

I'm very curious, did you try the hidden settings and deactivate the background Resource control?
See post 4.
 

xphyle1971

Senior Member
Apr 25, 2012
429
104
I'm very curious, did you try the hidden settings and deactivate the background Resource control?
See post 4.

Yes, but this did NOT help fix the Google Clock app. I have read other threads with people having the same issue with some google apps. The theory seems to be that perhaps the way gapps is added by LeEco into their roms breaks something having to do with notification system.
 
  • Like
Reactions: Tdjee

lukam01

Senior Member
Nov 2, 2016
96
17
Stock Indian roms encrypt data, but in revolution version the encrypition is removed by rom developer

Sent from my Le X820 using Tapatalk
 

frozzz

New member
Jan 25, 2013
2
0
can you guys confirm that in mokee and cuoco all notifications work well. i tried everything from forums and this thread, whatsapp is fixed, but i simply cant force gmail notifications to come properly. huge disappointment in this phone because of it. so i just want this to work with stable custom rom and that camera works as in stock rom...any recommendations?thanks
 

mame76

Member
Feb 15, 2017
44
0
I have same issue after a while notifications stop to work, resetting Google play services helps but issue occurs after few hours again. Trying to install different versions to see if it helps. For now also stopped Android Wear...

Using cuoco92 Rom S20v65
 

shaxs

Senior Member
Aug 16, 2010
653
64
Same issues here. In addition, some apps just plain don't work if the phone is asleep. I prefer using Google Clock for my alarms, and textra for my text messages. However, if the phone is asleep, the alarm will NEVER sound and I will NOT get text messages. I'm not just talking about not getting notifications for text messages, I'm talking that if someone sends me a text message I will not EVER get it. They only way to fix is to use the STOCK clock and text apps. Crazy.

Same here. I'm on tiny eui which is hard on 20s and I have done all the power and app settings. Every app works and I get notifications but alarms through alarm clock extreme will not go off when the phone is in deep sleep. I cannot figure it out.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Hi,

    Infos : there is 2 Hidden Menu :

    1- tap on dialer : *#*#4636#*#* --> Menu test
    2-tap on dialer : *#*#46360000#*#* --> Settings plus
    ;)

    Settings plus, did it for me.
    The Enable background resource control in the hidden menu.........I switched it off............no problem anymore for me with notifications. Whatsapp, Gmail, etc..... @sdevaux Thanx for the useful tip. @lukam01 and @anameeeen for helping out
    1
    I searched XDA, Google and the official site of LeEco. I have found similar problems with push notification(Whatsapp, Email.) But no direct solution for the leEco max 2.
    I've tried different roms, chinese and india, because of the EUI layout that i like.
    I tried all the settings that are mentioned: Priority notification on, no battery saving, no clearing of tasks, installing Push notification fixer, reinstalled from scratch, and now on stock indian 5.8.19S.
    But still no push notification when the phone is in sleep mode. After 30 minutes no use. Only after manualy activation of the phone.:crying:
    Has anybody a solution for the EUI Rom? Or is the only option to try CM on the phone?
    I appreciate all the help. Big Thanx in advance.:fingers-crossed:
    1
    In addition to what you have mentioned, you should put these apps in auto launch mode+app protection from phone manager.
    Make sure that you have also enabled auto-sync data from account management.

    Whatsapp and messenger notifications are working fine with these settings on indian rom 19s. However, I faced problems with Gmail notifications in other customs roms.
    1
    Autolaunch and app protection usually solves it

    Sent from my Le X820 using Tapatalk
    1
    I'm very curious, did you try the hidden settings and deactivate the background Resource control?
    See post 4.

    Yes, but this did NOT help fix the Google Clock app. I have read other threads with people having the same issue with some google apps. The theory seems to be that perhaps the way gapps is added by LeEco into their roms breaks something having to do with notification system.