Problem with the proximity sensor, please help

Search This thread

Loco5150

Senior Member
Jun 8, 2008
742
68
0
Hi all, I have a weird problem with the proximity sensor in my HTC Titan. I got a new Titan about a week ago, to which I immediately installed HSPL and Dynamics rom. After I did all the tweaks and installs I like, I noticed that every time I dial a phone call the screen goes off and stays that way until the number I called answers. If the number does not pick up, only thing I can do is remove the battery basically to hang the call up. I noticed that removing the back cover slightly affects the issue and its easier to get the screen back on (by pressing the power button), but still removing it does not solve the problem. With a handsfree I can actually stop the call as it has an accessible end call button.

I tried flashing another custom rom and also a stock rom, both had the same issue. So, I took the device for warranty repair. I got it back today from HTC, with a note saying that software has been updated and problem has been fixed. I tried the device and surely it was working. Well I can’t live without an fully unlocked device and against my better judgment flashed a custom rom again… And surprise surprice the problem appeared back.

Im thinking here that could I adjust the proximity sensor from the registry, if its somehow too sensitive or something. Strange part naturally is that other people with same rom are not experiencing this behavior, so it is device specific problem. Also I don’t think I can take the device back again and say yeah I was flashing some custom roms on it and lost whatever you did with it.

There a Proximity folder at HKLM and I tried changing some values there but no affect at all. It probably would be better to have someone who understands about the values little try to take a look.

Thanks a lot!
 
Last edited:

luizmeme

Senior Member
Jan 5, 2012
70
3
0
It's a hardware problem. I got the same issue after 2 months of use. I sent to repair but they wanted to charge me to do that, so I haven't fixed it but I still can get the screen back by pressing and rubbing my finger on top of the sensor.
 

Loco5150

Senior Member
Jun 8, 2008
742
68
0
But when I got it back from repair today it was working. I made few phone calls and it was working totally like normal.
 

nichitandrei

Senior Member
Apr 9, 2010
165
92
0
Dubai
you are not alone

But when I got it back from repair today it was working. I made few phone calls and it was working totally like normal.

I can tell you that you are not the only one with this problem, it happened the same to me. I'm still unsure if the problem is hardware or software, but I think it's software because it happened just after I install Dynamics_2.0_Titan. I really wish that someone will bring a good solution for it.