• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Problems testing TREBLE / GSI roms

Search This thread

rogerty

New member
Sep 28, 2021
1
0
Hello,

I have tested a lot of GSI roms, but I must be doing something wrong, because I have LOTS of problems:

My tablet has these specifications:
Allwinner A50 (Cortex A7 4 cores 1,2 GHz)
1 GB RAM
16 GB ROM
supporting legacy of project treble using vndk 27.0 (I don't know what it means)
seamless upgrades not supported
not using dynamic partitions

Existing partitions (I have this script to reset them all)

fastboot erase system
fastboot flash system system.img
fastboot flash vendor vendor.img
fastboot flash boot boot.img
fastboot flash bootloader bootloader.img
fastboot flash recovery recovery.img
fastboot flash private private.img
fastboot flash misc misc.img
fastboot flash metadata metadata.img
fastboot flash media_data media_data.img
fastboot flash frp frp.img
fastboot flash env env.img
fastboot flash empty empty.img
fastboot flash dto dto.img


I always test roms for a-only arm 32, by the way...

- The systems reboot into bootloader, or hangs in the logos, or are or become slow as hell, or have other problems (see the attached file for all the details, please)...

Also, I have some doubts:

- Every time I have to reflash system.img original, and then reset to factory. Why is it necessary, if I also delete the system partition every time and flash with the -w option ?!

- I am also aware of always choosing a rom having a slightly less size than the original to avoid overlapping partitions.

- The roms are generic, so they must work ? It's not normal what is happening to me ?

Thanks in advance ! This is a little nightmare, really...
 

Attachments

  • Lamentablet ocu 2020 t8116 misc.zip
    9.2 KB · Views: 5