Problems With Micro SD Card On My Samsung Galaxy Grand Prime Plus Phone

Search This thread

kobisko

Member
Jan 8, 2018
9
0
Hello:
I don't understand why My phone does not recognize my Micro SD Card. It has been like that since I bought it four years ago. It didn't work with the SD Card that came with the phone, and even when I bought another one it still didn't work. On the contrary, the card is recognizable by my computer, and when I inserted it in to the phone, using a card reader, it was recognized. But when I put it back in to the SD slot on top of the first SIM slot, it doesn't get recognized.
Please what can be done about this problem. My phone storage is already full. It is just 8GB.
Thanks for your anticipated help.
 

kobisko

Member
Jan 8, 2018
9
0
Look inside here:
Hello:
I've gone through the article you referred me to. The SD card is recognizable on the computer as I did inform you in that post, so I tried reformatting the card.
But when I visited the link on formatting the SD card, I got this message: You don't have permission to access /EN/Fat32Formatter/ on this server.
So, what else can I do.
 

kobisko

Member
Jan 8, 2018
9
0
Hello again:
I've formatted my micro SD card with the link you gave me, but the card is still unrecognizable or undetected by the phone. I remember I did the formatting about a year ago.
I am convinced that the problem is a hard ware one, considering the fact that the card can be detected by another phone and the computer. It was detected on my phone when I inserted it in to a card reader and plugged it in to my phone with the OTG cable. But when I put it back in to the SD card slot, it was not detected.
So, the question now is: what can I do now? how can I increase the storage of my phone. My phone internal storage is now full, and I cannot delete any apps.
What other methods can I try out. Or is there a way of fixing the micro SD slot?
The phone came that way. I didn't care to check the SD card slot before the warranty expired.
 

blackhawk

Senior Member
Jun 23, 2020
2,444
459
Inspect the SD bay contacts. Clean card contacts with isopropyl alcohol/cloth and don't touch them with your fingers.
Make sure it's properly seating in the phone.
Try a hard reboot the phone with the card in it.
Try another card.

Whatever app the device uses for storage control check there to see your options.
In the 10+ it's under Device Care>storage>SD card page 3 dots upper right corner.
If it gives you the option to format it, do so. You will lose any data on the card but it should functional then.
It's best to format the card in the device first before using it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    How can I find the the menu item of formatting my storage settings of Micro SD card.
    have you tried going on your Phone setting and searching for the word "SD"
    that would show SD card size and option to format it and such
    or perhaps have you tried insert other SD card or SD card socket itself has issue?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone