project SLIMBOX

Cayo2290

New member
Jan 13, 2021
2
0
1
USB_Burning_Tool v 2.0.0 runs on GT1Mini probably also suitable for GT1Mini-2 Beelink boxes react differently to OTG

1). You connect the cable and it is visible immediately
2). Another needs to hold the reset button and connect the usb
3). My GT1Mini works for 3 seconds after plugging and then disconnects from USB_Burning_Tool

installation method:

a). run USB_Burning_Tool on pc
b). connect usb to pc add .img and set it as shown in the SLIMBOX instruction
c). once you've done everything hit "START" in USB_Burning_Tool
d). now connect the box and wait for the process to finish
e). do not use USB 3.0 for this purpose
A). If you have the https://www.widevine.com/ license, you will lose it by installing this firmware, but if you don't care about widevine it then SLIMBOX is a good choice.

@superceleron, from freaktab, also made an excellent multi rom one for many models 905x2 & 905x3
Can someone confirm if has installed Slimbox in gt1mini2 please? I am sure I am doing everything okay, I am so bored. I mean my tv box works fine, but the interface is just awfull. and I don't like that the tv box is rooted and I can't turn oof the root. even with developers options, there is not an option to turn the root off. and I can´t install apps I need. I NEED HELP
 

wiwi60

Senior Member
May 6, 2012
70
9
43
Oise
freeaddons.free.fr
I tried out all the Netflix APKs found in this link http://freeaddons.free.fr/public/AML/X96AIR/Apps Apk/Netflix/

They are all the mobile version of Netflix. I have found a working Android TV version of Netflix if the person who manages that link wants to upload it.

I try it soon and i add your apk TV version on the folder link thanks for!!! Merci!!!
Netflix ATV apk version
Edit: I try installation ok and il launch a movie to verify.... Thanks again!
 
Last edited:

kalehrl

Senior Member
Nov 22, 2017
521
230
43
rebooted and still doesnt work. It says abnormal status in drive status. Do i need USB audio enabled or something? My setup is with an hdmi cable and the sound is processed through a receiver. For movies and tv shows i dont really need viper but for youtube, deezer and similar apps for music it should work or am i missing something??
I didn't enable anything.
My box is directly connected to my TV.
Maybe your receiver is to blame.
 

Bertonumber1

Senior Member
May 17, 2020
622
154
53
Glasgow UK
Hey, can anyone help ? I bought a x96max + S905x3 box sold as a 4/32gb and received it today . took it straight out of the box turned it on and saw the crap android 9 launcher and the crap stock firmware .
Went to flash @SlimHouse ATV rom for the X96max + it flashed OK and when I went to reboot , NOTHING , just a black screen .
On further inspection I opened the box up and the cheeky little fookers have only just sold me a box stamped on exterior 4/32gb , but the board and chip is a 2/16gb .
I don't know if I can recover from this .
If I leave the box on for 10 minutes the blue boot will come on but its not showing on the burntool. I've not even got recovery now . Any ideas , apart from a beermat or book stop? The box IP is showing up on Ethernet could I possibly install firmware from sdcard via telnet/putty ??

I'm usually an Allwinner/Amazon dude so maybe one of the guys familiar with amlogic could help .

Thanks in advance , and as always its greatly appreciated
 
Last edited:

wiwi60

Senior Member
May 6, 2012
70
9
43
Oise
freeaddons.free.fr
Hey, can anyone help ? I bought a x96max + S905x3 box sold as a 4/32gb and received it today . took it straight out of the box turned it on and saw the crap android 9 launcher and the crap stock firmware .
Went to flash @SlimHouse ATV rom for the X96max + it flashed OK and when I went to reboot , NOTHING , just a black screen .
On further inspection I opened the box up and the cheeky little fookers have only just sold me a box stamped on exterior 4/32gb , but the board and chip is a 2/16gb .
I don't know if I can recover from this .
If I leave the box on for 10 minutes the blue boot will come on but its not showing on the burntool. I've not even got recovery now . Any ideas , apart from a beermat or book stop? The box IP is showing up on Ethernet could I possibly install firmware from sdcard via telnet/putty ??

I'm usually an Allwinner/Amazon dude so maybe one of the guys familiar with amlogic could help .

Thanks in advance , and as always its greatly appreciated
Maybe "sdcard flash method " if exist with a stockfirmware
 

Bertonumber1

Senior Member
May 17, 2020
622
154
53
Glasgow UK
Maybe "sdcard flash method " if exist with a stockfirmware
hi there and thanks for reply i got it working by shorting the pins , well at least its showing in usb burn tool now , just trying to find the correct latest rom for the 2/16gb x96max +


###Edit ### Just flashed slimbox 2g version x96max + , its an absolutely stunning ROM , really smooth and quick , Is Magisk able to be flashed on this and could anyone tell me how ? I tried no dmverity and magisk from both slim twrp and twrp VIT 3.22 .......both no avail ...Bah. Anyway @SlimHouse thank you for your amazing ROM
 
Last edited:

pspablo

Member
Dec 9, 2016
30
1
8
Hey, can anyone help ? I bought a x96max + S905x3 box sold as a 4/32gb and received it today . took it straight out of the box turned it on and saw the crap android 9 launcher and the crap stock firmware .
Went to flash @SlimHouse ATV rom for the X96max + it flashed OK and when I went to reboot , NOTHING , just a black screen .
On further inspection I opened the box up and the cheeky little fookers have only just sold me a box stamped on exterior 4/32gb , but the board and chip is a 2/16gb .
I don't know if I can recover from this .
If I leave the box on for 10 minutes the blue boot will come on but its not showing on the burntool. I've not even got recovery now . Any ideas , apart from a beermat or book stop? The box IP is showing up on Ethernet could I possibly install firmware from sdcard via telnet/putty ??

I'm usually an Allwinner/Amazon dude so maybe one of the guys familiar with amlogic could help .

Thanks in advance , and as always its greatly appreciated
See my post on page 33, maybe that will help.
 

Bertonumber1

Senior Member
May 17, 2020
622
154
53
Glasgow UK
See my post on page 33, maybe that will help.
Thank you for your response, unfortunately I had no way of backing up/restoring anything, I couldn't get twrp. I took it straight out of the box brand new, and tried to flash a rom meant for the 4/32gb edition of the X96max +. My box (even though stamped with 4/32 stickers) was only a 2/16gb and this caused a hard brick.

To solve the matter I had to short out pins and reinstall the amlogic driver then ran Slims rom through the tether in UBT.
I then patched the boot with magisk, flashed 21.3.zip and no dm verity and we have a fully working box now.
Thank you for your input, it's appreciated
 

pspablo

Member
Dec 9, 2016
30
1
8
Thank you for your response, unfortunately I had no way of backing up/restoring anything, I couldn't get twrp. I took it straight out of the box brand new, and tried to flash a rom meant for the 4/32gb edition of the X96max +. My box (even though stamped with 4/32 stickers) was only a 2/16gb and this caused a hard brick.

To solve the matter I had to short out pins and reinstall the amlogic driver then ran Slims rom through the tether in UBT.
I then patched the boot with magisk, flashed 21.3.zip and no dm verity and we have a fully working box now.
Thank you for your input, it's appreciated
Can you write how you managed to correctly upload Magisk? I am asking for instructions.
 

zaidRANGER

New member
Jan 16, 2021
1
0
11
Is there a way to install this rom without PC? i don't have an A to A usb cable nor do i have an sdcard, can i somehow install this with TWRP?
 

Bertonumber1

Senior Member
May 17, 2020
622
154
53
Glasgow UK
Can you write how you managed to correctly upload Magisk? I am asking for instructions.
Sure no problem first I flashed the slim 10.4 and then used slim recovery from USB to twrp flash boot partition of the rom with https://drive.google.com/file/d/1d0VNjGuwELn7ITrfkujnTtEwpSEqk2l6/view?usp=sharing (unzip and you'll have the files)
which patched the boot partition , without rebooting and staying in TWRP I then flashed 20.3 full zip and then no dm verity zip, and then booted into system os. Once I verified I had root I rebooted to twrp and flashed magisk 21.3.

edit : @pspablo check the below post for update if you require
 
Last edited:
  • Like
Reactions: pspablo

Bertonumber1

Senior Member
May 17, 2020
622
154
53
Glasgow UK
Yes you can install Magisk through TWRP by flashing the image of magisk_patched_new.img by selecting the boot partition. BEFORE you have to delete the root by always flashing in TWRP UPDATE-unSU-signed.zip
This is version 20.3 of Magisk, after you must update it by downloading the ZIP version 20.4 from the Magisk Manager application or by downloading it HERE. And then flash the ZIP with TWRP.
hey i managed to root my x96max + last night with your old image , now i will Reflash with UBT and use this one.


Yourself or anyone else in the thread wouldn't happen to know how to change the bootanimation on 10.4?
While it was a good gesture in timing with the build release It's just not Xmas anymore.... The zip isn't in system/media were It normally is.


Thanks

Regards
 
Last edited:

kalehrl

Senior Member
Nov 22, 2017
521
230
43
I read on 4pda that blue LED can be disabled by this command:
Code:
echo 0 >/sys/class/leds/blue/brightness
but it only switches the blue LED for a couple of seconds and then it turns on again.
Any permanent solution for both blue and red LEDs?
 

wiwi60

Senior Member
May 6, 2012
70
9
43
Oise
freeaddons.free.fr