• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

project SLIMBOX

Search This thread

nokenokex

Member
Jul 30, 2021
12
1
Nice to meet you! I'm Japanese and I'm not good at English, so I use google translate.

slimbox TV is very nice.
But there is one problem for me.
That is, I can't log in to my google account and I can't use the google play store for android TV.
I can't log in to my google account, so I can't use google drive or photo.

Most apps can be downloaded and installed by apk, but you can't find Japanese unique android TV apps (TVer, d anime store, etc.) by searching the apk.
That's why I want to install the google play store and download those apps from there.

What I tried:
・ Install google play service from aptoidTV → Cannot log in
・ Install Google from aptoidTV → Google appears in the settings account, but when I click it, it remains a black screen and does not proceed

-Installing openGapps from the zip version of TWRP → There is a log that the installation was successful, but it is not actually installed. Similarly, magisk was installed from TWRP, but it is not installed.
Is it necessary to overwrite the android default recovery with the .iso version of TWRP?

I'm a beginner about android TV BOX, so I'm sorry if I'm doing something wrong.
I look forward to working with you.
I forgot to write it.
My android TV BOX is X96 Max Plus Q2 4G / 64G, and the firmware is the latest slimboxTV ver12.
 

gorillaz_gr

Senior Member
I forgot to write it.
My android TV BOX is X96 Max Plus Q2 4G / 64G, and the firmware is the latest slimboxTV ver12.
hey friend.

this is the original page for your correct firmware:
FIRMWARE: X96 MAX PLUS Q2 with Amlogic S905X3 SoC (12-09-2020)

try to install the original one, and then follow the instructions for installing slimBOX:
slimBOXtv - X96Max Plus
(on the right part of the page , the second box under the blue title is the option to change the language).
 

nokenokex

Member
Jul 30, 2021
12
1
hey friend.

this is the original page for your correct firmware:
FIRMWARE: X96 MAX PLUS Q2 with Amlogic S905X3 SoC (12-09-2020)

try to install the original one, and then follow the instructions for installing slimBOX:
slimBOXtv - X96Max Plus
(on the right part of the page , the second box under the blue title is the option to change the language).
thank you for your reply.

I tried the method taught by gorillaz_gr.
With the original firmware I was able to log in to my google account.
After that, I flashed slimbox and tried to log in, but I still couldn't log in.
Is it possible to log in to a google account from the Settings-Account screen even with slimbox?
 

nokenokex

Member
Jul 30, 2021
12
1
After that, I was able to log in to my google account if I randomly installed google servises from aptoideTV and other things that seemed to be related to google, such as installing OpenGapps again!
But another problem arose.
I downloaded and installed the Google Play Store (Android TV) from the URL below, but I got the error shown in the picture.
(The smartphone version of android google play worked)


You can't download apps optimized for android TV on the smartphone version of the play store, right?
If possible, I would like to install the Google Play Store (Android TV) and install the app optimized for android TV.

IMG20210731111210.jpg
thank you.
 

nokenokex

Member
Jul 30, 2021
12
1
I'm sorry for the continuous posting.
I also had a mi tv stick, which had a Japanese localized TV version of the google play store installed.

So, first, I installed the TV version of the app (amazon prime video, TVer, etc.) from the google play store on the mi tv stick, and extracted the apk file from it.

When I installed the extracted apk file on X96, TVer, d-anime (a popular app in Japan), and amazon music worked fine.

The google play store still didn't work.
Amazon prime video did not display the right edge of the screen like the picture, and the video could not be played.
(This caused the same problem when I installed amazon prime video from aptoid TV)
Amazon prime video, which is not the TV version, works fine.
IMG20210731134646.jpg

IMG20210731134704.jpg

Do you know the cause of this bug?
Also, do you use the TV version of amazon prime video or google play store?
Or are you using the smartphone version of it?
 

sesdave

Senior Member
Dec 5, 2011
66
8
Hi - getting a data error extracting HK1 box Pie v12 using 7zip. Downloaded file numerous times always get the data error on extract. X96 max plus 4gb and TX9S files no problem. Sorted - used another pC and worked ok
 
Last edited:

l3g0r

Member
Nov 16, 2013
7
0
hi I think that bb2 atv v12 version is not working , I flash twice and the same black screen , no boot.

Is it posible to add a newer android security patch? (as Aidan's ROM)
 

tombraga

Senior Member
Jan 24, 2017
651
99
Xiaomi Poco F3
There is a patch apk to delete Google Services to get slimbox light. Anybody tried?

But only the Services are uninstalled and we keep the Google Playstore working and also the Google Account, right?

Now i can respond it to myself, deletes all datas, too bad. Good, that i did a nano TWRP backup before...
 
Last edited:

dazedcrazy

Member
Jan 23, 2013
8
1
Version 12.7 ATV has the same problem that Version 11.6 had were HDR is just stuck on all the time on a X96 Max Plus Q2. Changing HDR to SDR and SDR to HDR both to off does nothing it just stays on.
 

lchang.atsoft

Senior Member
Oct 9, 2020
50
2
I have a tx3 mini that reboot by itself many times or I'm unable to install apps or apps crash all the times and i can barely use it. Even if i install original firmware with usb burning tool or any other firmware made for my revision of tx3 mini i always have the same problem. I flash the same firmwares on other tx3 mini of same revision and they all work ok. It happen also with a TX3 s905x3 i got and the same firmwares was used on other TX3 s905x3 and never had any problem.
Anyone never had this kind of problem?
It's probably the power supply. Replace that and you will have peace.
 

jaytec0007

Member
Mar 27, 2017
35
7
Version 12.7 ATV has the same problem that Version 11.6 had were HDR is just stuck on all the time on a X96 Max Plus Q2. Changing HDR to SDR and SDR to HDR both to off does nothing it just stays on.
Hi I had the same problem with x96 max + A100, the way I found to make it work is to do a backup of Vendor from original firmware with TWRP then after installing slimbox 12 i went back in TWRP and restored Vendor. After reboot, whit all aps you will have DroidTV Settings, then go in Display and clic on Adaptive HDR and disable it to turn it off. Here is the TWRP I used. You will have some apps from original firmware that will install when restoring Vendor but you can uninstall them after if you want
 

Attachments

  • TWRP_AML_SlimHouse_3.4.0_3.zip
    12.5 MB · Views: 26

hammo650

Member
Aug 3, 2021
7
0
I also have the newer x96 MAX + A100 version, was going to do the install as instructed in last post but you mentioned SD card does not work and i need that working so will stick to the factory ROM that came installed. Hopefully Slimbox can cook up a ROM for the A100 version of this box.
 

jaytec0007

Member
Mar 27, 2017
35
7
I also have the newer x96 MAX + A100 version, was going to do the install as instructed in last post but you mentioned SD card does not work and i need that working so will stick to the factory ROM that came installed. Hopefully Slimbox can cook up a ROM for the A100 version of this box.
yea SD doesn't seem to work in v12 for A100, but the firmware is still in the firmware test section from slimbox website, I already sent him a msg about the SD card and the HDR to SDR wont turn off. When I insert an SD card the box will show that an SD was plugin but don't see it inside any file browser app and when looking in the settings in storage it says that SD was correctly ejected. I used an USB drive to backup Vendor from original firmware
 
Last edited:

hammo650

Member
Aug 3, 2021
7
0
You mentioned in a previous post that after restoring vendor the only thing that didn't work was SD card port, can you please confirm the SD port works after flashing as well as BT, WIFI etc, i was also wondering if there is a link to the stock A100 version firmware.
 

jaytec0007

Member
Mar 27, 2017
35
7
It's probably the power supply. Replace that and you will have peace.
I use the same power supply for a while whit other boxes after flashing firmware and didn't had any problems, but just to be sure I try whit a new power supply and problem still there. Its very unusual cause even if I flash whit the original firmware or any other firmware made for my tx3 mini mini v1.6 it does the same. Sometime the box will reboot 3-4 times before I get to home screen and if I browse a USB drive or try to install an app sometime launcher will crash or box will reboot. I also have the same problem with a tx3 s905x3 but much less worse. I had to flash maybe 20 boxes in the past week and they all working good. With the tx3 mini I try everything I know, wipe everything in twrp and flashed right after, or restore a backup from twrp. Also tried more than 15 differents firmwares and still the same
 

hammo650

Member
Aug 3, 2021
7
0
yea SD doesn't seem to work in v12 for A100, but the firmware is still in the firmware test section from slimbox website, I already sent him a msg about the SD card and the HDR to SDR wont turn off. When I insert an SD card the box will show that an SD was plugin but don't see it inside any file browser app and when looking in the settings in storage it says that SD was correctly ejected. I used an USB drive to backup Vendor from original firmware
 

Top Liked Posts