Proximity Sensor Re calibration?

Dec 11, 2014
25
2
0
I have an issue with the proximity sensor on a LG G4 H810 (AT&T).

Out of a batch of 5 devices, all using the same Verizon branded tempered glass screen protectors (on AT&T devices), one of them refuses to work with the glass protector installed.

It's crystal clear, but when its on there and you dial a number, the screen immediately turns off (black), and you cannot force it back unless the call is ended by the other person.

Taking the glass screen protector off, immediately resolves the issue. So i know this proximity sensor must be out of whack.

Any way to re calibrate that bugger?
 

cym1124

New member
May 17, 2008
4
12
0
To re-calibrate proximity sensor in LG G4.

This issue can be solved by re-calibration proximity sensor, you still can use screen protector with sensor covered up.
Mine is H815.

Follow steps below to re-calibrate proximity sensor(must with the glass protector is installed and which is sensor covered up)

1. TYPE "277634#*#" in phone dialer. Hidden Menu screen will show up.

2. Select "Device Test"->"MT", it will show "system will be restarted", then choose OK.

3. After reboot, GENESIS MiniOS 3.1 screen will show up, press "individual item+power" while power button is pressed.

4. Next, find "sensor test", enter it(do not block the proximity sensor), the proximity sensor will be automatically calibrated. Then block proximity sensor two times to exit.

5. Find "Back to the MainList", enter.
6. Press "Normal boot+power" while power butten is pressed to reboot system, done.

Now the problem should be solved.
 

Attachments

Last edited:

sampathkumar2811

Senior Member
May 27, 2013
103
21
38
Hyderabad
Tried and waiting for results

I have tried the below steps.It seems fine for now.Will confirm after proper checking. :)



This issue can be solved by re-calibration proximity sensor, you still can use screen protector with sensor covered up.

Follow steps below to re-calibrate proximity sensor(must with the glass protector is installed and which is sensor covered up)

1. TYPE "277364#*#" in phone dialer. Hidden Menu screen will show up.

2. Select "Device Test"->"MT", it will show "system will be restarted", then choose OK.

3. After beboot, GENESIS MiniOS 3.1 screen will show up, press "individual item+power" while power button is pressed.

4. Next, find "sensor test", enter it(do not block the proximity sensor), the proximity sensor will auto be automatically calibrated. Then block proximity sensor two times to exit.

5. Find "Back to the MainList", enter.
6. Press "Normal boot+power" while power butten is pressed to reboot system, done.

Now the the problem should be solved.
 

alok_dhawal

Senior Member
Aug 24, 2009
266
41
0
This issue can be solved by re-calibration proximity sensor, you still can use screen protector with sensor covered up.

Follow steps below to re-calibrate proximity sensor(must with the glass protector is installed and which is sensor covered up)

1. TYPE "277364#*#" in phone dialer. Hidden Menu screen will show up.

2. Select "Device Test"->"MT", it will show "system will be restarted", then choose OK.

3. After beboot, GENESIS MiniOS 3.1 screen will show up, press "individual item+power" while power button is pressed.

4. Next, find "sensor test", enter it(do not block the proximity sensor), the proximity sensor will be automatically calibrated. Then block proximity sensor two times to exit.

5. Find "Back to the MainList", enter.
6. Press "Normal boot+power" while power butten is pressed to reboot system, done.

Now the the problem should be solved.
This worked like a charm. I had installed a new tempered glass protector and the problem started. But after this working fine! Thanks a ton
 

vivekiny2k

Senior Member
Oct 31, 2010
69
4
0
Do you know happen the code for Tmobile version?

I want to prevent the phone from turning off because of the proximity sensor completely.
 

Spookymyo

Senior Member
Dec 12, 2007
919
222
73
45
Morristown, TN
I know it can be recalibrated. I've done it on mine. I was just referring to the glass screen protector. The normal screen is directly touching the proximity sensor the glass screen protector isn't. It's a problem that's been mentioned before with the glass screen protectors that don't have a cut out for the proximity sensor.
 

shahper1

Senior Member
Oct 16, 2015
76
14
0
This issue can be solved by re-calibration proximity sensor, you still can use screen protector with sensor covered up.
Mine is H815.
Thanks man, re-calibration of proximity sensor solved the problem...kudos...I have the same model, problem started after putting tempered glass protector.
 

DerekZ10

Senior Member
Aug 18, 2011
72
39
0
is there a way to do this on verizon model?
Enter the codes using the dialer. Use the Verizon Diagnostics code to get into the MiniOS.

Verizon Diagnostics
Uses: Various Sensor tests, GENESIS MiniOS,
##228378
Verizon Hidden Menu
##PROGRAMxxx where xxx would be 986 for the VS986 model.
Location and MMS Debug Menu
##DEBUG
Feature Enable/Disable Menu
##FEATURE

EDIT:
Realized I did not include the service code. If asked for one enter six zeros: 000000
 
Last edited:

quasarcreator

New member
Jan 7, 2016
2
0
0
I went to do the sensor test, however after entering it I got an error message which read along the lines of 'proximity calibration fail' and it wouldn't do anything from there, and I still have the same issues. Any ideas?
 

myphonesbetter

Senior Member
May 15, 2011
120
8
0
This issue can be solved by re-calibration proximity sensor, you still can use screen protector with sensor covered up.
Mine is H815.

Follow steps below to re-calibrate proximity sensor(must with the glass protector is installed and which is sensor covered up)

1. TYPE "277634#*#" in phone dialer. Hidden Menu screen will show up.

2. Select "Device Test"->"MT", it will show "system will be restarted", then choose OK.

3. After reboot, GENESIS MiniOS 3.1 screen will show up, press "individual item+power" while power button is pressed.

4. Next, find "sensor test", enter it(do not block the proximity sensor), the proximity sensor will be automatically calibrated. Then block proximity sensor two times to exit.

5. Find "Back to the MainList", enter.
6. Press "Normal boot+power" while power butten is pressed to reboot system, done.

Now the problem should be solved.
@cym1124 Pease add this code to your original post.

Just thought I would add a little to this thread since it is the first one that pops up during a google search and a LG representative just gave me instructions from it word for word. Even the typo (unless theres a typo in the manual or something).

I don't know why, but that code (277634) doesn't work on my phone. I think It may be an earlier beta or something.
Its att but it had an early software on it, 810 09e.

Here is the one that works. *#546368#*810# , I would assume that you could replace the 810 with whatever your model number is.
The code I found actually had 815 at the end.
I found this code at the bottom of the comments on a youtube video. So thanks to whoever that person is.

The second problem I had was I could not get into MT mode. Whenever it prompted me to restart, I chose ok and it did nothing.
Im not sure why it would work, but I just tried it about 5 times in a row finally (after 2 weeks of trying other soloutions) and it finally booted into genesis.

After that the normal instructions worked.

Side note. Apparently the software for 810 09e might not have its qfuse blown. meaning it could've been the only ATT phone g4 with an unlockable bootloader. But I thought that an update would fix my proximity issue. WORNG. well now we'll never know.

Anyways hope this helps someone out there. Even you LG tech reps.
 
  • Like
Reactions: coredump

MindSpace

New member
Jun 23, 2016
1
0
0
This issue can be solved by re-calibration proximity sensor, you still can use screen protector with sensor covered up.
Mine is H815.
Follow steps below to re-calibrate proximity sensor(must with the glass protector is installed and which is sensor covered up)
1. TYPE "277634#*#" in phone dialer. Hidden Menu screen will show up.
...

@cym1124
For me, to access the Hidden Service Menu I needed to use: *#546368#*815#*
Apparently for Taiwanese model.