[Q&A] Lenovo phones / Cybermaus ROM's (A750, A789, P700i, A660)

Search This thread


Mar 6, 2009
hey brother!!!
you can try this out....i have heard that there is a recovery builder on cwm's website...it will build a suitable recovery if you upload suitable files like boot.img and others of your model....try building it out and flashing it...should work...anyway hit thanx if i helped you out...i too feel lack of resources for the lenovo phones....

---------- Post added at 09:58 AM ---------- Previous post was at 09:56 AM ----------

i dont think a deleted app can be recovered...still you can find suitable app for your model and push it into system...tell me your model...may be ill help you out...you can always download some other browser like chrome and others from he play store...should work like a charm...

The page you are referring to needs a base recovery. I am not sure what to put in there.


New member
Jul 26, 2014
Please can someone who has a copy of A789_ROW_S107_cybermaus_ICS_v3.21.zip that THEY KNOW WORKS please upload it to somewhere and please post the link. There seems to be a problem downloading the version that is in the guide in Cybermaus' DevHost site, it downloads extremely slowly and then at the end files are missing every time, I have tried to download it many times on different days, the scatter file and lots of others are missing and sometimes it stops at around 150MB but says it is 100% done.

Please help.
Last edited:

Kopi Pasta

New member
Aug 13, 2014
a560 need help

do have any dev for lenovo a560 ?!
the stock firmware is not stable (android 4.3.3)
so looking to change too kitkat or downgrade to ics 4.0

thx in advance


Senior Member
Jan 7, 2014
new Delhi
okkk lets try this one fix

That's sad, I do not have stock recovery otherwise I would have flashed it and perform a reset.

brother try to the stock rom zip official for your phone...it should contain stock recovery...i mean flash stock rom....automatically stock recovery will be flashed.....it has atleast worked for my device many time...i have a lenovo p700i....shuld work for you too....hit thanks if this works...


Senior Member
Jan 7, 2014
new Delhi
can be conflicting bro!!

Please can someone who has a copy of A789_ROW_S107_cybermaus_ICS_v3.21.zip that THEY KNOW WORKS please upload it to somewhere and please post the link. There seems to be a problem downloading the version that is in the guide in Cybermaus' DevHost site, it downloads extremely slowly and then at the end files are missing every time, I have tried to download it many times on different days, the scatter file and lots of others are missing and sometimes it stops at around 150MB but says it is 100% done.

Please help.

sorry bro!!
i could have mirrored the file but this can't be done unless cybermaus- the great does not expressly authorise to do so...


New member
Sep 23, 2008
This means I very much doubt you can get it properly into VirtualBox, not even when 'auto-grab-usb' is active. Or at least, I have never been able to do it from VMware. And WINE is out of the question completely.

So, find yourself a real Windows PC, or dual boot one. But not Virtual. The drivers work on XP and both 32 and 64 versions of Win7

This is how I got it to load the VCOM drivers in Virtualbox Win7-64bit in Debian Wheezy but probably works also for Ubuntu/KUbuntu/etc. I dont know if there are other issues I will run into later but finally got step one, the VCOM USB drivers recognized.....
NOTE: you must have installed "VirtualBox Extension Pack" otherwise you cannot pass the USB to the VM in Virtualbox.

1.) remove phone, shutdown, remove battery (do not connect until later)
2.) get MT65xx USB VCOM driver (for me usb2ser_Win764.inf), startup Win7 VM and add the driver to "c:\windows\inf" folder. Shutdown Win 7 VM.
3.) use "lsusb" to see what USB devices you have attached
4.) attach phone (do not turn on) and spam "lsusb"
5.) a new entry will be there, for me it was: "Bus 003 Device 010: ID 0e8d:2000 MediaTek Inc."
6.) Unplug phone.
7.) go to Virtualbox, right-click your win7 VM: settings -> USB -> add empty filter
8.) fill in manufacturer field that you found with "lsusb" refresh, for me "Manufacturer: MediaTek"
9.) startup Win7 box and when system has loaded up and everything is at rest, attach phone (still off). You should see Windows search and load drivers VBOX USB etc. etc.


Senior Member
Aug 2, 2010
after loading scatter file for a660 i get the screen at the attachment


i dont thing that this is normal.....

other question: why you dont provide everything for a tutorial you linking at?


  • scatter.PNG
    28.2 KB · Views: 53
Last edited:


Sep 13, 2013
Please help. Where can I get a recovery image for lenovo s898t+ . I un installed by mistake a system app and i need to do a hard reset.


Senior Member
May 26, 2015
my phone can't go thru recovery and can't boot properly. I mean it only shows the bootlogo and the "have been in factory" message. anyone knows a workaround?


Mar 6, 2009
Got Stock ROM for A600E (RELIANCE) and recovered completely. CHEERES!

I have rooted my Lenovo A600E using Framaroot and it is successfully rooted. I have also found fastboot working with my Lenovo A600E. For this I have installed LeTools_MultiLang_x86_x64_Full_setup_20320.exe (Googled it) and used fastboot available with tool. Other fastboot exe won't see Lenovo phones.

D:\Tools\Lenovo>adb reboot bootloader

D:\Tools\Lenovo>fastboot devices
A600e   fastboot

I didn't found a recovery for my specific model so I picked up other Lenovo recoveries and tried to flash it. after running fastboot flash recovery recovery.img:

D:\Tools\Lenovo>fastboot flash recovery recovery.img
  sending 'recovery' (3060 KB)... OKAY [  0.338s]
            writing 'recovery'... OKAY [  0.652s]
finished. total time: 0.992s

but it didn't work and I have lost stock recovery. If someone can help me with recovery I will be very thankful.

My phone is still working fine with normal boot. Only I can't boot into recovery.
  • Like
Reactions: pravoacidic14


Mar 6, 2009
Lenovo A600E Stock ROM

Got Stoock ROM for A600E from some strange site. Since this phone is for Reliance it is difficult to find a ROM or support from Lenovo.

Link is here:

brother try to the stock rom zip official for your phone...it should contain stock recovery...i mean flash stock rom....automatically stock recovery will be flashed.....it has atleast worked for my device many time...i have a lenovo p700i....shuld work for you too....hit thanks if this works...


Nov 1, 2005
hi all i am newbie trying to insert MTS sim into lenovo A600E but the network is locked with reliance , is there any option we ca use MTS Sim in this phone. if we try to port new rom is it possible to use the MTS Sim. please help me to understand where the sim settings are written in Android ....


New member
Jan 18, 2015
SD card mounting problems

Hi all,

so I have Lenovo p700i with Cybermaus ROM ICS 3.3. I followed the instructions from myxal and bgccgm from post 556 onwards (at http://forum.xda-developers.com/showpost.php?p=36407241&postcount=556) to remove internal SD and join its size with phone storage. It was difficult to follow, but in the end it worked well - big phone storage, no internal SD and SD card mounted at /mnt/sdcard (wonderful work guys).

Then much later my power button broke down, which I did not suspect - I suspected SW problem (it just did not react and I could not turn it off). Therefore I tried to flash different versions of recoveries that I had stored. After getting the power button repaired, I managed to repair almost all SW damage I did with flashing those unfinished versions.

My current situation is, that /mnt/sdcard is not mounted, /dev/block/vold/179:97 is mounted on /mnt/sdcard2 (SD card), even though in vold.fstab is as only uncommented line dev_mount sdcard /mnt/sdcard auto /device/platform/goldfish_mmc.1 /devices/platform/mtk-sd.1/mmc_host

I don't care if sdcard is mounted under /mnt/sdcard or /mnt/sdcard2, but pocket and evernote (two apps that I most use) seem not able to find the sdcard. And bind-mount /mnt/sdcard2 on /mnt/sdcard didn't seem to help, but recovery has no problem with sdcard, it gets mounted and I can install zip files.

I am not afraid to work with adb/fastboot/whatever, please help. What info about the phone do you need?


Feb 10, 2013
MT6582 (Lenovo A536) with IMEI but no Signal

Hello, I have a Lenovo A536 and it bricked. So I initally flashed this ROM Lenovo A536_USR_S120_1409181715_MP1V2.10_BMAIN_ROW using SP Flash Tool and back-up using MTK Droid Tools. It worked fine (Sim card is detected with network signal) but when I flashed a new ROM Vibe2_euro_linarmaximum to update my phone, I started to encounter the following problems:
  1. Sim Cards not detected ( Sim slot 1 & 2)
  2. No Signal
  3. IMEI=null

Now, I reverted back to the first ROM I used but it was the same. I downloaded another ROM A536_S147_140910_ROW hoping things will change. I managed to retrieve the IMEI number at the back of my phone and add it using MTK droid tools. It was recorded as expected but still no network signal. I thought the IMEI problem will fix the network signal. I have tried a lot of things now and I'm desperate to fix this.

Can somebody please help me :crying:


New member
Sep 29, 2015
Hey cybermaus... Sorry to disturb u... Just wanna know about the custom recovery for lenovo A560... I really need a custom recovery for A560... Would u pls help me??


Jan 19, 2018
Rom for Lenovo a789

I don't want to necroBump a dead thread, but I recently unearthed an old Lenovo a789. The firmware is Android 4.0.4 which means half of the Apps I need will not install. Is there a more up-to-date rom that I can flash onto it?

Top Liked Posts

  • There are no posts matching your filters.
  • 27
    Hi all

    I am opening up this Q&A thread as extension to my ROM threads, for the simple reason that ever since there is a limitation preventing new users from posting in development threads, I get flooded with PM's. So I intent to move any Q&A, help requests, as well as free and open discussions between users here.

    Since the A750 and A789 are so similar, and I put the same stuff in them, I extent both into this one Q&A thread, and in fact, much of it knowledge applies to other Lenovo's like the P700, P700i, S880, A660 which are again very similar and I even use them as basis of my ROM.

    Also, I am not intending to be topic police. Like in my other threads, I do not mind if you guys share knowledge about APKHOT or Smileyvvv or Etotalk ROM. As long as it is helpful. Also, I may not always reply myself, so feel free to help each other.

    Link to the original threads:
    [ROM][2012.xx.xx] Lenovo A750 custom ROM (GB&ICS). <last page>
    [ROM][2012.xx.xx] Lenovo A789,P700i,A660 factory&custom ROM (ICS). <last page>

    Other related threads (not all mine):
    CWM flashing tutorial (update using recovery)
    MT6575 flashing tutorial (update using flash utility
    Lenovo Original recovery tutorial
    [SCRIPTS] Unpack / repack MT65xx boot.img, recovery.img or logo.bin
    [REF] Unpacking and repacking stock rom .img files
    [UTIL][APP]Lenovo Security / LeSec app (anti-virus/spam/theft/firewall)
    [TOOL][TUT]Backup and Restore Mediatek based phone's IMEI
    How to DIY : Self root/gapps/playstore/locationfix/clean my ROM

    This is a guide on how to root & cleanup your China ROM yourself. It will probably work on all ICS China phones. But it requires & starts with the availability of a recovery image for your phone

    There are in fact a few steps:
    - Get a proper recovery image for your phone.
    - Root it by installing Chainfire's root package
    - Install Google GMS ('GAPPS') to get Play Store and Localisation to work
    And optionally
    - Install Mobile UncleToolset
    - Install an extra small fix with location services
    - Install an extra small fix with latest APN list
    - Install an extra fix to remove well known Chinese system apps

    Recovery image
    The Recovery Image allows you to boot into an alternative small Linux that you can then use to update the main Android. Updates usually come in "update.zip" scripted files. And the recovery has some other utilities like backup or wipe the entire phone. Getting a working recovery for your phone is step number one, because if you have a recovery, you can do everything else.

    To check if you already have a recovery: Well, try to boot into it. The boot sequence may vary with the phone, but on MediaTek phones it is usually to replace the battery and then press&hold both volume buttons while powering up. I have seen it where you need to actually press the power button a split second before pressing both volume buttons. Try a few times, replacing the battery each time.

    If you get to a screen that reads CWMR or CWMR Touch (short for ClockWorkModRecovery), you are all set and can continue with rooting. CWMR it is the most common open recovery image. If your recovery is closed, then you need to search the web for a working recovery for your specific model. Each brand and model needs its own recovery, because screen drivers, buttons and partition tables may differ.

    Search the web is the best advise. Search wide and search deep. If you cannot find any recovery, then see if you can find a full ROM for your phone. If you have a working ROM image, then there are people on XDA that can make a recovery for you, but typically you need to show/prove that you have really tried to find one yourself.

    Flashing a recovery
    If you do find a recovery, that you suspect is the correct one for your ROM, then comes the scary part: Flashing the recovery to the phone.

    This paragraph is specific to Mediatek based phones. On different hardware you also need a recovery, and once you have a recovery, you can use the other parts of this post, but how to flash other hardware, I do not know, sorry

    Flashing using the flash tool is scary to new users. Because new users suspect that if they mess it up, the phone dies. And this is correct! But if you only flash the recovery.img part, you should be fairly safe. Read this manual on flashing. Getting the USB driver installed is sometimes a bit tricky, you may also want to read post #21 and post #25 for help.

    I have seen several people asking 'where to find the scatter file'. Well, it comes with the ROM you want to flash. If your ROM file does not come with a scatter file, then is not a ROM file that can be flashed with the flash utility, but with an open recovery.

    Once you have a working recovery, the rest is simple. For rooting, simply install (from inside the recovery) chainfire's "CMW installable ZIP"
    Link to his post: (ignore his big red 'requires root' warning). The file you need is labeled "CWM installable ZIP" at the bottom. Direct link to the file you need to install via recovery update.zip

    This usually works by putting the zip file on the SD card (its name can be anything, though for some limited recoveries it sometimes must be named 'update.zip'), booting into recovery, and selecting the zip file to update.

    Google GMS (Market/Play Store, Location, etc)
    Simply install the latest Google Mobile Services (better known as GAPPS) from CyanogenMod V9. This is their explaining wiki from CyanogenMod
    The file you need is called gapps-ics-20120429-signed.zip for ICS and gapps-jb-20121212-signed.zip for JB and can be found here. You probably also want to wipe your cache partition after doing this.

    Mobile Uncle toolset
    Just install this program apk (so not through the recovery, just install it normally). Or search the web for the latest one.

    Fix location services
    If location services does not work, do apply Google GMS (GAPPS) above. If it still does not work, it may be because the phone is programmed to use Chinese location services. This patch will tell it to use GMS. The patch will apply, and probably even work, on all ICS phones. But was originally made&tested on a Lenovo A750 ICS. Its called V1.3 because many people have downloaded the A750 v1.3 patch and used it on many MT6575 phones. It is still the same patch, except the update.zip is tweaked to work on any ICS phone, not only MT6575 ones.

    Sometimes you also need to go into MobileUncle tool, the MTK Engineer mode, and in location settings. Depending on your exact model, somewhere in there is a NetLoc or NetLocation and a GeoCoding setting, with options of MEDIATEK and GOOGLE. Ensure they are set to GOOGLE.

    After messing with location settings, it is best to also wipe cache.

    Fix APN list (or My 3G does not connect!)
    You can always add your own APN (Access Point Names) from the settings menu. Just add your own, and select that over the pre-build one. But this package will update with the latest list as maintained by CyanogenMod 9. The update.zip was made in such a way it should work on all ICS phones, Mediatek or other.

    Clean well known Chinese system apps
    <patch still coming>


    List of known recovery images for Mediatek Flash tool:
    Lenovo A750 : 592zn : See also this post #607, nandroid backup does not work.
    Lenovo A789 : 592zn or APKHOT
    Lenovo P700i : My own, based on APKHOT with CWM.
    Lenovo P700 : My own, based on CWMT / 592zn. nandroid backup will not work.
    Lenovo A660 : My own, based on APKHOT with CWM
    Lenovo S560 : My own, based on APKHOT with CWM (as yet untested)

    Additional Recovery Images in this post.

    If you feel you searched all over the web, and could not find a recovery for your model, and you next feel you should ask me or one of the other people on XDA to make you one (which I am not encouraging), than please be aware we need at least a 'standard ROM' for your phone to start from. Without it, I can do nothing. So go back out there, and find a standard ROM, does not matter what language, as long as it is for your specific phone model and known to work.

    Also, as an extra warning : If you are flashing, and you experiment with 'suspicious' ROM sources, *never ever* flash the preloader, mbr, ebr uboot. Only flash those from a trusted source and if they belong to your exact brand and model phone.
    I created a port of the TWRP graphical/touch recovery for the A750, the A660, the A789 and the P700i

    The recoveries zip files above were made in such a way they can be applied with the flash tool (scatter file included) or with another recovery (update.zip style)
    lolo250612 said:
    Hello from France,

    Just a little message to thank you very much for your very useful "Lenovo A789 factory&custom ROM (ICS)" thread. I have just bought a A789 from etotalk, and your posts really help to master the beast.

    I can't participate to the thread because I am a new member and consequently can't post message to this development thread. And this very sad, because I have discovered a shortcoming of this phone. Apparently, the ICS entire phone encryption does not work and, according to some information I have gathered around the web, it may be due to the fact that the internal sd partition is not ext4 which seems to be required.

    It may be due to the fact that the kernel does not support ext4. If this was the case, I would be very pleased to activate the option, recompile it and share the result with other people at xda. I have done it for two types of Samsung Galaxy phones.

    In this case, the two problems I would be faced with are:
    1) Getting the kernel sources. For Samsung it is quite easy. For Lenovo, I am not able to find them (I can't read Chinese).
    2) The process to package the new compiled kernel to a zip, compatible with cwm.

    Anyway, thanks for your help and to share your knowledge.



    cybermaus said:
    well, not sure about encryption, but I can *assure* you that the phone supports ext4, because in fact the root; system; cache; secro and data partitions are all in ext4 . I know that quite certain, because to unpack/repack, I need to recreate an ext4 loop device.

    Internal SD is indeed FAT partition. But it is normal for SD to be FAT

    It is possible the encryption fails on the FAT of the SD card. It is an internal device, if that encryption utility tries to parse all the internal partitions, it may fail on FAT, but I am guessing here. However, then it would fail on pretty much all recent china phones, they all seem to have this internal SD card. You could try to simply format the internal SD as ext4.

    I do not think it would fail on the recovery or boot sections. Those are all nicely wrapped up in the first partition of the emmc chip (emmc0p0 or something) in a proprietary filesystem, as I suspect true for all Androids. So your tool would know to exclude that the first one. However, if you want, you can get the original recovery you asked about from the original A789 ROM in my Dev-Host.

    Edit: Encryption issue solved, see post#9 below
    Sorry, I am not doing Languages.

    Still to busy to finish the latest builds for the A660, A789 and S560, but they will happen, at the very least the recovery images.