[Q&A][Oneplus 5]Help thread, newbies post here first

Search This thread

tumba_mc

New member
Jun 28, 2011
1
0
Good night,
I don't know if this is where I should ask this question, but here it goes.
For someone with some patience and availability to help me.
My nephew offered a Oneplus 5 to my daughter and told her the screen was freezing. She managed to use it for a few hours and do facial recognition. Then it froze and the touch stopped working for good.
It opened with facial recognition, but nothing else could be done. I didn't follow the process and ended up not knowing which version of android was installed. I couldn't do anything at all.
I saw and reviewed several posts here on the forum and I've tried several suggestions. All worked in full, but none solved the display problem.
The phone apparently works fine, the keys all work, I've changed the display but the problem remains the same.
If there is someone with any suggestions I appreciate the help.
Thanks

Ícone Validada pela comunidade
 

mmmiiikkk123

New member
Aug 9, 2021
1
0
Hi guys does anyone have a guide for installing stock rom? currently on lineage but would like it back to stock
 

gonzule

Senior Member
Aug 17, 2010
87
9
Melbourne
Hi everyone. Does anyone know any way to edit the camera and google assistant shortcuts on the lock screen, on a non rooted phone?
Thanks
 

Ankzz619

New member
Oct 26, 2021
1
0
Hello Team,

I am not able to flash TWRP on my One Plus 5...I want to install Dot OS to my OP5 but the TWRP twrp-3.4.0-10-cheeseburger-dumpling-mauronofrio also does not work on my device....I flashed the img file through ADB but after booting to recovery, the screen is black and the charging light is ON(USB connected to PC)....Can someone help me with this?....I am right now on Android Version 8.1.0 and Oxygen OS 5.1.2.....Before this trouble, I was using Xtended ROM very well, but faced a lot issue to flash Dot OS....It would be great if someone helps me install this OS to my device....Thanks a lott
 

TheMultiRounderG

New member
Oct 27, 2021
1
0
Hi! So basically, I installed LineageOS today. It installed correctly, and everything was working fine, but I didn't really like it so I wanted to go back to OxygenOS. I wiped using TWRP, and I had taken a NANDroid backup, so I restored the backup. Buuut I think I did something wrong because when I was booting, then first I got the "Your bootloader is unlocked so blah blah" warning, then I got the boot logo, then the screen went black. The only indication that the device was actually powered was the light blue LED on the top bezel. So I 'powered off' by holding down the power button for a few seconds, and booted into fastboot. I flashed TWRP (because I'm pretty sure Lineage deleted my TWRP and replaced it with the Lineage recovery), and then went into recovery mode. TWRP was working fine, but then it turns out that I don't have an OS installed. I know this because when I pressed "Reboot to system" then it gave me the warning that there is no OS installed. IDK what happened. So I installed the OxygenOS zip for OP5 from the OnePlus website, and pasted it into the OP5 internal storage. I tried to flash it, but it gave me a zip treble error. I reinstalled a newer version of TWRP (mine was 3.4.0, the newest is 3.5.2 i think) but it was still giving me the same error. I tried flashing the LineageOS zip too, to no avail. But then I had the absolutely BRILLIANT idea that I was going to restore my LineageOS. You see, I had also taken a NANDroid backup of my phone before wiping it to install the stock OS again. I was sure I had struck gold, but nah. TWRP didn't give me any error after restoring, I booted into system, and then bam. Bootloop. It's a bit weird though, because what happens is-

Bootloader unlocked warning > OnePlus bootlogo > Black screen for a few seconds > Fastboot mode

I thought "Oh it's just fastboot, I can boot into TWRP". And yeah, I *can* do that, but what do I do now? I'm completely stumped. Help. Rn, the only thing I have is TWRP and nothing else is installed, I think.
 

13455887477

New member
Jan 24, 2022
1
0
Mod edit :
I can't find the Resurrection Remix-OS for OnePlus 5 Android 11, can anyone give me a link!
************
我找不到一加5安卓11的Resurrection Remix-OS有没有人给个链接啊!!
 
Last edited by a moderator:

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Oneplus 5 Help Thread



    Welcome to the Oneplus 5 help thread! You can ask all questions here without the need of background knowledge. This thread is dedicated to solve users problems, so if you don't want to start a new thread for your question, ask it here. Members ready to help will be monitoring this thread and provide answers as soon as possible. A list of supporters will be added here as soon as the thread is getting more answers.

    For everyone having trouble with rooting send installing a recovery: Please read this first. Thanks to @Funk Wizard for the great guide!

    To those seeking help: Please don't bombard the supporters with PMs asking for help. Instead, ask your question here in the thread so others can benefit from the solution to your problem as well. If you want to be sure someone particular gets notified of your question, put his / her username directly after an @. Also, if you have ROM related questions, post in the relevant ROM Q&A thread (if there is one) or directly in the ROM development thread. If you are not eligible of posting there, you may post here. Thank you!

    Supporters:If you want to be put on or off the list, just make a request here in the thread!

    ROM developers: Please read this. Consider if you want to have a ROM specific help thread or not, if not, most likely questions about your ROM will be asked here if the users aren't eligable for posting in development section.
    4
    Hey.

    Not new to xda. Been out of all the action for a couple of years and I'm returning with the one plus 5.

    Does anyone know if I can unlock and root without screwing up Android pay? There's this Magisk thing I've read, but some tutorial on how to load it up on the one plus 5 would be nice.
    Yes, super easy. Look in the Dev section for full install. Cliff notes:
    Unlock bootloader via fastboot (performs a full format)
    Install TWRP v58
    Install Magisk via TWRP (it's a zip)
    In Magisk there is an option that allows you to hide root from certain apps, Android pay is on by default.

    When you update the OS, do a full install (refer to official threads here on XDA for full downloads)
    Go to TWRP
    Perform a full backup
    Wipe dalvik cache
    Install new OS (full install)
    Reinstall Magisk
    Wipe dalivk cache
    Reboot the phone
    You won't lose anything with this method

    Is it possible to keep root after updating your OS? i just updated to oxygenOS 4.5.4 (flashed it through zip on OP forums) and I lost my root and TWRP recovery.

    Verstuurd vanaf mijn ONEPLUS A5000 met Tapatalk

    See above, just refash Magisk in TWRP and wipe dalvik cache.
    3
    Hey, I have a question regarding rooting and OTAs! As far as I've understood, flashing a custom recovery and root after unlocking the bootloader breaks the OTAs and makes it a hassle to update your phone unless you're running a custom ROM, which im not planning to do just yet. My question is: is there a way to unlock the bootloader and root the device WITHOUT flashing a custom recovery, which (hopefully) wouldn't break OTA updates?
    I don't have a custom ROM
    I'm on 4.5.4
    I have TWRP installed and am rooted via Magisk
    With an Ota, OOS detects root and does a full download. To install it, you boot into recovery (TWRP) wipe dalvik cache, install full Ota (about 1.5gb), reflash Magisk whole in TWRP
    Wipe dalvik cache once more and reboot. No issues here.