[Q&A] [Rom] [Kernel] [Unofficial] KitKat for Wiko DarkMoon [MT6582]

Search This thread
Q

QA Bot

Guest
Q&A for [Rom] [Kernel] [Unofficial] KitKat for Wiko DarkMoon [MT6582]

Some developers prefer that questions remain separate from their main development thread to help keep things organized. Placing your question within this thread will increase its chances of being answered by a member of the community or by the developer.

Before posting, please use the forum search and read through the discussion thread for [Rom] [Kernel] [Unofficial] KitKat for Wiko DarkMoon [MT6582]. If you can't find an answer, post it here, being sure to give as much information as possible (firmware version, steps to reproduce, logcat if available) so that you can get help.

Thanks for understanding and for helping to keep XDA neat and tidy! :)
 

jack42reg

Member
Mar 28, 2015
5
1
31
please😊

Please make separate .zip patch for the front camera) )))
You did a great job , you are a genius
 

halogenn

Senior Member
Mar 29, 2015
81
32
im getting this error mr superdragonpt. im from PH and using iceberg slim. on custom rom, rooted and 2gb repartition mod. any ideas?
 

Attachments

  • error.jpg
    error.jpg
    130.3 KB · Views: 322

xda75

Member
Aug 3, 2010
23
0
Thanks for your awesome works !!!

Thanks for your awesome work !!!!

In your previsous relase (1.0) I have some trouble :
- to wake up my phone when I was in sleeping mode (power button), I have to wait a few seconds (between 1-10 seconds).
- sometimes, when I want to launch a application or just for typing a number, my phone freeze for a moment (1 or 2 seconds)
- It's a small problem but with Dolphin Browser, I can't go in internet, I have to use another browser (like Chrome)

For information : I install the 1.0 with a clea install (factory...)
Do you have this problems ?

To install the new version, currently i'm in 1.0, I just have to follow this step ?
- Wipe Data / Factory Reset
- Wipe Dalvik Cache
- Mounts and Storage > Format /System
- Reboot to Recovery
- Flash The ROM.zip

Thanks Again !!!!
Max

EDIT : Sorry if my english is bad, i'm french
 
Last edited:

-dennis

Member
Jan 10, 2015
12
3
Titanium works

You have to read the warning in TB that says you must deselect in SuperSU under Security the NameArea mount. After you have done this, restart your device and try again :)
 

soundair_250

New member
Apr 15, 2014
0
0
marcador

boas, desde já fico agradecido pelo seu excelente trabalho no que respeita as rom lancadas por si! Instalei a rom do kitkat e notei que existe um atraso significativo no marcador de telefone, assim como este para aparecer tem de se carregar no teclado numerico, na tecla back e depois teclado numerico para aparecer o mesmo. tenho 2 darkmoon e em ambos acontece isto. Agradecido desde ja, os meus melhores cumprimentos,

Sergio silva
 

simsays69

Member
Nov 25, 2014
7
0
Problem with bootanimation on this rom

Hello and first thank you for the hard work you've done, the kitkat rom is very smooth, and works perfectly.
But i have a problem when changing bootanimation, while on stock jellybean my root explorer could change permissions,
cut, copy and paste to /root but now i can't copy my new boot anim to /system/media like before, it says : operation failed !
and i can't change permissions of any files, even if su access is fully granted ...
currently i don't have any bootanimation at all and i can't put another one...
please help ! thanks in advance
 

JRAG

New member
Apr 10, 2015
0
0
governor

Hi, I've tried this ROM and it works fine. Very smooth :)
But I can't find the Performance menu to change the governor...

Thanks
 

digitaldrag0n

Member
Feb 13, 2013
12
0
Lisbon
Battery Problems

Hello,

I seeing the same issues with battery.
It takes about 2 days and half to be depleted... but its showing always 30% to 50 % of battery before it shutdown.

Have seen that for example when i complete charge the phone and doesn't get to much use the phone shows 100% battery even after 4h of been turn on its strange at least :)

After running some apps (games for example) it jumps to 94% (this is a specific case).

Its annoying but nothing that cannot be controlled. :)
 

-dennis

Member
Jan 10, 2015
12
3
Do you habe a CWM-Backup of the working system?

Maybe you could try to recover everything from the working backup except the data? I think it's worth a try. Do a Backup of the non working system before, so if all doesn't work, you can install a fresh system and recover the data via nandroid by hand.
 

André April

New member
Apr 13, 2015
1
1
date/time problem with unofficial kitkat for wiko darkmoon version 1.1

@superdragonpt : First of all, let me thank you for the great job you've done (I've bought you a few beers).
You saved my live. I could not do any install or upgrade anymore on my Darkmoon and now, I have mnanged to install CWM and your unofficial KitKat version 1.1 (30 march 2015) and everything works like a charm... except a small littre anoyance regarding date and time.

When I choose automatic update of date and time based on operator network, the date and time first set the good value. But after one hour or two, the time (and sometime date) suddenly change arbitrary. If I choose GPS time, the time is one hour too early. Since I installed it begin april, I can't tell if it has something to do with summer time or not (i.e. if the problem would have been the same in winter time). I've tried these settings many time with the same problem. As having a wrong date/time is really frustrating, I finally chose for manual date and time.

Does anyone have the same problem?
 
  • Like
Reactions: superdragonpt

superdragonpt

Recognized Developer
Apr 27, 2013
4,923
19,278
Lisbon / Taiwan / USA
www.caixamagica.pt
@superdragonpt : First of all, let me thank you for the great job you've done (I've bought you a few beers).
You saved my live. I could not do any install or upgrade anymore on my Darkmoon and now, I have mnanged to install CWM and your unofficial KitKat version 1.1 (30 march 2015) and everything works like a charm... except a small littre anoyance regarding date and time.

When I choose automatic update of date and time based on operator network, the date and time first set the good value. But after one hour or two, the time (and sometime date) suddenly change arbitrary. If I choose GPS time, the time is one hour too early. Since I installed it begin april, I can't tell if it has something to do with summer time or not (i.e. if the problem would have been the same in winter time). I've tried these settings many time with the same problem. As having a wrong date/time is really frustrating, I finally chose for manual date and time.

Does anyone have the same problem?

Hi
First of all, thanks for the feedback.

I do have this option enabled, and no issues here (with dual SIMs: MEO/Vodafone PT).
There's yes some issues with (our... stupid) Summer Time, usually it does have some issues updating to the "new" summer time hour.
What i usually do, is turn it to manual, set the current hour, reboot, turn it on again. This never failed on me.

Also, let me just say that this also occurs in some of my other phones...

Cheers
 
  • Like
Reactions: PRADEEPHONDA

André April

New member
Apr 13, 2015
1
1
I followed your advise to reboot after setting the time. I chose automatic network time setting and then rebooted. It solved the problem :p Thank you very much :good::good::good::good::good:
 

Suikachan

New member
Apr 9, 2015
2
1
Hi @superdragonpt , first I'll thank you for your great work.
But I get a problem for install your KitKat ROM.
Even after following all instructions, I can't install the ROM. I have done it several times, to be sure, I tried with another recovery, I tried to flash your 3.4.5 kernel.
The first times, when I chose the ROM, the recovery stayed on "opening package" and then reboot. After I flashed the kernel, I succeeded to install it but I had bootloops. And now, I get an error message that says "installation aborted (bad)". I also checked if the file wasn't wrong but this is not the case.
Oh, and I have a question, is your 3.4.67 KK kernel included in the ROM ?
(I would add that I already got problems to install this ROM, I had to change the recovery to make it work)
So, I hope to have a solution, and thank you in advance. :)
(I'm so sorry for the bad english...)
 

Im_Dangerous

New member
Apr 6, 2015
0
0
Does your GPS work?

My Darkmoon is unable to catch signal from the GPS using Google Maps or Meo Drive. When I indeed can connect (rarely and only with the internet on) I immediately loose the signal again. Is the GPS working better in the stock ROM?
 

PRADEEPHONDA

Senior Member
Apr 5, 2015
84
31
Special Thanks to all the developers especially to Superdragonpt.

I'm very happy to state that your Roms are awesome, whether its Stock or to Kitkat stable for MTK6582 Wiko Darkmoon/MMX Canvas Turbo mini...!

I Recommend everyone to Flash the Rom without any second thought over it...Using it from a month & Not even one single lag or bugs...!

Can we expect more for DARKMOON Devices like Lolipop Port or something near because I know this device can handle anything...!

My heartily thanks note for all the Mods & Developers...!

---------- Post added at 09:15 PM ---------- Previous post was at 09:10 PM ----------

Hi @superdragonpt , first I'll thank you for your great work.
But I get a problem for install your KitKat ROM.
Even after following all instructions, I can't install the ROM. I have done it several times, to be sure, I tried with another recovery, I tried to flash your 3.4.5 kernel.
The first times, when I chose the ROM, the recovery stayed on "opening package" and then reboot. After I flashed the kernel, I succeeded to install it but I had bootloops. And now, I get an error message that says "installation aborted (bad)". I also checked if the file wasn't wrong but this is not the case.
Oh, and I have a question, is your 3.4.67 KK kernel included in the ROM ?
(I would add that I already got problems to install this ROM, I had to change the recovery to make it work)
So, I hope to have a solution, and thank you in advance. :)
(I'm so sorry for the bad english...)

Dude you got to Flash Wiko Stock rom form Superdragonpt first & let it boot, then get back to recovery to Install Kitkat through CWM Recovery.
Kernel is included in the KitKat Rom.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    date/time problem with unofficial kitkat for wiko darkmoon version 1.1

    @superdragonpt : First of all, let me thank you for the great job you've done (I've bought you a few beers).
    You saved my live. I could not do any install or upgrade anymore on my Darkmoon and now, I have mnanged to install CWM and your unofficial KitKat version 1.1 (30 march 2015) and everything works like a charm... except a small littre anoyance regarding date and time.

    When I choose automatic update of date and time based on operator network, the date and time first set the good value. But after one hour or two, the time (and sometime date) suddenly change arbitrary. If I choose GPS time, the time is one hour too early. Since I installed it begin april, I can't tell if it has something to do with summer time or not (i.e. if the problem would have been the same in winter time). I've tried these settings many time with the same problem. As having a wrong date/time is really frustrating, I finally chose for manual date and time.

    Does anyone have the same problem?
    1
    @superdragonpt : First of all, let me thank you for the great job you've done (I've bought you a few beers).
    You saved my live. I could not do any install or upgrade anymore on my Darkmoon and now, I have mnanged to install CWM and your unofficial KitKat version 1.1 (30 march 2015) and everything works like a charm... except a small littre anoyance regarding date and time.

    When I choose automatic update of date and time based on operator network, the date and time first set the good value. But after one hour or two, the time (and sometime date) suddenly change arbitrary. If I choose GPS time, the time is one hour too early. Since I installed it begin april, I can't tell if it has something to do with summer time or not (i.e. if the problem would have been the same in winter time). I've tried these settings many time with the same problem. As having a wrong date/time is really frustrating, I finally chose for manual date and time.

    Does anyone have the same problem?

    Hi
    First of all, thanks for the feedback.

    I do have this option enabled, and no issues here (with dual SIMs: MEO/Vodafone PT).
    There's yes some issues with (our... stupid) Summer Time, usually it does have some issues updating to the "new" summer time hour.
    What i usually do, is turn it to manual, set the current hour, reboot, turn it on again. This never failed on me.

    Also, let me just say that this also occurs in some of my other phones...

    Cheers
    1
    Dude you got to Flash Wiko Stock rom form Superdragonpt first & let it boot, then get back to recovery to Install Kitkat through CWM Recovery.
    Kernel is included in the KitKat Rom.
    This is what I did. But I finally got it by not wiping /data /cache /system and dalvik cache
    Thank you anyway ! :)