[Q&A/T] CloudyG2 3.3 -=- [All Variants]

Search This thread

alessa

Senior Member
Jul 5, 2008
1,233
119
autorec installs the older twrp version (don't know which one exactly, but older than 2.8.7.3)

you can use autorec if you don't have twrp but update to newer one by simple flashing newer twrp zip through twrp itself (just make sure you download correct twrp for your variant)

thanks

but I searched on xda and I can not find the correct version ... help?
 

60nine

Senior Member
May 24, 2012
3,458
2,887
Zagreb
www.soundcloud.com
thanks

but I searched on xda and I can not find the correct version ... help?

oh come on dude - how hard is it to find blastagator's thread and the link to his download server in the 1st post of that thread?!

http://www.gregtwallace.com/lgg2-projects/twrp/ (for the index page)

http://www.gregtwallace.com/lgg2-projects/twrp/?version=2.8.7.3 (for 2.8.7.3 version downloads)

http://forum.xda-developers.com/lg-g2/development/twrp-twrp-2-8-0-0-kernel-f2fs-tools-t2898705 (for blastagator's twrp thread)
 
  • Like
Reactions: alessa

alessa

Senior Member
Jul 5, 2008
1,233
119
oh come on dude - how hard is it to find blastagator's thread and the link to his download server in the 1st post of that thread?!

http://www.gregtwallace.com/lgg2-projects/twrp/ (for the index page)

http://www.gregtwallace.com/lgg2-projects/twrp/?version=2.8.7.3 (for 2.8.7.3 version downloads)

http://forum.xda-developers.com/lg-g2/development/twrp-twrp-2-8-0-0-kernel-f2fs-tools-t2898705 (for blastagator's twrp thread)

thank you very much.
I find the link, but I was not on it either this well and I did not want to do something stupid ... but thank you.
 

ashhad101

Senior Member
Aug 9, 2014
95
22
Can anybody please give me kk bootloader for ls980 sprint version, i have looked alot but iam unable to find it if anybody knows anything then please tell me, previously i tried to install this rom but my phone got bricked luckily i unbricked it currently iam on cloudy 2.2.
 
  • Like
Reactions: lgamateur

emreagacli

Senior Member
Jan 31, 2014
120
21
hello i want to ask that is it possible to enable lte 900 1800 and 2600 bands on vs980. please help me i can not use lte in TURKEY. my operator is vodafone and using this lte bands.
 

Envy-X

Senior Member
Feb 15, 2013
1,731
818
23
On CloudyG2 (KK) there was that one animated lockscreen. Is there a way to get that lockscreen onto CloudyG3 3.3? (LP)
 

doctor_evil

Senior Member
Dec 6, 2010
89
15
Gainesville GA
I installed the 3.3 version of the rom and it seems to be working well on my LS-980 except for two issues, one I have fixed, the other one is an annoyance and can be worked around.

The only quirk I had was that my phone is setup for freedompop instead of sprint and I couldn't get the data working. I had to use the zip file from here to flash a APN config file that had the freedompop APN settings. I now have a mobile data connection, and the speed seems to be the same as it was prior to me flashing the cloudyg2 3.3 rom

The only remaining issue I see is that now my data is working but it isn't showing the normal icon to indicate how fast the connection is, all It shows is the signal strength bars.

Is there a way to fix this issue?
 

jskateborders

New member
Apr 8, 2016
2
0
text messages

I just installed this ROM onto a vs980 and I am unable to send text messages. When I attempted to use the stock messenger, I received a "stopped working" error. I then tried google messenger in which no option to enter a message is given and go sms where sending a text reverts back to an empty text field with no message history.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 171
    Questions & Answers/Troubleshooting
    [SIZE=+2]Specific to[/SIZE]

    l4Lf3p6.png


    Click link here>> to go to ROM thread <<Click link here

    Please feel free to share issues, questions and offer help

    It is always best to thank a ROM OP, in lieu of simply posting "Thank you".

    redLine.png

    Please keep discussion focused, on the topic described in the OP
    redLine.png
    31
    MIRROR


    CLoudy-resize_zpsnbwuelbt.jpg


    CloudyG2 3.3



    [*]COPY - Uploading

    MD5: B40C0EF12D9B5A66C04047A9EF51BE02


    Credits and Thanks To: @Cloudyfa
    30
    I dont think so, Dori.

    chargerlogo is a binary always been there in the ramdisk by default. The rom use stock kernel so it remained untouched. And there's nothing about it in the system , maybe you mistaken a bit when seeing it in root folder (bc of ramdisk).
    Btw, I think that chargerlogo affect nothing if people using the default kernel or your custom kernel (if it cause issue, your custom kernel may already removed it, and again, if it cause the issue, all stock kernels have rebooting issue)

    Yep, i see that i should deal with this.
    This is a stock binary stuck in ramdisk in stock and my kernel.

    I will see how i can help, strange that i never seen its working on my device.
    But other roms custom.. reporting errors from it, and kernel reboot.
    Stock 30b is quiet...

    Sorry for disturbing you :)
    Its seems to be my problem now, haha.
    Where is my hammer.???


    Sent from my LG-D802
    21
    I'm using RR 5.4.8 (lollipop 5.1.1).
    Can anyone tell me what I must flash to work on D802?
    In rom thread says that i must only do Full Wipe & Flash rom, but i I read, that some users have to flash another's zip to work rom properly.
    Btw What is bootstack? I search on google and xda, but i don't find the answer.

    Thank you for using the Q&A, as for the several posters above I'm glad they were moved here instead of the development section.

    Basically, the process is very simple. AOSP based roms are kept very simple and they mostly just flash /system files as well as a boot.bin (kernel). There are plenty of other files in your phone, like the recovery, bootloader, modem and others. These are NEVER touched by AOSP roms (unless specified).

    Sometimes, especially with locked bootloaders and restricted device sources, closed-source updates that come from the manufacturer (in this case, LG), update these very crucial folders/files to make them work with new firmware/software updates. This was the case when LG updated the G2 from Kitkat to Lollipop.

    When the official update came into place, they updated the rom (/system), updated the user apps (/data), updated the stock recovery, updated the bootloader to LP and updated a lot of other files/folders including the modem, laf, etc.

    All of these are essential to make a ROM work properly and not updating these causes issues (random reboots, no sound, no knock on, no GPS, etc). As there are many variants for this device, it's very difficult to keep track of what keeps breaking what.

    For this, devs have released a bootstack (a collection of files and folders which you can see here) for each variant that had an official Lollipop release. It updates the bootloader, modem and all the other partitions.

    The bootloader used however, is the KITKAT version, as the lollipop version has no exploit available to have a custom recovery on. Modem is usually LP, although some users report to use KitKat.

    So...what's next?

    If you're on stock lollipop, you NEED a KITKAT bootloader. Use autorec v2 from the playstore and then -> flash LP bootstack. This should get you the necessary bootloader and overwrite the already present LP files/modem
    If you're on stock kitkat, you already HAVE a KITKAT bootloader. If you're missing root, use autorec v1 found in the development section and you're missing what could possibly fix the issues mentioned above, stored in the LP files/modem -> flash LP bootstack.
    If you're on stock jellybean, you don't have EITHER a KITKAT bootloader or the LP modem/files -> flash LP bootstack

    Now here comes the interesting part

    If you're on AOSP without CAF sources, you're using a JELLYBEAN bootloader and have no LP modem/files. You need a KITKAT bootloader to flash CAF roms -> flash LP bootstack
    If you're on AOSP with CAF sources, you're using a KITKAT bootloader and you might or might not have LP modem/files. Might as well -> flash LP bootstack

    If you're still unsure, just read the official instructions (these do the same as the bootstack does, as updating to official lollipop will get you all the lollipop files, and flashing autorec v2 will downgrade the only thing you need, the bootloader, to the KITKAT version)

    Can I upgrade to this ROM from other LP ROM?
    - I dont know if your current ROM use the official partitions from LG LP releases or the modified one, this ROM requires org parts from LG. If you're not sure about that just kdz/tot back to Lollipop firmware, root, install AutoRec V2 (that support Lollipop) to get the recovery and flash the ROM like Installation guide above.

    Also, just in case, I realize cloudy's isn't an AOSP rom, but being a custom stock-based rom on the g2 with a locked bootloader, you can pretty much treat it like one. It does, however, offer the option to update the modem.

    When did this become a mess? During the introduction of CAF (qualcomm optimized branch for devices) sources for the G2. The ONLY issue with the LP-bootstack is when you try to flash older roms, that use a loki exploit found in the JELLYBEAN bootloader and patched on the KITKAT bootloader. This might require another bootstack, or not. No one really bothered to check compatibility with older versions and for good reason.
    18
    I was having serious battery drain issue on my D800 and thank you Google for that :)

    Big thanks to @Alcolawl as he found a way to destroy the battery drain issue caused by Google Update Service.

    I packaged the script and please flash it from Recovery and enjoy few more hours of battery!

    Btw, it can be flashed for both CloudyG2 3.1 and 3.2.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone