[Q&A] WiFi stuck on turning on; MAC 02:00:00:00:00:00; G2 G3 G4 G5 Nexus5 Nexus 7 etc

Search This thread

NimbleWeasel

Member
Aug 31, 2016
31
24
[Q&A] WiFi stuck on turning on; MAC 02:00:00:00:00:00; G2 G3 G4 G5 Nexus5 Nexus 7 etc

Hi!
If you are reading this now, you are probably one of the unlucky fellows who's WiFi (and Bluetooth) stopped functioning, and if so, you are probably deperately searching for a solution/fix. I might have something for you, but first:

*** DISCLAIMER/WARNING ***
You yourself are exclusively responsible for whatever may (or may not) happen to your mobile device, to yourself or others. I am only giving hints/advices here that *MAY* help, but I will not take any responsability, nor will I provide any support, in absolutely *ANY CASE*, including, but not limited to: your problem not being solved or/and your mobile device becoming partially or completely broken. Let me be very clear: If you do anything to your device rendering it useless, destroying it, seriously or fataly injuring you or others, and then come blaming me or/and cry for help, I will point my index finger at you and laugh at you. Period.

If you are a impatient person and want to get straight to the point, jump right to section 6.

Table of Contents
0. Foreword
1. Description of the problem
2. Urgent advice
3. Things that didn't work
4. There is little hope
5. My most obvious advice
6. LET'S GET SERIOUS!
6.a Sellotape / Scotch tape
6.b Refrigerator / Freezer
6.c Oven

0. Foreword
Two or three months ago, one fine morning, the WiFi/BT of my LG G2 suddenly stopped working. Initially I thought this would be only one stupid annoying minor thingy, that I’d be able to solve it fast. I was wrong.

1. Description of the problem
When turning on the WiFi, it would just stay in "Turning on..." forever. Similar thing for Bluetooth: It would stay on for a few seconds and then turn itself off again after. (But then, who needs Bluetooth anyway, WiFi ist probably 100 times more important...). I have thoroughly searched the internet, and I found quite some videos with exactly the same problem (remove the two blanks from the links to watch):
h ttps://w ww.youtube.com/watch?v=fRGnQz1zUmw
h ttps://w ww.youtube.com/watch?v=4W8YJMDFM88
h ttp://w ww.dailymotion.com/video/x2cuyjt_nexus-5-turning-wifi-on-frozen-problem_tech

2. Urgent advice
I want to prevent you from wasting countless hours searching for a solution - I wasted so much of my time already, no need for you to repeat that. Therefore: *Please* be aware that there is a VERY HIGH PROBABILITY that this issue is being caused by a hardware defect. I can not speak for all devices of course, but keep in mind that the main reason I wasted so much time, was me beliving it was some software issue! See the next section for a glimpse of stuff I have tried without any success:

3. Things that *DIDN'T* work
01. Restarting WiFi/Bluetooth several times
02. Rebooting the phone
03. Turning airplane mode on/off several times
04. Slapping/hitting the phone (this was indeed suggested in a forum)
05. Using WiFi-Fixer apps
06. Resetting to factory settings
07. Upgrading to newest Android version
08. Fully drained the battery and left it uncharged for several hours
(Rooted the phone)
09. Deleting the /data/misc/wifi/wpa_supplicant.conf
10. Deleting the whole /data/misc/wifi folder
11. Creating a file named ".bdaddr" in /persist/bluetooth containing a MAC-Address in hexadecimal format
12. Creating a file named ".macaddr" in /persist/wifi containing a MAC-Address in hexadecimal format
13. Flashing several custom ROMs to it (CyanogenMod, ParanoidAndroid, ...)
14. Going back to stock ROM
15. etc. etc. etc.
16. Several combinations and permutations of the above

4. There is little hope
Again, as the cause of the problem is most likely a hardware issue, I don't recommend going through all the steps as described in the previous section; however, though none of the steps worked for me, this doesn't mean that none won't work for you neither; you might be luckier than I was. In that case, enjoy your restored WiFi and be happy. :)

5. My most obvious advice
You need to replace the motherboard (main board) of your device.
Honestly, if you can afford it and it doesn't cause too many inconveniences to you, you'll be better off by simply buying a new device. If you don't want to buy a new device, send it in for repairs. If you don't want to do that as well, you'll have to fallback to a DIY solution:
I. Buy a new main board for your device. Be careful to get exactly the right component for your specific model. If you dont find any shop selling those, there are plenty of individuals out there that own devices with broken displays. You dont need the displays, you need the motherboard. Buy one such broken device, and you'll have your main board replacement.
II. Replace your main board or let someone else do it for you

Continues below.
 

NimbleWeasel

Member
Aug 31, 2016
31
24
continuation

6. LET'S GET SERIOUS!
If you are reading this, you either didn't read or you decided not to follow my most obvious advice in section 5. So be it. If you want to carry on from here, be sure to re-read my disclaimer at the top of my post.
There are 3 DIY possible fixes for the WiFi problem - none is guaranteed. I will describe them from the most harmless to the most kamikaze/deadliest. All of them will require you to open your device; if you are not careful and damage any of the components inside, you will end up with a worse device than before - but hey, don't say I didn't warn you.

At this point we assume that the cause of the problem is a faulty solder joint of your WiFi IC. The goal is to try to restore that solder joint. To do that, you will have to:
I. Open your device
II. Find your main board and separate it from all connected plugs
III. Find / identify the WiFi IC chip on the main board. I recommend searching for a service manual for your device, or/and searching for a disassembly video for your device; you need to know which one of the chips on the main board is the WiFi one.

Once you have identified your WiFi chip, you have 3 options, which you may combine with each other, but I recommend to try them out one-by-one as follows:
6.a Sellotape / Scotch tape
You need to make sure that your WiFi chip is pressed against the main board (ideally, this ensures the broken contacts touch each other, solving the problem). The best way to achieve this, is to attach a series of tape strips on the top of the WiFi chip, causing it to be pressed against the main board by the surrounding cover/hull once you reassemble/close the device. The tape strips are just a suggestion, do whatever you find convenient as long as you ensure that the chip is pushed against the board at all times.
This method may solve the WiFi problem already. When you turn your device back on, give it some time (5-10 minutes) and reboot it a few times if the problem still persists. My own WiFi didn't function right away, but after a while it finally recovered - hurray!
6.b Refrigerator / Freezer
Instead of using the tape as described in 6.a, you may first try to put your motherboard in a fridge for a few hours/days. But make sure to put it there in a plastic bag, and avoid moisture as much as you can, specially when taking it out of the fridge. Make sure its completely dry before reassembling your device!
By the way, try the refrigerator option BEFORE you try the freezer option!
6.c Oven
If everything else fails, the oven might be your last chance. This is not a joke, but as you probably can assume, it is "All-In" i.e. highly risky. The theory behind this is that high temperature will cause defective solder joints to reflow, reconnecting and thus fixing the problem.
You should only try this as a matter of last ressort. Be warned that you may fully destroy your main board, and there is a high chance that you will. Also, you may cause serious injury to yourself or others. Make sure you make backups of your data first. DO NOT BAKE THE WHOLE DEVICE, ONLY THE MAIN BOARD. DO NOT BAKE THE BATTERY!!
If you are still reading:
I. pre-heat your oven to 385° Fahrenheit (196° Celsius)
II. put your main board in the oven, bake it there for 7 minutes
III. remove from the oven, let it cool down until every component of the board has room temperature
Finally, here is a video of a guy doing a similar thing, but with a heat gun:
h ttps://w ww.youtube.com/watch?v=A4n0j3uaS7E

Ok, this is all, I hope I could help you.

Good luck!
 

NimbleWeasel

Member
Aug 31, 2016
31
24
Summary

Hello all,

first of all, I want to thank brysclar and xbing6 for their valuable feedback! Thanks a lot guys! :good:

Now, in an effort to update this thread and in an effort of trying to summarize it in fewer words (my disclaimer above applies!):
- The described problem seems to affect mainly (all kinds of) LG devices
- The issue seems to be caused by a defective soldering of the Wi-Fi chip on the main board
- The defect seems to be induced by dropping or/and overheating the device; recharging the battery, big/long app or android updates or the flashing of custom roms could cause excessive heating
- brysclar pointed out that replacing the battery might solve the problem (I haven't tried this out myself, so I can neither deny nor confirm this)
- My recommended solution is 6.a - applying pressure on the Wi-Fi chip, pushing it against the main board, using tape stripes
- There is a video of a brasilean guy doing some similar, but using pieces of an old credit card instead of tape strips: https://www.youtube.com/watch?v=OJkdva2iOag BUT PLEASE NOTE THAT HE IS APPLYING THE PRESSURE ON A RANDOM SPOT, NOT DIRECTLY TO THE WIFI CHIP! It *may* work for you, but if it doesn't, find/identify your Wi-Fi chip and apply the pressure there
- If everything else fails, and only as a matter of last ressort, you may try what I have written in 6.c

So... this thread has over 500 views, but not one single reply. :rolleyes:

Guys... what has your experience been? Have you tried anything out from the posts above, and if so, what was the result? Did it help you? Do you recommend anything? Has something else, not written here, worked for you?

There are a lot of people out there having the same problem. It would be great if you could give any feedback, share anything that helps the community.
 
Last edited:

brysclar

Member
Aug 26, 2016
5
2
I honestly didn't see this post before. You really covered every detail very well. So far, returning my G3 to stock and replacing the battery has fixed it for me. Weird. I know. I did try 90% of the things on your "things that don't work" list and you are correct. They don't work.
 
  • Like
Reactions: NimbleWeasel

xbing6

Member
Apr 9, 2013
10
3
Simply awesome.

I have similar issue with my Nexus 5x. It is QCA6174 hw 3.2 chip, lspci does not detect this chip any more. I am going to do a little bit investigation from device driver (cnss) perspective. It enables one GPIO to provide power to this WiFi chip, I will try read back this GPIO status to see if it is enabled. I do not have the schematics, I do not know how to check if power is supplied to this wifi chip.

lspci used to show below:
$ ./lspci
00:00.0 PCI bridge: Airgo Networks Inc Device 0300 (rev ff)
01:00.0 Network controller: Atheros Communications Inc. Device 003e (rev ff) (this is qca6174)

If kernel driver investigation does not reveal anything helpful, I will ask other guys to replace the chip.

I thought it is because of vendor partition is accidentally wiped out, maybe it is unlikely.

---------- Post added at 08:49 PM ---------- Previous post was at 08:40 PM ----------

As Bluetooth can not be turned either, I am tending to think this is hardware related as well. As described previously, I will see if I can check that gpio status.
 
  • Like
Reactions: NimbleWeasel

NimbleWeasel

Member
Aug 31, 2016
31
24
investigating

I have similar issue with my Nexus 5x.
(...)
I am going to do a little bit investigation

Hi xbing, and thank you for your feedback! :good:

I am really curious and looking forward to hear the results of your investigation! I believe that in your case, too, the Wi-Fi/BT chip is not being supplied correctly due to a defective soldering. Note that I don't think that the chip itself is defective, only the contacts between the chip and the main board. So, before replacing the chip, I'd recommend to first try what I've written in 6.a (or check my update/summary above).

Keep us posted about everything you find out! :)
 

Tomcat5

Senior Member
Aug 17, 2011
546
133
Lower Slower Delaware
Sprint declined to fix my LS990 due to "water damage" being the reason for it not working, and wanted to charge me a $150 deductible for a $100 phone. Shimming the WiFi chip against the metal covering with some thermal pad I had lying around and adding a bit of sticky foam on top of the ribbon cable for the camera worked great! Much thanks!
 
  • Like
Reactions: NimbleWeasel

NavHur

New member
Sep 17, 2016
2
0
Sprint declined to fix my LS990 due to "water damage" being the reason for it not working, and wanted to charge me a $150 deductible for a $100 phone. Shimming the WiFi chip against the metal covering with some thermal pad I had lying around and adding a bit of sticky foam on top of the ribbon cable for the camera worked great! Much thanks!

Any idea if thermal paste/grease could work?
 

NimbleWeasel

Member
Aug 31, 2016
31
24
unlikely

Any idea if thermal paste/grease could work?

Hi NavHur,

since the problem is mostly caused by a loose Wi-Fi chip, respectively a defective solder joint, using thermal paste or grease is unlikely to help; again, what you need to do is to have your Wi-Fi chip pushed against your main board. You can use your imagination on how to accomplish this; what Tomcat5 described he did ultimately led to exactly having his chip being pressed against the board.
Of course you are free to try whatever you want - if you find new solutions please post some feedback. :)

Good luck.
 

NavHur

New member
Sep 17, 2016
2
0
Hi NavHur,

since the problem is mostly caused by a loose Wi-Fi chip, respectively a defective solder joint, using thermal paste or grease is unlikely to help; again, what you need to do is to have your Wi-Fi chip pushed against your main board. You can use your imagination on how to accomplish this; what Tomcat5 described he did ultimately led to exactly having his chip being pressed against the board.
Of course you are free to try whatever you want - if you find new solutions please post some feedback. :)

Good luck.

Thanks you so much, I placed a small piece of plastic above the wifi chip and one next to the camera lens. Now the wifi works fine. However my screen was pushed up so it bended a little. The faulty thing was my battery, not the added plastic. I compared mine with the one of a friend, mine was 1 mm bigger. (also with the battery of my friend's g3 the screen was fine)
I'll be changing it soon.
 

Pratap94

New member
Sep 19, 2016
1
0
same problem as u but sometimes wifi works(mainly fully charged) and sometimes dont

i have lg g2 D802 model. It had a wifi problem as u shown in your videos,my phone also behaves same like yours but sometimes it works normally like while charging,works like 2 or 3 times a day(for 5-10 min).please tell me whether my phone got ic problem or software issue
 

NimbleWeasel

Member
Aug 31, 2016
31
24
i have lg g2 D802 model. It had a wifi problem as u shown in your videos,my phone also behaves same like yours but sometimes it works normally like while charging,works like 2 or 3 times a day(for 5-10 min).please tell me whether my phone got ic problem or software issue

Hi Pratap94,

nobody, neither here in this forum nor elsewhere in the internet, will be able to give you a reliable answer without having a *physical* look at your phone. Nobody.
However, I can give you my opinion, based on the stuff you wrote: The fact that it works normally sometimes, specially while charging (probably it heats up in the process?), indeed seems to indicate a hardware issue. I believe you have a loose Wi-Fi chip i.e. a defective solder joint, like I had on my LG G2 D802 as well. I solved my problem by doing the stuff I described in 6.a.

Good luck.
 

NimbleWeasel

Member
Aug 31, 2016
31
24
Sadly step 6.a did not help me. Well, it worked for first 5-10 minutes and then back again.

Hi Olzhas18,
that might be an indication that your WiFi chip is still a bit loose and is not sitting tight enough on the main board. On LG G2, it is difficult to push the chip against the board because it's covered by a metal cover...
Also, did you check out this video: https://www.youtube.com/watch?v=OJkdva2iOag ?
Good luck!
 
  • Like
Reactions: Olzhas18

Olzhas18

New member
Dec 11, 2015
4
1
Hi Olzhas18,
that might be an indication that your WiFi chip is still a bit loose and is not sitting tight enough on the main board. On LG G2, it is difficult to push the chip against the board because it's covered by a metal cover...
Also, did you check out this video: https://www.youtube.com/watch?v=OJkdva2iOag ?
Good luck!

Thank you this tip and this whole thread. I have seen this video, but still the same effect. 5-10 minutes, I can rean some news and back to flashing. I'm going to buy Huawei Honor 8 soon, it was the last chance to recover my G4. I doubt I will purchase any other phone from LG.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    [Q&A] WiFi stuck on turning on; MAC 02:00:00:00:00:00; G2 G3 G4 G5 Nexus5 Nexus 7 etc

    Hi!
    If you are reading this now, you are probably one of the unlucky fellows who's WiFi (and Bluetooth) stopped functioning, and if so, you are probably deperately searching for a solution/fix. I might have something for you, but first:

    *** DISCLAIMER/WARNING ***
    You yourself are exclusively responsible for whatever may (or may not) happen to your mobile device, to yourself or others. I am only giving hints/advices here that *MAY* help, but I will not take any responsability, nor will I provide any support, in absolutely *ANY CASE*, including, but not limited to: your problem not being solved or/and your mobile device becoming partially or completely broken. Let me be very clear: If you do anything to your device rendering it useless, destroying it, seriously or fataly injuring you or others, and then come blaming me or/and cry for help, I will point my index finger at you and laugh at you. Period.

    If you are a impatient person and want to get straight to the point, jump right to section 6.

    Table of Contents
    0. Foreword
    1. Description of the problem
    2. Urgent advice
    3. Things that didn't work
    4. There is little hope
    5. My most obvious advice
    6. LET'S GET SERIOUS!
    6.a Sellotape / Scotch tape
    6.b Refrigerator / Freezer
    6.c Oven

    0. Foreword
    Two or three months ago, one fine morning, the WiFi/BT of my LG G2 suddenly stopped working. Initially I thought this would be only one stupid annoying minor thingy, that I’d be able to solve it fast. I was wrong.

    1. Description of the problem
    When turning on the WiFi, it would just stay in "Turning on..." forever. Similar thing for Bluetooth: It would stay on for a few seconds and then turn itself off again after. (But then, who needs Bluetooth anyway, WiFi ist probably 100 times more important...). I have thoroughly searched the internet, and I found quite some videos with exactly the same problem (remove the two blanks from the links to watch):
    h ttps://w ww.youtube.com/watch?v=fRGnQz1zUmw
    h ttps://w ww.youtube.com/watch?v=4W8YJMDFM88
    h ttp://w ww.dailymotion.com/video/x2cuyjt_nexus-5-turning-wifi-on-frozen-problem_tech

    2. Urgent advice
    I want to prevent you from wasting countless hours searching for a solution - I wasted so much of my time already, no need for you to repeat that. Therefore: *Please* be aware that there is a VERY HIGH PROBABILITY that this issue is being caused by a hardware defect. I can not speak for all devices of course, but keep in mind that the main reason I wasted so much time, was me beliving it was some software issue! See the next section for a glimpse of stuff I have tried without any success:

    3. Things that *DIDN'T* work
    01. Restarting WiFi/Bluetooth several times
    02. Rebooting the phone
    03. Turning airplane mode on/off several times
    04. Slapping/hitting the phone (this was indeed suggested in a forum)
    05. Using WiFi-Fixer apps
    06. Resetting to factory settings
    07. Upgrading to newest Android version
    08. Fully drained the battery and left it uncharged for several hours
    (Rooted the phone)
    09. Deleting the /data/misc/wifi/wpa_supplicant.conf
    10. Deleting the whole /data/misc/wifi folder
    11. Creating a file named ".bdaddr" in /persist/bluetooth containing a MAC-Address in hexadecimal format
    12. Creating a file named ".macaddr" in /persist/wifi containing a MAC-Address in hexadecimal format
    13. Flashing several custom ROMs to it (CyanogenMod, ParanoidAndroid, ...)
    14. Going back to stock ROM
    15. etc. etc. etc.
    16. Several combinations and permutations of the above

    4. There is little hope
    Again, as the cause of the problem is most likely a hardware issue, I don't recommend going through all the steps as described in the previous section; however, though none of the steps worked for me, this doesn't mean that none won't work for you neither; you might be luckier than I was. In that case, enjoy your restored WiFi and be happy. :)

    5. My most obvious advice
    You need to replace the motherboard (main board) of your device.
    Honestly, if you can afford it and it doesn't cause too many inconveniences to you, you'll be better off by simply buying a new device. If you don't want to buy a new device, send it in for repairs. If you don't want to do that as well, you'll have to fallback to a DIY solution:
    I. Buy a new main board for your device. Be careful to get exactly the right component for your specific model. If you dont find any shop selling those, there are plenty of individuals out there that own devices with broken displays. You dont need the displays, you need the motherboard. Buy one such broken device, and you'll have your main board replacement.
    II. Replace your main board or let someone else do it for you

    Continues below.
    9
    continuation

    6. LET'S GET SERIOUS!
    If you are reading this, you either didn't read or you decided not to follow my most obvious advice in section 5. So be it. If you want to carry on from here, be sure to re-read my disclaimer at the top of my post.
    There are 3 DIY possible fixes for the WiFi problem - none is guaranteed. I will describe them from the most harmless to the most kamikaze/deadliest. All of them will require you to open your device; if you are not careful and damage any of the components inside, you will end up with a worse device than before - but hey, don't say I didn't warn you.

    At this point we assume that the cause of the problem is a faulty solder joint of your WiFi IC. The goal is to try to restore that solder joint. To do that, you will have to:
    I. Open your device
    II. Find your main board and separate it from all connected plugs
    III. Find / identify the WiFi IC chip on the main board. I recommend searching for a service manual for your device, or/and searching for a disassembly video for your device; you need to know which one of the chips on the main board is the WiFi one.

    Once you have identified your WiFi chip, you have 3 options, which you may combine with each other, but I recommend to try them out one-by-one as follows:
    6.a Sellotape / Scotch tape
    You need to make sure that your WiFi chip is pressed against the main board (ideally, this ensures the broken contacts touch each other, solving the problem). The best way to achieve this, is to attach a series of tape strips on the top of the WiFi chip, causing it to be pressed against the main board by the surrounding cover/hull once you reassemble/close the device. The tape strips are just a suggestion, do whatever you find convenient as long as you ensure that the chip is pushed against the board at all times.
    This method may solve the WiFi problem already. When you turn your device back on, give it some time (5-10 minutes) and reboot it a few times if the problem still persists. My own WiFi didn't function right away, but after a while it finally recovered - hurray!
    6.b Refrigerator / Freezer
    Instead of using the tape as described in 6.a, you may first try to put your motherboard in a fridge for a few hours/days. But make sure to put it there in a plastic bag, and avoid moisture as much as you can, specially when taking it out of the fridge. Make sure its completely dry before reassembling your device!
    By the way, try the refrigerator option BEFORE you try the freezer option!
    6.c Oven
    If everything else fails, the oven might be your last chance. This is not a joke, but as you probably can assume, it is "All-In" i.e. highly risky. The theory behind this is that high temperature will cause defective solder joints to reflow, reconnecting and thus fixing the problem.
    You should only try this as a matter of last ressort. Be warned that you may fully destroy your main board, and there is a high chance that you will. Also, you may cause serious injury to yourself or others. Make sure you make backups of your data first. DO NOT BAKE THE WHOLE DEVICE, ONLY THE MAIN BOARD. DO NOT BAKE THE BATTERY!!
    If you are still reading:
    I. pre-heat your oven to 385° Fahrenheit (196° Celsius)
    II. put your main board in the oven, bake it there for 7 minutes
    III. remove from the oven, let it cool down until every component of the board has room temperature
    Finally, here is a video of a guy doing a similar thing, but with a heat gun:
    h ttps://w ww.youtube.com/watch?v=A4n0j3uaS7E

    Ok, this is all, I hope I could help you.

    Good luck!
    3
    Summary

    Hello all,

    first of all, I want to thank brysclar and xbing6 for their valuable feedback! Thanks a lot guys! :good:

    Now, in an effort to update this thread and in an effort of trying to summarize it in fewer words (my disclaimer above applies!):
    - The described problem seems to affect mainly (all kinds of) LG devices
    - The issue seems to be caused by a defective soldering of the Wi-Fi chip on the main board
    - The defect seems to be induced by dropping or/and overheating the device; recharging the battery, big/long app or android updates or the flashing of custom roms could cause excessive heating
    - brysclar pointed out that replacing the battery might solve the problem (I haven't tried this out myself, so I can neither deny nor confirm this)
    - My recommended solution is 6.a - applying pressure on the Wi-Fi chip, pushing it against the main board, using tape stripes
    - There is a video of a brasilean guy doing some similar, but using pieces of an old credit card instead of tape strips: https://www.youtube.com/watch?v=OJkdva2iOag BUT PLEASE NOTE THAT HE IS APPLYING THE PRESSURE ON A RANDOM SPOT, NOT DIRECTLY TO THE WIFI CHIP! It *may* work for you, but if it doesn't, find/identify your Wi-Fi chip and apply the pressure there
    - If everything else fails, and only as a matter of last ressort, you may try what I have written in 6.c

    So... this thread has over 500 views, but not one single reply. :rolleyes:

    Guys... what has your experience been? Have you tried anything out from the posts above, and if so, what was the result? Did it help you? Do you recommend anything? Has something else, not written here, worked for you?

    There are a lot of people out there having the same problem. It would be great if you could give any feedback, share anything that helps the community.
    1
    I honestly didn't see this post before. You really covered every detail very well. So far, returning my G3 to stock and replacing the battery has fixed it for me. Weird. I know. I did try 90% of the things on your "things that don't work" list and you are correct. They don't work.
    1
    Simply awesome.

    I have similar issue with my Nexus 5x. It is QCA6174 hw 3.2 chip, lspci does not detect this chip any more. I am going to do a little bit investigation from device driver (cnss) perspective. It enables one GPIO to provide power to this WiFi chip, I will try read back this GPIO status to see if it is enabled. I do not have the schematics, I do not know how to check if power is supplied to this wifi chip.

    lspci used to show below:
    $ ./lspci
    00:00.0 PCI bridge: Airgo Networks Inc Device 0300 (rev ff)
    01:00.0 Network controller: Atheros Communications Inc. Device 003e (rev ff) (this is qca6174)

    If kernel driver investigation does not reveal anything helpful, I will ask other guys to replace the chip.

    I thought it is because of vendor partition is accidentally wiped out, maybe it is unlikely.

    ---------- Post added at 08:49 PM ---------- Previous post was at 08:40 PM ----------

    As Bluetooth can not be turned either, I am tending to think this is hardware related as well. As described previously, I will see if I can check that gpio status.