[Q]Airplane mode keeps turning itself on and won't turn off

Search This thread

coleburns

Senior Member
Dec 22, 2010
380
32
London
First of all, a battery pull fixes the issue

What i am trying to figure out if what causes the bug and whether other people are having the same issue

As you can see from both images, there is no cell signal but WIFI is on but somehow the phone thinks airplane mode has been turned on

This is the 3rd time is past few days and i have missed loads of calls as a result.
From what i can see from my apps, there is nothing that should be causing the issue.

Also, there doesn't seem to a root cause, It has happened while i was charging the phone and while the phone had been on constant use

Any ideas?
 

Attachments

  • Screenshot_2011-12-12-05-16-09.jpg
    Screenshot_2011-12-12-05-16-09.jpg
    23.3 KB · Views: 832
  • Screenshot_2011-12-12-04-56-02.jpg
    Screenshot_2011-12-12-04-56-02.jpg
    12.9 KB · Views: 715

joeykrim

Inactive Recognized Developer
Jan 9, 2009
1,979
1,310
First of all, a battery pull fixes the issue

What i am trying to figure out if what causes the bug and whether other people are having the same issue

As you can see from both images, there is no cell signal but WIFI is on but somehow the phone thinks airplane mode has been turned on

This is the 3rd time is past few days and i have missed loads of calls as a result.
From what i can see from my apps, there is nothing that should be causing the issue.

Also, there doesn't seem to a root cause, It has happened while i was charging the phone and while the phone had been on constant use

Any ideas?
I'm usually in low signal areas and when I move into an area where I know there is signal, it sometimes takes the device 30-60 seconds to recognize there is a signal.
This makes me think the radio polling interval is set fairly slow, perhaps in an attempt to save battery life.
I've used the airplane mode to toggle the radio and "wake it up" quicker than waiting the 60 seconds for the radio/phone to recognize the signal.

By any chance, are you in or around a low signal area when this occurs? I wonder if our two experiences might be related.
 

Luxferro

Senior Member
Nov 19, 2009
1,510
433
Long Island, NY
Not that this helps you, but the one thing I noticed from your pics is they spelled "aeroplane mode" wrong... lol

Why is your Android Build #?

I had this happen once before, but it was before I upgraded.. so not sure if that is related or was just a coincidence that it has worked fine the times I used it after updating.
 

coleburns

Senior Member
Dec 22, 2010
380
32
London
I'm usually in low signal areas and when I move into an area where I know there is signal, it sometimes takes the device 30-60 seconds to recognize there is a signal.
This makes me think the radio polling interval is set fairly slow, perhaps in an attempt to save battery life.
I've used the airplane mode to toggle the radio and "wake it up" quicker than waiting the 60 seconds for the radio/phone to recognize the signal.

By any chance, are you in or around a low signal area when this occurs? I wonder if our two experiences might be related.

Not 100% sure but this happens a lot while i am at home and the signal ain't too great. You might have a point though.

I just don't know why it won't let me switch bad.
 

coleburns

Senior Member
Dec 22, 2010
380
32
London
Not that this helps you, but the one thing I noticed from your pics is they spelled "aeroplane mode" wrong... lol

Why is your Android Build #?

I had this happen once before, but it was before I upgraded.. so not sure if that is related or was just a coincidence that it has worked fine the times I used it after updating.

Build Number: ITL41F
Baseband: 19250xxkk1

cheers All
 

lightbulb115

New member
Aug 30, 2009
3
0
This happens on my Galaxy Nexus too. I can leave the phone somewhere with a very good 3G signal and come back to find no signal and that I'm unable to toggle the radio on or off. Restarting fixes the problem.
Vodafone UK, Android 4.0.1, baseband: I9250XXKK1, Kernel:3.0.1-ga052f63 [email protected] #1, build number: ITL41F
 

psignore

New member
Jan 23, 2009
2
0
This happens to me as well. Airplane mode that doesn't turn off and slow reception, sometimes signals just goes away and doesn't come back for some minutes!!! I hope they fix those issues soon.

I9250XXKK1
Kernel:3.0.1-ga052f63 [email protected] #1, build number: ITL41F
 

Spud387

Member
Jun 23, 2011
18
1
34
Delta, BC
Do you have any apps with a radio related option/requerments ?
that might be the problem.

did any of you guy's try factory reset?
and on what firmware are you guy's?

Google or samsung?

I just did a factory reset and haven't reinstalled any apps. I'll see if the issue reoccurs.

Info
Android Version: 4.0.1
Baseband Version: I9250UGKL1
Kernal Version: 3.0.1-ga052f63
[email protected]#1
Build Number: ITL41F.I9250UGKL1
 

alanb1976

Member
Feb 20, 2010
28
0
I have had a similar issue, except that I am able to enable connection again by selecting to turn airplane mode off. I sometimes have to do this 2 times, but the phone does not freeze during this process. I have not been able to determine a cause as it happens in use and idle. This happened using stock 2.3.4 Samsung ROM (with being rooted) and with a recent flash to VillainROM 2.5. Through that I would assume it is deeply embedded bug that is being carried over with ROM's or, perhaps more likely, one of the apps I got is causing this.
 
Last edited:

coleburns

Senior Member
Dec 22, 2010
380
32
London
Do you have any apps with a radio related option/requerments ?
that might be the problem.

did any of you guy's try factory reset?
and on what firmware are you guy's?

Google or samsung?

well, my nexus experience just keeps getting weirder. the phone just restarted itself and hasn't gone past the google logo. it restarts (hear it vibrate) at that point and wont go past that screen. no idea what could have caused it as phone was right next to me and i wasn't using it

past the point of caring to be honest. i will try a factory reset when i get home tonight
 

NewMossie

Senior Member
Sep 23, 2010
65
6
I haven't had this issue since I flashed a new build of the stock rom, here:
http://android.modaco.com/topic/349407-odin-firmware-i9250xwkk9-itl41f-newest-build/

I've been using it for the past 8 hours and have had a consistent 4-5 bars. It's supposed to be a later build of the ITL41F firmware.
Unforturnately, it's got compatibility issues with most of the mods. If you flash mods on top of this, you'll lose the the status bar and the 3 buttons.

Will continue to monitor and update.
 

avesik

Member
Sep 16, 2008
29
0
Warsaw
I can confirm that the problem happens to me on a completely stock phone - no apps installed (just the ones included with the system), no root, no tampering whatsoever. It has to be a Android 4.0 and/or SGN problem.
 

JazzMozz

Senior Member
Dec 21, 2010
237
25
Here another victim of the sudden loss of signal. Toggling airplane mode on and off does solve the problem, but what worries me is that I am incommunicado in the period just prior to the moment I discover that the signal is lost.

Android 4.0.1
Baseband version: I9250XXKK1
Kernel version 3.0.1-ga052f63
[email protected] #1
Build number ITL41F
 

cassull

Member
Dec 17, 2011
17
8
I also recently encountered this issue. My phone was working fine while rooted and bootloader unlocked until today. Usually when I wake up, I check my email and I'm usually on 3G because I don't get 4G at home. Gmail had not refreshed, couldn't get on browser, had to reboot. I left my phone alone for about two hours or so, turned it on to check email and again, no signal in a place I typically get 4G. Had to reboot again to get signal. It doesn't look like my phone is going into airplane mode like some people are reporting as I don't see an airplane icon or notification.

I have not tried toggling airplane mode yet to get signal back. My phone does not run custom roms or themes, only has some root apps. I have the Verizon version.

Android Version: 4.0.2
Baseband: I515.90 V.EK05 / I515.EK02
Kernel: 3.0.8-gaaa2611 [email protected]#1
Build#: ICL53F