[Q] Amazon Fire Tv

attn1

Inactive Recognized Developer
Mar 18, 2010
2,554
1,816
0
this is supposedly boots from USB. Conceivably, you could make a USB stick that boots CWM.

Anyone know where Amazon posts it's GPL kernel source?
 

jcase

Retired Forum Moderator / Senior Recognized Develo
Feb 20, 2010
6,331
15,767
263
Sequim WA
If you look in the back there's a usb port I'm going to try using usb to usb from it to my computer...

I know this is for a thumb drive or keyboard but you never know
Yeah, try that, and if it does not work, also try plugging that port into your electrical outlet. Result will be more or less the same, but the latter is more spectacular.

P.S.: That USB port is a host.
USB Port is also used for fastboot, connecting it to your PC then powering it up will drop it into fastboot mode.
 

roligov

Senior Member
Dec 29, 2012
284
98
0
London
Bootloader isn't a problem, I've posted video of booting unsigned code. Problem is finding a root exploit I'm comfortable releasing, and getting a properly working recovery
Any chance of you helping us get a recovery working now that there is a root exploit already out?
 

DigiRay

Senior Member
Dec 15, 2007
53
8
0
Hi all

I'm hopeing someone can help me in some way with my 1st Gen FireTV.

The FireTV I had that wasn't rooted, recieved the FireOS 5.0.5 update and was working fine. I then decided to root using Kingroot and that worked fine. Reading that it installs certain bloatware, I used SuperSU-Me to replace all the Kingroot apps and have the normal SU app instead.

Everything was working fine and dandy. I blocked updates both on my router and on the device using the same command I had used previously on other devices and that was that. I did no more tinkering at all.

On Saturday I rebooted the device (pressing OK and Play on the remote) and now my device won't boot. It shows the white Amazon Logo, that disappears and then it goes to the Amazon FireTV coloured logo. That's it, it goes no further.

I have tried the Alt + Prnt Scrn + I thing, and the 1st time I tried it, it the device did flicker and reboot, but since then, it doesn't recognise the keyboard. I know it doesn't recognise it because I have plugged in a keyboard with LED's on the sides and they light up, but when pressing NUM LOCK, CAPS LOCK etc, those lights don't actually come on, and I've tried 3 different keyboards. Could the combination of changed in FireOS5.0.5?? Could my USB port of some how taken damage?

If I connect it my PC with an A-A cable, while the white Amazon logo is showing, it picks up an ADB Device for a few seconds. That disconnects and then it picks up 4 unknown devices.

Also it doesn't boot far enough in to the OS for the remote to work or have network capability.

It appears to me as if it has gotten stuck at the part where it searches for an update at bootup, but it can't as the "app" is disabled...

Any help would be very much apreciated

Thanks in advance