[Q] Android VPN settings: how to add the Port of the server?

Search This thread

lavive

Member
Dec 14, 2010
28
4
Beijing
Hi!
Does anybody know a trick on Froyo to set a port number for VPN servers?

My VPN connection requires port 443, but if I set the VPN server address with ":443" at the end, when I try to connect to it, I have "ATTENTION: server name cannot be resolved"

It looks like it only like VPN server addresses without any port i.e. it used port 80 by default. I'm really surprised it cannot be added.
I tried L2TP, PPTP and L2TP/IPSec. Same issue.

FYI: I can connect without problem to other VPN servers that use port 80.

thanks a lot for your comments.

[I'm running Froyo on HTC Desire]
 
Last edited:
  • Like
Reactions: xenonum

lavive

Member
Dec 14, 2010
28
4
Beijing
Hi!
Isn't there anybody that faced/faces this problem?
It's unbelievable that one cannot specify the port of a VPN server in Android settings!
Thanks for any tips.
 

zitomd

Member
Feb 5, 2011
8
1
Hi!
Does anybody know a trick on Froyo to set a port number for VPN servers?

My VPN connection requires port 443, but if I set the VPN server address with ":443" at the end, when I try to connect to it, I have "ATTENTION: server name cannot be resolved"

It looks like it only like VPN server addresses without any port i.e. it used port 80 by default. I'm really surprised it cannot be added.
I tried L2TP, PPTP and L2TP/IPSec. Same issue.

FYI: I can connect without problem to other VPN servers that use port 80.

thanks a lot for your comments.

[I'm running Froyo on HTC Desire]

was this ever answered? I would like to know myself-
 

DroidVPN

Senior Member
Nov 20, 2011
220
113
Manila
droidvpn.com
Hi!
Does anybody know a trick on Froyo to set a port number for VPN servers?

My VPN connection requires port 443, but if I set the VPN server address with ":443" at the end, when I try to connect to it, I have "ATTENTION: server name cannot be resolved"

It looks like it only like VPN server addresses without any port i.e. it used port 80 by default. I'm really surprised it cannot be added.
I tried L2TP, PPTP and L2TP/IPSec. Same issue.

FYI: I can connect without problem to other VPN servers that use port 80.

thanks a lot for your comments.

[I'm running Froyo on HTC Desire]
As far as i know you cannot set the port used by PPTP or L2TP.
 

Linda7463

Member
Dec 19, 2011
7
0
Isn't there anybody that faced/faces this problem?
It's unbelievable that one cannot specify the port of a VPN server in Android settings!
Thanks for any tips.
jh2.jpg

2.jpg

5.jpg
 
Last edited:

lavive

Member
Dec 14, 2010
28
4
Beijing
Hi,
Tada! I've found out how to force the use of a port number in L2TP and PPTP VPN configurations:
after you've input the server's IP address do not use ":" but just a space character before imputing the port number
e.g. 10.245.123.456 443
It also works with iOS VPN config, and of course any kind of ports which are supported by your VPN service provider's servers (443, 8000, 1194, 8292...).
Enjoy!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi!
    Does anybody know a trick on Froyo to set a port number for VPN servers?

    My VPN connection requires port 443, but if I set the VPN server address with ":443" at the end, when I try to connect to it, I have "ATTENTION: server name cannot be resolved"

    It looks like it only like VPN server addresses without any port i.e. it used port 80 by default. I'm really surprised it cannot be added.
    I tried L2TP, PPTP and L2TP/IPSec. Same issue.

    FYI: I can connect without problem to other VPN servers that use port 80.

    thanks a lot for your comments.

    [I'm running Froyo on HTC Desire]
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone