• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Bluetooth Audio Settings In Android 4.3

Search This thread

gg48gg

Member
Jan 8, 2011
32
3
Hello all. I appreciate your help on this question. I have posted this over at the CM forum as well, but it is a non CM specific Android 4.3/Gnex question, so I think it's post here is appropriate. Also, I think this is more of a general Android development type of question and seems more suited for this forum's members.

I am on 10.2-20131127-NIGHTLY-toro (Android 4.3), coming from 10.0.0 (Android 4.1). It is running pretty well for me for the last 2 days, however...

I do have some intermittent audio skipping when streaming music to my Kenwood DNX8120 headunit in my car. In the past (on Android 4.1), I have been able to resolve this by using some bluetooth audio.conf tweaks (changing /system/etc/bluetooth/audio.conf). The problem is that the bluetooth stack was completely changed since Android 4.2, and you can no longer change bluetooth settings in this way.

I understand there are some build.prop changes that I can make to accomplish the setting changes I need, but I need some help identifying which build.prop properties correspond to the audio.conf settings I need. If I recall correctly, the audio.conf settings I changed were: "Master=true", "MaxConnections=10", "SBCSources=10", the "Enable" string (see below), as well as "HFP=true" to make the A2DP stream work without skipping.

Also, I am a noob at changing build.prop and I need to know if I am even understanding it's use correctly? Will it control settings the way I think it will?

One of the build.prop settings I have learned about is called "ro.bluetooth.request.master" and I think I need to set this to "true", but I don't know the other props that I need to change.

Thanks in advance for your responses and insight.

Here is the whole audio.conf file that used to work well with my headunit on Android 4.1...

Code:
$ cat audio.conf
[General]
Enable=Sink,Control,Headset,Gateway,Source
Master=true
AutoConnect=true

[Headset]
HFP=true
MaxConnections=10
FastConnectable=false

[A2DP]
SBCSources=10
MPEG12Sources=0

[AVRCP]
InputDeviceName=AVRCP
MetaDataBlackList=Ford Audio
 
Last edited:

pro450

Member
Feb 3, 2012
5
1
Any answer?

Did you happen to come up with an answer? I just upgraded to 4.4 from 4.2 and now I have audio dropouts in my car. Up until now this never happened. It's interesting that on my phone (not a Nexus) the dropouts can be avoided if I keep the screen awake. I guess I would really like to know if there are any settings I can tweak.
 

gg48gg

Member
Jan 8, 2011
32
3
Did you happen to come up with an answer? I just upgraded to 4.4 from 4.2 and now I have audio dropouts in my car. Up until now this never happened. It's interesting that on my phone (not a Nexus) the dropouts can be avoided if I keep the screen awake. I guess I would really like to know if there are any settings I can tweak.

Nope. No one was able to help me. I've searched and researched. I know it's possible to fix, but there is no documentation out there and no one has come forward with any information. Sorry for the bad news.

I did have a moto x for a short time on kitkat, and it did skip less, but it did skip.
 

Antaroo

Senior Member
Aug 9, 2014
148
11
I know this thread is like 1.5 year old, but have any of you managed to fix that damn bluetooth thing ? Or implement the "master" setting line into bluetooth config file ?