• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] Bluetooth tether issue with 4.1.2

Search This thread

Z0l

Senior Member
Aug 22, 2010
130
22
Budapest
I'm trying to set up bluetooth tethering between a Galaxy Nexus and a Nexus 7 (both running stock 4.1.2, no root, locked bootloader). I tried rebooting both devices several times, setup pairing several times, but everytime I try to connect, I receive the following in logcat:

E/BluetoothEventLoop.cpp( 352): onPanDeviceConnectionResult: D-Bus error: org.bluez.Error.Failed (Connection refused (111))

On 4.1.1, bluetooth tethering was working with frequent disconnects. Now it's getting worse. Anybody has an idea what's going on?
 

Z0l

Senior Member
Aug 22, 2010
130
22
Budapest
Bump

Anybody having success with bluetooth tethering on 4.1.2? Perhaps its the Nexus 7 causing the prob...

Sent from my Galaxy Nexus using xda app-developers app
 

Z0l

Senior Member
Aug 22, 2010
130
22
Budapest
If you can point me towards a tutorial on how to generate those, I'd gladly post them.

It's quite easy. First, please install the Android SDK (http://developer.android.com/sdk/index.html)
After it's installed, please install platform-tools to make sure you have the adb command.
Once you have it, you have to enable USB debugging under Settings -> Development, after that connect your device via USB to the computer and issue the command "adb logcat" without the quotes. If this brings up loads of text, you're done :)

Now what you should do is prepare both devices, issue the command, touch connect, exit adb logcat by using ctrl+c and paste the output here (or look for the line mentioned in the OP).

On a sidenote, I've found a bug related to this here: http://code.google.com/p/android/issues/detail?id=38563 please star it if you also have the issue.
 

drooff

Member
Oct 2, 2012
29
48
EDIT: Removed everything as I'm an idiot. Forgot to check the "Allow Bluetooth Tethering" box after flashing to stock 4.1.2. Disregard everything I said...
 
Last edited: