• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Q] Cant Activate Wifi after Root on Xperia Z3 compact

Search This thread

jlichi

New member
Dec 3, 2014
1
0
Hello, I have looked at other post and there is no case like this yet so I hope someone can help me; really Im willing to donate to my rescuer.

I just Rooted my brand new Xperia Z3 and just after I got super SU and thought I had it all, I come across the issue that WIFI cant even be activated, neither Theterin they cant be turned on at all; it just stays off.
I have searched for hours and there ir no answer. I ran the modules.zip. and nothing. I dont think that is the problem.

For more info, I flashed Z3c_DooMLoRD_AdvStkKernel_v01_FW-105 and then UPDATE-SuperSU-v2.37.zip
Is there a way to return to stock rom?

Really, I can pay if you can help me. Thank you.
 
Last edited:

sxtester

Senior Member
Sep 11, 2014
458
163
Not sure what you did nor what might have gone wrong for you, but I would have posted over here:
http://forum.xda-developers.com/z3-...58xx-cwm-based-recovery-6-0-4-7-root-t2890231

Now, yes, you can go back to stock by flashing a stock .FTF that you can download from...
http://forum.xda-developers.com/z3-compact/general/list-stock-firmwares-d5803-d5833-t2906706
...using the latest version of FlashTool from here: http://www.flashtool.net/index.php

Tutorial (one of the many):
http://forum.xda-developers.com/xperia-z/general/tutorial-how-to-flash-stock-roms-t2240614
 
  • Like
Reactions: Rhonin86

ianwuk

Member
Sep 14, 2010
39
2
Hello, I have looked at other post and there is no case like this yet so I hope someone can help me; really Im willing to donate to my rescuer.

I just Rooted my brand new Xperia Z3 and just after I got super SU and thought I had it all, I come across the issue that WIFI cant even be activated, neither Theterin they cant be turned on at all; it just stays off.
I have searched for hours and there ir no answer. I ran the modules.zip. and nothing. I dont think that is the problem.

For more info, I flashed Z3c_DooMLoRD_AdvStkKernel_v01_FW-105 and then UPDATE-SuperSU-v2.37.zip
Is there a way to return to stock rom?

Really, I can pay if you can help me. Thank you.

Not sure what you did nor what might have gone wrong for you, but I would have posted over here:
http://forum.xda-developers.com/z3-...58xx-cwm-based-recovery-6-0-4-7-root-t2890231

Now, yes, you can go back to stock by flashing a stock .FTF that you can download from...
http://forum.xda-developers.com/z3-compact/general/list-stock-firmwares-d5803-d5833-t2906706
...using the latest version of FlashTool from here: http://www.flashtool.net/index.php

Tutorial (one of the many):
http://forum.xda-developers.com/xperia-z/general/tutorial-how-to-flash-stock-roms-t2240614

I have the same issue after flashing the same file to my Z3. Has anyone found a fix for the wifi issue and to remain rooted? Right now I am going to flash back to stock.

Thanks.

ianwuk
 

astrosp4c3

Senior Member
May 28, 2012
464
148
Moon
I have the same issue after flashing the same file to my Z3. Has anyone found a fix for the wifi issue and to remain rooted? Right now I am going to flash back to stock.

Thanks.

ianwuk

Once you install the .77 firmware via recovery you have to make another flash (dirty if you prefer) of .77 via flashtool excluding the system partition.
This way you will solve the issue.
 
  • Like
Reactions: Duv'orynn

ianwuk

Member
Sep 14, 2010
39
2
Flash a different recovery and you're good ;)

Sander, can you give us more information? What do you mean? Do you mean we flash Doomlords kernel (which gives us CWM) and then change to something like TWRP? Right now I lose wifi when I flash Doomlords file and I just flashed back to stock to confirm it is an issue and yes, wifi is working again on stock so what would you recommend?

---------- Post added at 03:44 AM ---------- Previous post was at 03:42 AM ----------

Exactly, root itself should not affect the WiFi connectivity, it's either the recovery, kernel.
I am stock, rooted and using Nutz dual recovery, no issues.

Can you give me more information on how you did this please? I have an Xperia Z3, not a Z3 Compact, will that make any difference?

Many thanks.
 

schnuff*1

Senior Member
Jan 29, 2013
171
39
Yesterday I had the same problem with wifi.
The solution fo me: downloaded another .ftf (rooted) for germany, flashed via recovery and then it works perfect.
It was not a .ftf from the threads here, the link was from a german forum,this works not for me.
 

sander151187

Senior Member
Apr 16, 2010
128
14
Boxtel
Sander, can you give us more information? What do you mean? Do you mean we flash Doomlords kernel (which gives us CWM) and then change to something like TWRP? Right now I lose wifi when I flash Doomlords file and I just flashed back to stock to confirm it is an issue and yes, wifi is working again on stock so what would you recommend?

---------- Post added at 03:44 AM ---------- Previous post was at 03:42 AM ----------



Can you give me more information on how you did this please? I have an Xperia Z3, not a Z3 Compact, will that make any difference?

Many thanks.
For me every kernel works, except the CWM kernel somewhere on this forum.
 

Gunknight

New member
Oct 13, 2017
4
0
Sander, can you give us more information? What do you mean? Do you mean we flash Doomlords kernel (which gives us CWM) and then change to something like TWRP? Right now I lose wifi when I flash Doomlords file and I just flashed back to stock to confirm it is an issue and yes, wifi is working again on stock so what would you recommend?

---------- Post added at 03:44 AM ---------- Previous post was at 03:42 AM ----------



Can you give me more information on how you did this please? I have an Xperia Z3, not a Z3 Compact, will that make any difference?

Many thanks.

sorry bumping old thread, i am also had exactly the same case and using xperia Z3, can you tell me @ianwuk how you solve this case?

i'm trying various stock ROM with various kernel and never once this wifi and tether works :(

7QfZh7tg.png

edit : adding screenshot my current firmware and recovery, flashing the .zip firmware using TWRP

Regards,

Gunknight
 
Last edited:

Gunknight

New member
Oct 13, 2017
4
0
update : i'm already wipe data cache system and reflash the .232 zip, boot it, and flash again the .232 ftf using FlashTool, the issue still persist :( please help is it my hardware problem or not thank you
 

Top Liked Posts