• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Does anyone have good Netflix playback on this tablet?

Search This thread

30Seconds

Senior Member
Jul 25, 2012
131
18
I have had a great experience with my new Xperia Z1 phone and wanted the Sony tablet as I love the form factor. My primary use is to watch video and do a few emails.

I'm pretty disappointed to find that Netflix works extremely poorly on this tablet and has constant issues with sound sync and dropped frames during playback. We have literally tried everything to improve it including a repair through PC Companion but nothing helps. It may be a wi-fi issue specific to this tablet and I am looking at that today, but it doesn't seem like something we can fix. We have a Nexus 7 and a few phones here and they all work just fine.

Does anyone have flawless Netflix playback on this tablet?
 

Spartoi

Senior Member
Jul 31, 2009
1,861
99
Pomona
I don't have any major issues but I don't use Netflix much. Sound is in sync and I don't see any frame drops after about 30 seconds of playback. I was watching The Avengers and noticed a green flicker sometimes but that's it.
 

Napoleoneg87

Member
Mar 29, 2011
11
1
LOS ANGELES
I have the exact same problems, the sound is slight un-synced and the video quality is not that good at all, i love Sony, but i really am disappointed about this.
 

twvance

Senior Member
Jan 8, 2011
159
26
Athens, Georgia
I didn't even notice it because I throw my Netflix onto my TV, but I just checked and the sound is definitely not synced up. No dropped frames here, but it's almost unwatchable with how off the sound is.

Sent from my Xperia Tablet Z
 

cantenna

Senior Member
Aug 5, 2012
2,299
553
Newcastle
Netflix works great on my xperia tablet z 321, no issues at all. I use Meow ROM and kernel on my tablet. Make sure you back up DRM keys before unlocking boot loader. Only issue with this 4.3 jb ROM is video cam record is broken, still takes pics fine. I prefer using my gs4 for video record anyways. Meow, meow, meow, meow, meow, meow, babby!:cyclops:
 

TempestDK

Member
Feb 17, 2010
37
3
I have had a great experience with my new Xperia Z1 phone and wanted the Sony tablet as I love the form factor. My primary use is to watch video and do a few emails.

I'm pretty disappointed to find that Netflix works extremely poorly on this tablet and has constant issues with sound sync and dropped frames during playback. We have literally tried everything to improve it including a repair through PC Companion but nothing helps. It may be a wi-fi issue specific to this tablet and I am looking at that today, but it doesn't seem like something we can fix. We have a Nexus 7 and a few phones here and they all work just fine.

Does anyone have flawless Netflix playback on this tablet?

I have had no issues with Netflix on this tablet, even with stock rom. I haven't noticed any sync problems or bad image quality (except maybe the first 30 seconds). Haven't mattered whether I used 3g/4g or WiFi.
 

daisy 192

New member
Dec 13, 2013
1
0
Netflix

I have had a great experience with my new Xperia Z1 phone and wanted the Sony tablet as I love the form factor. My primary use is to watch video and do a few emails.

I'm pretty disappointed to find that Netflix works extremely poorly on this tablet and has constant issues with sound sync and dropped frames during playback. We have literally tried everything to improve it including a repair through PC Companion but nothing helps. It may be a wi-fi issue specific to this tablet and I am looking at that today, but it doesn't seem like something we can fix. We have a Nexus 7 and a few phones here and they all work just fine.

Does anyone have flawless Netflix playback on this tablet?
Mine is running fantastic. I just received my Z a few days ago and absolutely love it!
Still on 4.1 though.
 

vipergrm

Senior Member
May 20, 2009
131
7
I am experiencing exactly the same problem. I wonder is it something to do with the Bravia Engine being enforced which is causing the delay whilst it performs extra processing on the image? Is there a way to turn this off? It's the only issue I have with this tablet as it is otherwise absolutely fantastic. I also use Plex and Qloud Media Player to stream from my PC and I don't get any lip sync issues with this. Netflix is unwatchable on the Tablet Z.
 

badasscat

Senior Member
Aug 11, 2009
139
14
Just got my Xperia Z Tablet yesterday, and immediately noticed this issue. Came here and I don't know if I should be happy or disappointed to see that others have the same problem. At least I'm not crazy, but neither does it seem like something I can just return my unit over and get one that works.

I had the same thought about the Bravia Engine and you can turn that off in display settings, but it didn't seem to do anything for me. I also tried turning off all sound processing; nothing works, still out of sync.

Very disappointing as Netflix is one of the big things I use a tablet for.
 

vipergrm

Senior Member
May 20, 2009
131
7
Yeah it didn't work for me neither. Very disappointing. We should expect this to be repaired with the next Tablet Z up yet but that is for certain. This is the only issue I have with the tablet

Sent from my LG-D802 using Tapatalk
 

negrobembon

Senior Member
Jul 17, 2011
3,299
452
32
panamá
I stream netflix on my tablet almost everyday and its perfect, no issues here

Running Stock 4.3

Sent from my SGP311 using Tapatalk
 

badasscat

Senior Member
Aug 11, 2009
139
14
Just upgraded to 4.3... no change.

I wonder if this is something some people just don't notice. I wouldn't say it makes Netflix unwatchable like some others, but to me it's definitely noticeable. It's about a 50ms delay between the picture and sound. Ironically my Xoom plays Netflix better than the Xperia Z.
 

negrobembon

Senior Member
Jul 17, 2011
3,299
452
32
panamá
Just upgraded to 4.3... no change.

I wonder if this is something some people just don't notice. I wouldn't say it makes Netflix unwatchable like some others, but to me it's definitely noticeable. It's about a 50ms delay between the picture and sound. Ironically my Xoom plays Netflix better than the Xperia Z.

Trust me, if those things were happening to me i WOULD notice, specially audio sync issues


Sent from my C6906 using Tapatalk
 

badasscat

Senior Member
Aug 11, 2009
139
14
Trust me, if those things were happening to me i WOULD notice, specially audio sync issues

That makes me wonder if I should try exchanging mine. You're running totally stock 4.3? I have not rooted or made any other changes to mine, just installed a few other apps that I normally install. It seems really weird that only this one app would be affected, but I guess if not everyone has this problem, it could be a batch of defective audio chips or something. The strange thing is the audio is actually *late* on mine, so it's not the picture lagging, it's the audio.

Is anyone else running totally stock 4.3 that has *no* sync issues in Netflix? Perfect sync?
 

negrobembon

Senior Member
Jul 17, 2011
3,299
452
32
panamá
That makes me wonder if I should try exchanging mine. You're running totally stock 4.3? I have not rooted or made any other changes to mine, just installed a few other apps that I normally install. It seems really weird that only this one app would be affected, but I guess if not everyone has this problem, it could be a batch of defective audio chips or something. The strange thing is the audio is actually *late* on mine, so it's not the picture lagging, it's the audio.

Is anyone else running totally stock 4.3 that has *no* sync issues in Netflix? Perfect sync?

Yeah mine is totally stock completely unmodded, perfect netflix sync, no late audio, i just used it for an hour an i had no issues

Though im curious, does locking the device mid video and then unlocking it trigger the delay? It hasnt happened on netflix but sometimes when im watching anime using MX player and i lock the device while its playing and then unlock it the audio starts to lag but it fixes itself by rewinding the video a bit

Sent from my SGP311 using Tapatalk
 

vipergrm

Senior Member
May 20, 2009
131
7
Mine is really noticeable. I'd estimate it's about 300ms out. Totally ruins watching Netflix. Plex works perfectly however

Sent from my LG-D802 using Tapatalk
 

badasscat

Senior Member
Aug 11, 2009
139
14
Though im curious, does locking the device mid video and then unlocking it trigger the delay?

No, it's just always there. I've tried starting and restarting Netflix in a bunch of different ways, including booting clean, waiting until everything's finished loading and then starting it up; closing down every single running service and then starting it; starting a video, backing out and then resuming it; starting a video and scrubbing to different points; pausing and then resuming; killing the Netflix process and then restarting Netflix; alternately turning on and off every single audio and video processing feature (by which I learned that the Bravia engine actually makes the PQ worse, but that's another issue); I mean no matter what I do, it's still out of sync. And it is the only video app that is. YouTube, Play Movies, the Sony Movies app, MX Player, etc. all play fine. It's just Netflix. It's bizarre.

I am seriously thinking about returning mine and just trying another one. (Problem is I always seem to buy tablets right before going on trips, and I need it.) Since *some* people seem to have good playback, and absolutely none of the reviews I've seen have mentioned this, I really wonder if there's not some weird defect with the ones that are affected by this problem. But it's just really strange that it's only in this one app. OTOH, it definitely does not happen on any other Android tablet I've used, so it seems like a tablet problem rather than a Netflix problem.
 

negrobembon

Senior Member
Jul 17, 2011
3,299
452
32
panamá
No, it's just always there. I've tried starting and restarting Netflix in a bunch of different ways, including booting clean, waiting until everything's finished loading and then starting it up; closing down every single running service and then starting it; starting a video, backing out and then resuming it; starting a video and scrubbing to different points; pausing and then resuming; killing the Netflix process and then restarting Netflix; alternately turning on and off every single audio and video processing feature (by which I learned that the Bravia engine actually makes the PQ worse, but that's another issue); I mean no matter what I do, it's still out of sync. And it is the only video app that is. YouTube, Play Movies, the Sony Movies app, MX Player, etc. all play fine. It's just Netflix. It's bizarre.

I am seriously thinking about returning mine and just trying another one. (Problem is I always seem to buy tablets right before going on trips, and I need it.) Since *some* people seem to have good playback, and absolutely none of the reviews I've seen have mentioned this, I really wonder if there's not some weird defect with the ones that are affected by this problem. But it's just really strange that it's only in this one app. OTOH, it definitely does not happen on any other Android tablet I've used, so it seems like a tablet problem rather than a Netflix problem.

Maybe its a problem with the netflix app itself? Maybe its conflicting with some of your settings or something and that's why only some users have the issue

Sent from my C6906 using Tapatalk
 

badasscat

Senior Member
Aug 11, 2009
139
14
Maybe its a problem with the netflix app itself? Maybe its conflicting with some of your settings or something and that's why only some users have the issue

Well, I just did a factory restore and the first thing I did was run Netflix, totally clean system. Same result - out of sync. This thing is going back to Best Buy. If the next one is the same, well, then I've gotta decide what to do... my Xoom plays Netflix better than this and it also gives me live TV (which the XTZ doesn't)...