• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Q] Editing APNs, Verizon > Metro PCS *** SOLVED ***

Search This thread

artisan_lewa

Member
May 17, 2010
39
10
*** SOLVED, see third post ***

Hello, I'm trying to use my VWZ Note 2 on MetroPCS.

I'm rooted, stock 4.4.2.

When I use the buildprop edit suggested here, my "add access point names" menu disappears entirely:
http://forums.androidcentral.com/ve...41691-mod-add-apn-editor-system-settings.html

If I remove the buildprop code, I get the menu back, but I can't edit anything.

I pushed my own version of "apns-conf.xml" to /sdcard/ and then pasted it into /system/etc/ and replaced the old one, changed permissions to read-only. Also tried read/write all permissions open.

I can now click the "+" button in the APNs screen. I can add/save APNS, but when (and only when) I have ALL of the correct APN info put in, it instantly deletes the APN I've added. Up to that point I can save the APN, see it in the APN list, and edit it further.

I restart phone, the APNs are all gone except the grayed-out "LTE - Verizon Internet". :mad:
 
Last edited:

artisan_lewa

Member
May 17, 2010
39
10
I got an app to read the APN settings from the SIM card itself (the one I'm already using on my metroPCS phone). Interestingly, these are the networks on the SIM card:

T-Mobile US
Simple
StraightTalk T-Mobile
solavei
T-Mobile LTE

Added both of the T-Mobile APNs, which did save to my access point names, but no network still.

Then I realized that I am a monumental idiot. I put the SIM back in my old metroPCS phone and got the APN settings from there. For future use, here they are:

Name: MetroPCS
APN: fast.metropcs.com
MMSC: http://metropcs.mmsmvno.com/mms/wapenc
MCC: 310
MNC: 260
APN type: default,supl,mms,hipri
APN protocol: IPv6
APN roaming protocol: IPv4

Let's try putting those in my note 2. Why the heck I didn't try this sooner is beyond me.

Still nothing, "No signal." Also, "SIM from unknown source."

EDIT: As I suspected, the APN settings weren't being saved to apns-conf.xml in system/etc/
So I pulled, edited, pushed my new version of apns-conf.xml to have the correct metro pcs settings, put it back in system/etc/, set the correct permissions (read-only for the system).
Now I have the MetroPCS access point name, it matches apns-conf.xml, but still no connection.

I think I'm about out of options.
 
Last edited:

artisan_lewa

Member
May 17, 2010
39
10
SOLVED.

If mod wants to truncate this into one post total, that's cool.

My process to get MetroPCS working on a VZW (Verizon) Note 2.

1: Root it
Name: MetroPCS
APN: fast.metropcs.com
MMSC: http://metropcs.mmsvno.com/mms/wapenc
MCC: 310
MNC: 260
APN type: default,supl,mms,hipri,*
APN protocol: IPv6

  • You'll want to have those settings both in the apns-conf.xml, and in the More Settings>Mobile Networks>Access point names
  • Activate your phone with MetroPCS.
  • Remove "Unknown SIM card" notification: Long press the notification to figure out which app is creating it (app info), then use titanium backup to uninstall it.
 
  • Like
Reactions: mattnmag

jfin79

Senior Member
Sep 26, 2010
454
99
Florida
I have read and read i am having issues now since the sim message is generated by tbe system ui i cant kill this is in the verizon note 2 when i install the sim it force closes everything any thoughts would be great.
 

artisan_lewa

Member
May 17, 2010
39
10
Ugh. Try doing a factory reset and starting over.

Make sure you use TitaniumBackup to uninstall (preferably freeze if you own pro) the app that's causing the SIM message. You must be rooted of course. Not sure why things would force close, you might have got rid of wrong system app.
 

dmarie1275

New member
Mar 5, 2015
1
0
San Jose, California
I have read and read i am having issues now since the sim message is generated by tbe system ui i cant kill this is in the verizon note 2 when i install the sim it force closes everything any thoughts would be great.

If you are rooted, install Root Explorer, open it and click on the r/w at the top , navigate to the app folder, find the setup wizard folder and delete it. Restart phone and the message will be gone!
 

Top Liked Posts