[Q] eMMC issues - how do i tell if i have a bricked Desire Z?

Search This thread


New member
Jan 5, 2012
Not sure how to start this...

first off, i'm pretty sure my phone now has a fried eMMC chip, but in reality, i don't really know...

the reason i say i think it's fried is because no matter what method i try to flash anything to my phone with...it simply won't do it...most fastboot commands will not work anymore, my computer won't load the devise anymore so no adb commands, bootloader fails everything when trying to flash a stock rom and gets hung up updating the radio_v2....i've tried running official RUU's but it keeps telling me my phone has less then 30% battery life, wich is simply false. and i can't get into my recovery without it crashing the phone and not letting me turn it back on (till battery pull).

i went onto the #g2root and #xda-devs channels on the freenode server in mIRC, and had talked to a couple people there who also think i probably fried the eMMC chip (making it impossible to write or read anything from the phone), but again...i'm really going on word of mouth rather then first hand knowledge here.

but again today, i ran into yet another possible solution and i just want to know if i should bother trying or if i have a chance.

http://forum.xda-developers.com/showthread.php?t=1314629 is the thread, but i think this is for a desire s, so i suppose my question would be...would this method still work if i just used the right files or, again, am i screwed?

i have an HTC Desire Z that i got from Bell in Canada. it has gotten an OTA firmware update, and does not have root or s-off

if i remember right, everything is still stock, completely. minus the now possibly fried eMMC chip lol

thank you in advance and i will try to edit this post as neccessary so as to update any needed info.

please ask me questions as to what i have done and i will try my best to let you know. i know i had followed probably too many guides for rooting with too many methods lol next time, xda-dev's wiki guide, and that's it!

[edit:] i just found this too...lemme know if this helps..... http://forum.xda-developers.com/showthread.php?t=1284196

[edit:] i do know that when i go into my recovery, it does say those things (e: can't mount cache, blah blah) but it crash's out and doesn't actually get me into the recovery console. if so i would be able to envoke some adb commands and just finish this, but that's adding to the issue really...not being able to get into my recovery.
Last edited:


Senior Member
Sep 20, 2008
i feel with you.
it happend for me just today morning.
got my desire z on thursday, installed usual apps.

it started to freeze in random app installations. the last softreset threw it into a boot loop with the same problems you stated above.

you can get pre formated desire z emmc's for around 30 - 40 euro i think. but soldering them on your own requires some skill and tools since their contacs are below and not on the side.

this accident threw me back to my old htc touch diamond (with windows mobile 6.1 D: )
Last edited: